Test of Android version 2.2.x
  • Zdravim,

    android 4.1.2
    navigator 2.2.27

    po aktualizacii na tuto verziu, ide hlas velmi slabo, po instalacii je oznacene len "use SCO protocol for bluetooth audio" , pomohlo mi zmenit nastavenie na  "Media"

    myslim, ze v zaklade to nieje nastavene spravne

    en(google): After updating to this version, it is very weak voice, after the installation is indicated as "use SCO protocol for Bluetooth audio" , helped me change the setting to "Media"

    I think that in basis that is not set correctly


  • 102 Comments sorted by
  • @tomas , @hvdwolf - I am in the "Other colours" but I cannot see anything for the navigation arrow.

    There are 4 choices for route highlight only

    please send me a screenshot...
  •  - you are right, default setting was incorrect
     - automatic renderer chooses HW/SW renderer depends which is faster for your device
     - functions like choosing GPS arrow colour have to be implemented in both renderers(actually noone did it in SW renderer), it is same like that projection wasnt avaible in 2.1.x versions for HW renderer

    @Joppy changelog:
    HD Traffic
     - still not ready for beta testing
    Redesigned settings
     - added POI subcategory selecting
     - redesigned vehicle profiles
     - clicking areas enlarged
    Redesigned HUD
     - bigger icons
     - one infopanel
    Map toolbar
     - added:next manoeuvre, share position, skip waypoint
     - different settings for map and navigation toolbar
     - you can modify items by holding finger on it

    HW renderer
     - click on map better link choosing
     - dynamic change of FPS
     - more details on map(visible on high DPI devices)
     - movement extrapolation
     - raster patterns support
     - second projection implemented

    Alternative routes for shortest and cheapest optimisations
    Experimental bluetooth audio support
    TTS support for more languages

    72bugs/crashes of 2.1.97 version fixed
  • Hello all,

    updated to the beta version 2.2.7 yesterday. I had to wait about 10min with faded screen until menu was availlable.

    But now program starts normal and first tests with addresses in Ireland from phone book for navigation worked well. Will make a trip tomorrow.

    BTW: Is there a change history with major points updated in this version?
  • any chance we can have the link to v2.2.7
  • @Tomas - thanks, just joined the group.
  • Quick question - where are the navigation arrow colour settings?
    Cant seem to be able to find them... and I looked everywhere...  :-)
  • settings -> Map Customisation (4th item) -> Other colours
  • Thanks Hvdwolf but this is for changing the route colour.

    I am looking for the colour settings for the navigation arrow ( triangle) - made available in v2.2
  • Weird... the fifth row is missing on my screen (and maybe also on stavrich's..)
  • I don't yet have this version, but may be you just have to move the screen a little bit upwards? I had that earlier, that part of the screen were just hidden but could be made visible ...
  • That's not the case with me.. I see only the first four rows and they take less than half the screen (in height). No big deal with me. I personally don't feel the need to change the arrow's colour.
  • Fifth row is missing on mine as well. I get 4 rows (and before anyone blames my Blackberry :)  ) on both my Blackberry Z30 and Samsung galaxy S3.

    Z30 screenshot


    Samsung Screenshot

  • This is exactly the same as my Asus Zenfone Max and also on an Archos tablet. I will try a Cubot X12 as well this evening
  • Try to change to hardware render
  • Changing to Hardware render the 5th option appears.
    Switching back to Automatic or Software render the 5th option disappears 
    Changing arrow colour while in Hardware render changes the whole arrow to the chosen colour ( whole arrow turns to one colour only)
    Changing back to Automatic or Software render the arrow reverts back to the default 2-colour.

    I think it needs to be looked at..
  • @lubos - first of all many thanks for the "change log". I would have never found or know about the "Map toolbar" changes and especially the "skip waypoint" (and I will be testing soon). 

    Publishing a brief "change log" it's beneficial to both parties - we get to know about them, test them and advise you - so... please continue =D>

    As for the arrow - it works on HW rendered but not on SW renderer

  • @tomas 

    ked si nasimulujete tuto trasu, tak cca. v mieste startu Vam navigacia zahlasi "po 500m odbocte dolava" (neskor: po 200m odbocte dolava) , odbocit vpravo nehlasi, lebo sa inak neda ist?

    when you simulate the route and the starting point you navigate reports an "after 500 meters turn left" (later: after 200 meters turn left), turn right not vote because they can not otherwise go?

  • I have had
    a small trip, navigating with version 2.2.28. When I used Wold-Miller cylindrical
    projection everything was ok, but when I used Wold-Mercator cylindrical projection,
    the navigation highlight line often disappeared for 15 seconds or so, and then
    came back again.

    Galaxy S4


  • V2.2.28

    "Save as GPX automatically " function is broken. Tracks are not automatically saved. Recording icon not displayed.

  • @tomas:
    your post from July 3 "It's there..." always appears here as the last post. That's irritating.
  • 2.2.28 with hardware renderer on Samsung S5 mini, Android 5.1.1

    I have constant crashes with 2.2.28. I'm currently on a business trip and I simply can't use Navigator. 
    If I select a destination and tap "Navigate" it crashes.
    If it doesn't crash immediately, it crashes after 3 seconds to 2 minutes.
    If I zoom in on the map and tap to select the destination (you try all kind of things), it crashes.
    I have rebooted numerous times. I did 4 trips now and not on one single trip I could use Navigator.

    I did not try software renderer because even if that one works it is not relevant: hardware renderer should simply work.

    Fortunately I have another nav app still on my phone.

  • same problem.
    OnePlus-One, Android 6.01.
    have this beta delete. back on 2.1.
  • How can I get the previous version - 2.2.27
  • On Navroad Nexo Smart (MTK MT8312 & Mali-400 MP) 2.2.28 crashes 2-3 sek after start navigation in Hardware rendering mode. In Software rendering works fine.
  • We will provide new beta version with fixes during next week.
  • I've had similar crash problems on v2.2.28. I sent the logs on Sunday & Tomas asked me to try software render. No problems with that but crashed when I set back to hardware render. I agree with hvdwolf. This should not happen.
  • Software render works fine indeed.
  • The Hardware rendering is now smooth,thanks. It seems it works without errors. Have to make a new style for bihgger house numbers, but this is not matter. in 2.1.97 i have disabled it because it crashed and it was very slow while navigation. Samsung Galaxy XCover3
    I am now tester and downloading the app with raccoon.

    Edit: The freezing while exit problem is still present
  • Hello,
    the download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.2.33+ available for testing. If you need older 2.1.97 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk

    We apology for problems with version 2.2.28 we underestimated alpha testing in that version.
    Version 2.2.33 will be avaible on Google Play Beta in few hours.

    Changelog 2.2.33:
    -auto gps recording fixed (thanks @stavrich)
    -crash on like/dislike on android5 fixed
    -default sound output channel fixed (thanks @Durko)
    -download summary screen fixed
    -HD traffic disabled by default
    -HW renderer crashes fixed
    -HW renderer POI icons in 3D fixed
    -HW renderer selecting waypoint fixed
    -HW renderer sky in 3D better
    -map colours dialog fixed
    -night mode fixed
    -translations persian-fa, pl, pt-BR, tr
  • I had some problems on android 4.4.2 and 5.0.1 with using contacts app contact.
    Is there a chance to improve the target display? The device was connected to a wlan but had no internet access.
  • @Lubos - great work - well done!

    Please note the option to change navigation arrow colour still not available on Software renderer.
  • Hello,
    I tested the TCP-Commands in 2.1.97, 2.2.28 and 2.2.33.
    The command "$navigation_statistics" did not work as described in the manual.
    The result should like this "1800,120,1800,120" in meters and seconds.
    But what i get is: "1.8,00:02:16,1.8,00:02" or "464,00:00:35,464,< 00:01" if distance is less than 500m and time less than 1min.
    It seems that result is a copy of the stings in the info-panel.
    The PC version works as expected.
  • It should be possible to disable the Testing of integrity of data. I removed all data and copied new data in that folder from pc and navigator try testing integrity again without any reason. Only starting without data and close and copy backup data again solve the annoying problem. I was on a big tour and changed from hw renderer to sw renderer and after this navigator want testing the integrity from the half world. No Navigation System anymore on a strange place without a reason. This testing need hours.

    The HW renderer works not properly, when Zoom 100% i can only move the map vertically or horizontal but not 45 degrees over the screen. And the map stop not when i stop the finger, this i dont like. It seems the moving is to heavy for my Galaxy Xcover3, also in 2.2.33. Its a little bit smoother, but it need more time for showing house numbers and sometimes it stuck.
  • Hardware render problems in v.2.2.33 seem to be solved. I have noticed that when you tough the screen the menu that used to appear on the right of the screen (departure, waypoint, destination etc.) now appears on the bottom. The information option is no longer present in that menu.
  • @jd417
    The buttons are now customisable. Choose a button you want to replace with the information button, then press long on it.
  • I had a trip, 350 km using version 2.2.33, Hardware render, World Mercator cylindrical projection. Everything went well. Nice work.
  • @tvo: Not as criticism, but purely out of curiosity: Why do you mention the projection? 
    On low zoomlevels, looking from "high above" there is of course a big difference between Miller and Mercator. However when you are on a totally zoomed-in level during navigation I don't see differences. Do you?
  • He mentioned the projection because it seemed to make a difference with HW renderer

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.2.35+

    -HD traffic - many fixes(still not ready for testing)
    -HW renderer - click on map speed up
    -HW renderer - adding waypoint from map speed up
    -HW renderer - movement extrapolation fixed (thanks @Matthias)
    -map toolbar - info instead of share as default (thanks @jd417)
    -navigation_statistics tcpip command redesigned according to manual (thanks @hknk1)
    -settings - screen orientation locking added into advanced
    -translations - cz,nl,ro,sl

    @blubb - Without internet we are not able to convert address to coordinates so it cannot work
    @Matthias - Navigator creates during restart engines navigator.lock in navigator folder, if you kill navigator and delete this file then it loads normaly. Problem with moving was that it was calculated in pixels, I changed calculation to DPI and it seems it works well now.

    Mercator projection is new in HW renderer and because of this projection there is need to load more data than in Miller projection. We are glad that someone is testing it, thank you.
  • @hvdwolf, yes  @IU0BMP tells the reason. I tested Mercator projection, because it is new for HW rendere, and we are beta testers. By the way, there are small differences between Miller and Mercator projection during navigation. The roundabouts are more circular for Mercado compared with Miller, but of course this is not a big issue for me.
  • I am not sure but has the sound output been reduced on both Bluetooth and smartphone with the last 2 versions? I am more concerned with the bluetooth output in my motorcycle helmet.

    I dont think is as loud as it used to be.

    Has anybody else noticed any difference.
  • Bluetooth volume was too low for me since the very beginning -only for TTS, not recorded voice . I didn't notice any changes since then.
  • hello all, version 2.2.38
    application language / system default = eng (system phone SK)

    change sk / cz still language eng

  • Same here with german menu-language under 2.2.38. I lost my default settings and can't get german menu back.
  • @hurdygurdyman

    What do you mean with, you lost your default settings? Apart from the incorrect application language, I could not find anything like that.

    The only thing I found: As Navigation voice, I previously had set up Voice engine = Record voices, Voice language = German (Doris). Doris died .... er, is not selected anymore; there is simply nothing now, and I cannot choose anything here, probably because I have to download voices first ....?
  • I see the same problem as @hurdygurdyman "Application language" is always English no matter what language I choose.
  • It's just the menu-language (application). I didn't check routing advices, cause I just planned a new route.
    Checked navigation voice with route simulation. It's German as set.
  • I can confirm as well. Application language is always english.
    Navigation instructions are in the correct, chosen TTS language.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion