A tutorial on POI
  • I decided to try your app, so I downloaded from Play on my Note 8 tablet.

    The first obstacle I found is the POI management.
    The navigator is important for me cause I have a CNG car, then I may need to find a methane station near my road.

    I'm partecipating in a community (www.metanoauto.com) where the POIs are downloadable, so I retrieved the last version of all Europe gas station in csv format.

    Using diggerqt I prepared the file to be used , then I copied it in the data directory in the tablet.

    After that, I tried to used them, but the list seems empty
    Do you have a step to step tutorial, with pictures, on how to prepare a POI list and how to install/use it?

    I can supply the file I prepared, if needed
  • 29 Comments sorted by
  • there is no manual
    you probably did not select what to see on map

  • Can you search your own POIs?
    You do that from the POI screen, but you do not use the normal search, but the imports search. In that screen you simply select the imported POI file, type (part of) the name of the gas station.

    And as Tomas mentioned: You need to switch on the POI category
  • The fact is that my POI file seems empty, while I'm sure I did all exactly as said in the manual.

    Here is the link to the poi

    Is it possible for you tell me where I did wrong?
  • The POI file is not correct indeed. It even makes my Navigator hang if I try to search. It doesn't show POIs on the map either. Which manual did you follow?

    I have seen that you need to register at that website, which I don't want to do, but can you share a small part of your POI file which you used to make the mca?
  • Same for this one: http://forum2.touring24.info/wbb3/index.php?page=Thread&postID=36880#post36880

    I wrote one for myself in english but can't find it at the moment.
  • That ov2 file is not correct. I can't open it in any converter. Some open it and show nothing. Others simply can't open it. The csv is the same ov2.
  • That'sstrange.
    I used the csv in Tyre and converted it to ov2 with poiedit 2007.
    The only thing I did is the convertion in utf8 with notepad++
    I'm going to download it again and sharing it with you without any convertion.

    But.. why we have to use a proprietary format? Why not use a csv?
  • csv is perfect. You can see what's in and what should possibly be modified.
    What I meant that your link was the same ov2 file and not the csv file.
  • Have you checked the csv-file :
    Examples :
    "PL-POZNAŃ GŁOGOWSKA 429 >+48618390627 F 00-24   PF 6-14   FS Chiuso   CC 00-24   CNG AUTO CARD"
    "PL-WAŁBRZYCH UL. LUDOWA 1D >+48746663340 F-PF-FS 00-24"

    should be ( according to metanoauto.com) :
  • I had similar problems when trying to import a (different) csv-file. I don't know if it is the solution for you, but I could fix it the following way:

    1. Special characters in the csv-file caused invalid mca files. I open the csv-file in Excel and saved it as .xls. Then, I used the Excel driver of digger to import the xls-file, which worked fine with special characters.

    2. Table cells with descriptions containing more then 255 characters resulted in unusable mca-files. Looking at your csv-file that might be a problem for you. I used a script to restrict all cells to 255 characters.
  • I can easily create an mca with icons displaying the stations, but searching through the texts still doesn't work. There must be something incorrect in the strings.
  • Well, I suppose the problem maybe those strange letters you have in eastern languages.

    I understand the historical roots, but also French and German decided to stop using ae and that beta sign that sounds like a double ss (even if a lot of people still use them..)

    I'm starting from scratch, looking on those nations one by one.
    But I have to underline that Tyre accepted gracefully the same file..

  • Hi,

    See this zip on mega
  • @hvdwolf : ... converting to ASCII is not a good idea, as this will garble the records !
    Examples :
    "PL-POZNA GOGOWSKA 429 ..."

    .. should be :

  • I know that converting to ASCII is a bad option, but if the only other option is to remove the records as DiggerQT can't handle them, then it is better to have a garbled, partially readable record then no record at all. What's more: Even with a garbled record you can at least see where the icon is on the map with the coordinates. This means that you can navigate to it. If you have to remove the record you have nothing at all.
    I have been thinking to do a sed search&replace for the characters like Č to C, but that's up to others and you still don't have the correct address.

    Anyone else can modify the strings by hand just as long until the characters are excepted by the diggerQT engine.
  • (btw)
    I tested files downloaded from poiplaza, and *.GPX has one POI more than *.CSV, so if You have the possibility, download POI as GPX (Garmin gpx).
  • I tried the gpx way, but digger did not liked my file...
  • --->>> select data source type -->> GPS Exchange Driver (GPX).

  • I know, but Digger did not liked that file
    Would you like to try it?
  • Connection failed!

    ...but try download file from poiplaza, garmin gpx, and is o.k., so check Your file, or try convert gpx to gpx???

    PoiEdit -> Tools -> Batch convert -> dest format TomTom Binary ov2 -> DiggerQT: 2967 records.
    csv -> DiggerQT: 2965 records.
    ... there is still sth wrong - Don't You want to change fuel to LPG? Look at STAG.
  • I've tried with Poiedit 2007, unsuccessfully.

    I give up..  will buy an old TomTom (new ones does not support ITN files..)

    Thanks to everyone for the help
  • I loaded MiG's file to routeconverter.exe and exported it from there to gpx.

    While the original gpx file did not connect to digger, the exportet gpx did.

    So I could create a .mca file. I could find stations now in PC Navigator.

    Yould should find both files here for a while: < deleted because problem is solved , see below>

  • Yes, it works!

    The last issue is this 'east' letters: łąśćńóęźż (<---there are letters).
  • You were great!

    Now mapfactor start be be usable.. ;-)
    Now I only have to learn how to create ITiNerary..
  • p.s. my colleague confirmed that the problem was with encoding of the original GPX file
    was (first line)
    <?xml version="1.0" encoding="ISO-8859-1"?>
    and only supported (by Digger) encoding is UTF8:
    <?xml version="1.0" encoding="utf-8"?>

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion