Android FAQ
  • 147 Comments sorted by
  • Veeru, did you already try the 3D mode? The streets are displayed bigger, then.
  • andyneouk
    could you please give exact departure and destination?
  • hi, i'm italian so i'm sorry for my poor english.

    i have a question about mapfactor navigator on android 4.3 (gnex device)

    i cant see where i am during the navigation, the phone show me always black back hereimage

  • This is name of the road where you should turn ... are you sure that that particular road has name? Version 1.0.34+ (available as beta) should improve itinerary info on small links without name. You can download it here:
  • yep, the name of the road is written directy on the map.
    i used the navigator for an hour in milan and i saw only black back and on the left the three small horizontal lines to open the menu.

    i will try the new version thank you!
  • so sorry, triple post for this error  with chrome "String could not be parsed as XML"

    dunno why
  • I see how to use the Maps, the app seems very nice and combined with the windows app it seems even better to have a dispatcher find and direct our Itinerary. However, Currently I can on search and find cross streets. How do I find a specific address?
  • when street numbers are available in the map data then you can
    search for it, for example New York/Manhattan/5th Avenue.
    Unfortunately house numbers are frequently missing in free maps, but
    are available in TomTom maps.

    Free maps are created by volunteers at
    - anybody can join and help to make maps better using their local

    Having said this, we do have a built-in Google search,
    fourth tab in Search.

  • Hello...pls somebody help me. I purchased a map in this mapfactor app for 14 plus euros 3 days ago. But everytime i use it, it says "NAVIGATOR HAS STOPPED". I send email to the seller but i havent received any comment....pls somebody help me...
  • The sellers email is really need help mow pls
  • Question:
    I got a kindle fire hd (android)
    It has no built-in gps: can I use an external gps device connected using bluetooth?

  • Don't know about the kindle, but on my android phone I can use a bluetooth gps. What I needed to make it work was the app "Bluetooth GPS Provider"

  • Hi there,


    Thank you for the app. Unfortunately I do have a problem with it and I need your help. I installed the app from Play Store and downloaded the maps (free version) on the sd card. When try to run the app it says that the maps are not downloaded, which is incorrect. What should I do in this case?

    I would appreciate your time and help.


  • Hi,

    I reaaally love your application for android. For me it's the without any doubt the best one. And the most of all, for free !
    I like it so much that I decided to donate. For others: Don't hesitate to do the same !

    Now what could make this app even more perfect would be a link / view / taking care of the traffic situation. Like Google Maps or others apps.
    Is there any way to have that in future ?
    I'm not a programmer in my job, but I have "some" skills, and I can engage myself to help or try to do it if you want to !

    Thanks !
  • While downloading mapfactor apk on my MOTO G (android 4.4.2) my screen goes white midway, y is it so? i m fedup of downloading again and again because of this problem. Whts the solution.
  • try to set direct download in settings/advanced
  • During the update of a map the telephone crashed and after restarting it the app crashed every time I tried to run it. The reinstalling didn't help. Also I don't know how to send logs because clicking on the link makes me download an apk file, with which I don't know what to do. I use Android 4.1.2
  • close Navigator and delete data in Android settings/application
    manager/Navigator - then reboot your phone. If this does not help,
    please email logs (navigator/log folder).
    logs are files, just attache them to email
  • Deleting the files did help. Although FYI - maybe I'm thick but I can't find a single contact e-mail on your website.
  • Hello,

    I am a osm contributor and I use osmand on android and now I try your navigator for android

    I have 2 request

    The first I wrote on the market ; svp modifier le positionnement 5° 15' 52 '' en 5.287654 (exemple) qui est le plus utilisé de nos jours, merci

    And the second ; could you minimize the automatic zoom in high speed to see the road in more km and towns earlier.

    For the fun I love Praha but I live in south France so my English is not very good
  • >>>For the fun I love Praha but I live in south France so my English is not very good

    Still better than anyone from Detroit.
  • Hi,
    I've been using your Navigator on my Samsung Galaxy 4 for a couple of months until recently when Google started stopping it during downloading map updates, especially big map updates like the Germany ones.
    Then during the last map update I got the message “Checksum error” and Google stopped the application, so it won’t start again, even after uninstalling and reinstalling it.
    I had to uninstall the app and manually delete the folders left, so preventing Google’s from stopping the application.
    Now after a new installation, I’ve unchecked “Use google analytics” and hope Google won’t interfere with the application again.

    Also have a suggestion regarding the font size on the menu bar where the buttons “Settings”, “Map manager” and “Exit“ are located.
    Could you please make those fonts bigger? They are extremely small and difficult to read when you are driving having the phone placed onto the car’s dashboard.
    I would be willing to donate if you could fix the above-mentioned issues.

    Thank you in advance for providing us with such a nice application for free.
  • The directory where you have to copy your user created POI (.mca files) is
    This is also where the map files are. Copying to /Navigator/data doesn't work.
  • Hi,
    I have been using the Navigator with TomTom maps for a while now and I am really happy with it. Now I have bought a new smartphone and of course I would like to use the Navigator on that phone. Is there any way to safely transfer the map files I have bought from the old phone to the new one? I have tried to redownload, but it seems like it is only possible to purchase them again :-(
  • Hi Lars,
    go to settings and click Send logs (new device)
    please type your order ID
  • Hi
    I originally connected my Nexus 5 to the "Aux" socket on my car using a generic H166 bluetooth receiver without a problem.
    As the receiver had only a 4 hour battery life it was stopping before my days drive was finished - not good.
    Decided to upgrade to an Avantree TC200 bluetooth receiver because it has a 9 hour battery life - then my problems began.
    Now the initial 1.5 seconds of a Navigator bluetooth audio message is missing, but using a cable is perfect.
    I took up this issue with Avantree support who tell me that the output fromn Navigator is in mono and not compatible with the TC200 which is stereo.  Are they correct? or have you any other explanation for the missing audio ?

  • Yes, they are correct. As long as Navigator uses mono you should use something like Mono Bluetooth router or an app from the same category.
    I use mono bluetooth router but please try others so see what works best for you.

    it's not only mono though. It also depends which one of three android audio output modes is used.
  • Hi hvdwolf
    Thank you for your reply.
    I have tried "Mono Bluetooth Router" app but am unable to get it to connect to any of the three devices in my possession.  (Avantree TC200, Generic H166C and SW100 bluetooth speaker/hands free).
    Have you any names of the other apps as non I can see on Play Store seem to be relevant?

    You also mention three audio outputs - I am aware of Media and Phone what is the other.

    Avantree support have been helpful and are allowing me to test one of their "Cara II" devices. 
    I will update this comment in 7 days after item received and tested.


  • Hi,

    In Play search on "bluetooth router" or "bluetooth car".
    you will find a few others
  • I have the MapFactor Free Navigator app on my phone (Samsung Galaxy Centura) and receive notifications to update the maps I have downloaded.  I typically use my phone to update the maps, but the last 3 or 4 updates, the update never loads.  It shows the screen with the first map name (e.g. USA OSM/USA Alabama OSM and the status bar for the download's progress, but nothing actually ever happens.  An hour or so later, I click "Cancel data download" and try again, but the same thing happens.  I try turning my phone off, then turning it back on and trying it again, still nothing.  I've uninstalled the app & reinstalled it, but still, nothing.  The only work-around I've found is to delete the exising maps off my SD card, then re-installing them all from scratch.  I really like this app, but it's becoming cumbersome to maintain.  Please help!  Thanks!
  • try to switch to direct download in settings/advanced
  • Hi, paid for TOM TOM truck maps it would be nice if we could enable POI like low bridges etc and routing a bit off when run next to tomtom or sygic satnav.
    And the app makes some weird sounds or warning sounds but I dont know what warning its telling me?

    Good app but needs improving
  • Take it thats a NO then so I can see on map where low bridges etc are.
  • at this moment you cannot see it, but it is taken in to calculation of routes
  • Hi,

    I have a LG P710 with Android 4.4.2.
    Navigator correctly detects the SD card; creates its own directory in /storage/external_SD/Android/Data ; downloads maps and stuff to the SD and seems to work fine, but after the first phone reboot, when I open the app, I get something like "The Navigator folder is set as read-only. This may happen because the device has been updated to Android 4.4 or later"
    Why does it lose writing rights on its directory? AFAIK about the new Kitkat policies, this shouldn't happen...
  • App won't run after paying for the maps. Said app is set to read only.

    I have a Samsung tab 4, 7 inch.

    What must I do to fix this.
  • close Navigator and delete data in Android settings/application
    manager/Navigator - then reboot your phone. If this does not help,
    please email logs (navigator/log folder).
  • I'll try that, but before I have some news: Yesterday the app misteriously ran fine without deleting or reinstalling anything, and then it didn't work again after reboot. Very odd. Could it be some conflict with apps running in background or what?
    Thanks for your attention ;-)
  • most probably slow SD
    try to click on the message several times
  • Problem is apparently solved! I put the app back in the internal memory (not, data the actual app, which I had moved to the SD) and it runs fine now (tried rebooting several times). Strange, I'd swear I had already tried that before, but what's important is that it works
  • Problem: good GPS navigation when driving slowly (20 mph), bad navigation when driving faster (40 mph and above).

    Details: I bought a phone with Android 4.2.2 (model MINI M1 by an original Chinese manufacturer, the CPU is Dual Core, MTK6572 ARMv7 @ 1.3GHZ). The Explorer software works fine and all features are OK (in fact they are great!), however as the speed of the vehicle increases the number of satellites used decreases, hence the accuracy of location decreases (the current location starts jumping left and right of the street onto other neighbouring streets) and eventually at 40 mph the number of satellites gets to zero, hence no navigation possible. This usually starts at speed 30 mph and by 40 mph the navigation stops and the software behaves as if frozen (it is not frozen, it just appears to be). Now please note the following: I investigated this issue and IT IS NOT some poor GPS sensitivity (i.e. it is not poor GPS sensitivity at higher speed or Doppler effect, etc.), rather it appears to be the high processor load by the Explorer when the road situation starts changing faster as the vehicle speed increases. For example, if I use a light-weight application, such as "GPS Essentials", the number of satellites used remains at all times and all speeds very high, at least 7-8, along the same route. The accuracy of the fix is also displayed as very good 8m-10m. However, after closing "GPS Essentials" and starting Explorer the number of satellites starts changing with the speed -- initially they are 7-8 at 20 mph then they go down to 4 at 30 mph and by 40 mph they are zero and Explorer appears frozen because. If at this moment I close Explorer and start "GPS Essentials" it shows the number of satellites to be 7-8 and the accuracy to be 8m-10m and it dynamically shows correctly the current instant speed and the current travelled distance with very good accuracy (therefore it is indeed receiving GPS data from the GPS receiver with correct and accurate coordinates).So it appears that on my device when running a light-weight application the GPS data is correct at all times, but when running Explorer the GPS data is correct only at low speeds.


    1) Have you come across anything similar at all? Do you know of any like remedy (short of buying a different phone)? I took a detailed look at the Explorer settings and have disabled auto-zoom and 3D display and will try it now to see if this would make any difference on the processor load)

    2) What exactly is the Advanced Setting called in Explorer "NMEA Encoder" and could it help in my case (however I am not recording the track)? Is this purely and solely related to recording the route and not to obtaining the fix? (I.e. not related to the way GPS fixes are obtained or calculated during navigation, etc.)

    3) What further debugging can I do with Explorer?

    Thank you very much for your time and help!

    Kind regards,
    The Resistor

  • Hi Resistor,
    I will answer 1)
    GPS is controlled by Android, Navigator cannot make GPS reception better or worse.
    Try to reboot your device, it quite often helps.
  • Hello Tomas,

    Thanks for you prompt reply -- this is much appreciated.

    Regarding your answer to question (1): I take your answer to be that you have not come across anything similar in the past, right?

    Also, about your advice to reboot the device: I indeed had done this, multiple times before writing here (proper Android reboot). Sadly this made no difference and the problem persisted.

    Could you help with question (2) and shed some light on what they mean by "encoder" and in which function is it used? E.g. is it used only when recording a track, or is it used for navigation?

    Finally, I have a new question (4): there is a setting in Explorer which allows the user to choose the map projection (with two options: Mercator and Miller). What is the intent for this setting and also, is this a question of real free choice, or is it a question of knowing in what projection the given map is? Does it have any bearing on the processor load?

    Thanks again for your help and time -- this is very kind.

  • I had to reset may tablet do to bad GAS reception, after installing the app I can not load Tom Tom commercial maps any more, getting error message (invalid key). I used your build in option with email and order ID and got no answer, the SD card containing the files and maps suffered no changes. Pleas this is urgent, I am a truck driver and this is my primary navigation system. 

    Thank you for your help. 
  • Thank you for the prompt reply. The map loaded now but I have a problem with scaling. I made the usual settings but the map is out off scale, road, text and icons been to small, If I resize the road from setings it becomes unreadable. Map dose not scale to the correct size of my screen.

    Thank you kindly for your help.
  • 1. I have not heard this before
    2. this is not question I can answer, may be someone else
    4. projection is used to display map - it may look different if you change projection, especially in high zoom

  • Hello
    I generaly like your app but, in nav mode, I don't like the time to "refresh" the map on the screen which is around 1 seconde (I have the same behavior on my actual phone LG G2 - Android 4.4.2 than my old one Galaxy S - Android 2.3.6). At the opposit, it's smooth on Google Nav.
    Are there some settings to improve ?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion