MapFactor crashed while downloading maps, now unable to download maps due to lack of space
  • Device: HTC Evo 4G.  Android phone running Ice Cream Sandwich.  Has an internal 32GB memory card.
    Scenario: Was downloading maps when MapFactor (MF) crashed.  Attempted to restart MF but it reported no maps.  Selected add maps, but it reported there was only 3MB of space.  Rebooted phone, still had same error.  Uninstalled it and reinstalled it.  Same error. Uninstalled MF, deleted data and navigator folders on SD card, Installed again, same error. It sees the SD card because I can go into Settings/Apps and move the executable to the SD card, but for some reason the download maps function does not.
    I have other OSD apps that still see the maps they loaded on the SD card and allow me to download more maps without a problem.
  • 7 Comments sorted by
  • try to delete data in Android settings/application manager/navigator

  • I don't see that path anywhere.  On the SD card I have Android/data/com.mapfactor.navigator/files. The files folder is empty, but I deleted the path com.mapfactor.navigator/files without any change.   I also deleted the navigator folder, which was in the root.
    In the ICS OS, I went into settings/Apps and deleted the Navigator app.  No application manager path was shown.
    I am accessing the SD card with both my PC via the USB connection, and with ES File Explorer, an Android app.
    I just checked the other OSM apps, which are Navfree and OsmAnd.  With the USB not sharing the SD card, there are files in both the Navfree and the OsmAnd apps.  The Navigator folder, however, is empty.  I suspect this is the root of the issue, MF is apparently placing its application files in a different folder, which is confusing the Maps function.
    I just tried erasing the SD card, but the same issue still exists.  And now I have to reload the other OSM apps.  But they do see the SD card as a valid storage location.
    This is a fresh, non-activated phone, so I don't mind experimenting, as long as the result is a functioning MF app.
  • What tomas meant, was to go into your Android app manager (Settings --> Apps). Choose app MapFactor Navigator, then "Delete data".
  • Thanks for the clarification.  That was one of the first things I tried, as well as deleting the cache.  To no avail, unfortunately.
    I really like this app, so this is quite unfortunate.
  • maps may be in navigator/data i could be on SD or internal memory

  • On this particular phone the maps must go on the SD card because it only has 1GB of internal flash memory.  It does sound, however, that MF is trying to put the maps on internal flash memory, which will fail every time.
    Even if there was some way to track down and change where it is trying to put the maps I can try it.
  • to move Navigator to SD go to Settings/advanced

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion