Suddenly Navigator not seeing sd card
  • Android 4.2.1 Asus tablet. Latest Navigator. Was working fine. Then error message on opening saying something about can no longer see sd card because upgraded - which it most definitely has not - I checked! Now won't see sd card tho other apps do ok. Re-installed Navigator on internal mem after uninstalling first but still won't recognise sd card. Reinstalled version is obviously missing all data I had previousl entered and d/l to sd. Tried installing apk suggested by tomas in another post for something similar, no change.

    Thanks for any help and for app.
  • 5 Comments sorted by
  • try to delete data in Android settings/application manager/Navigator - then reboot
  • Hi tomas
    Thanks. Tried that. Also deleted Cache. Still not seeing sd card. It used to see it.
  • uninstall and reinstall?
  • Check whether your SD card is seen by your file manager. Really check the contents of your SDcard folders as Android immediately creates default folders on in internal memory if your SDcard is corrupt, which means that it only looks like your SDcard is still there (als check total size versus available space).
    I had that twice.
    If so: repair your SD-card on some pc by doing a disk check.
    If that doesn't work: format it.
  • Thanks. Useful info.
    File manager is seeing sd card as I can open docs and music files from it ok. Sizes look ok. Just Navigator unable to move files to it as says I've only got one sd card. Could move maps etc before. Weird.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion