Navigator.exe missing
  • Hi there,
    I am trying to install the mapfactor navigator sw onto a SD car (to be used on a WinCE device).
    Everything seems to go fine but at the end of the process I am not able to find the navigator.exe file anywhere... I see all the other file types like .xml, .dll, .map etc etc... but the executable is missing and my WinCE device looks for it to start the program.
    anyone else has faced this issue?


  • 21 Comments sorted by
  • it could be in internal storage,depends where you installed it
  • I did the installation on a SD card using the"navigator 12 setup utility", so there is no internal storage involved... and I am not able to find the navigator.exe anywhere in the SD card.
  • please check that path is correct in your device settings
  • what path are your referring to?
    Maybe I was not very clear in my explanation: I used my PC (Win7) to install the navigator software on a SD card that I want to use on a WinCE device.
    I can see on my SD card the navigator software installed, I have also (successfully) loaded a map on it... so I guess the path is correct, but on the SD card there is no trace of the .exe file so I dont know how to have the navigator running on my WinCE device.
  • yes, but can you configure path on your device? it may be pointing to your old software
  • Here a instruction that I found in this forum for a WinCE device:

    "Thanks to Navigator Free, I was able to give a second live to my old Viamichelin X-970T GPS!
    Viamichelin stoped manufacturing GPS some years ago, and you cannot update the maps anymore.
    Hopefully I was able to install Navigator Free on it, and I now have a brand new GPS with maps from all over the
    world for free!
    To install Navigator Free on the VM X-970T:
    - On an empty SD card - this way you keep the original card just in case... - (I recommand a 2 Go card), create a
    "InstallSD" folder
    - Download Navigator Free set-up utility
    - With the set-up utility, install Navigator Free on the SD card in the InstallSD folder: choose "Install the software"
    / "Install Pocket Navigator" / "Windows CE device" (the VM 970 runs on Windows CE 5)
    - Still with the set-up utility, install the maps you wish in the same folder: choose "Install Data", and install the
    language too.
    - In the InstallSD folder, rename "Navigator.exe" to "InstallSD.exe"
    There are some missing Dlls on the Viamichelin that you need to install too. Here is the list:
    coredll.dll, ole32.dll, oleaut32.dll, shlwapi.dll, wininet.dll, ws2.dll, zlib.dll
    Type "download coredll.dll, ole32.dll, oleaut32.dll, shlwapi.dll, wininet.dll, ws2.dll, zlib.dll" on google
    Copy the Dlls on the SD card, still in the same folder.
    Insert the SD card in the GPS and perform a soft reset (insert a paperclip in the back)."
  • anddo you have VM X-970T?
  • Hello guys first of all thanks for your time.
    I don't have a X-970-T, I have an Eonon WinCE device on my car and when I change the navigation path on it (I am able to do it) it looks for any .exe file... but after the installation (that I do with my PC directly into the SD card) I cannot see any .exe file.
    Here you can see a screenshot of what I see on my SD card after the installation:

    I have tried with different SD cards/USB sticks and also to install it on a local path on my HDD but the result is always the same

  • If you download CE-version with "setup utility" don't choose "setup the program". There should be a folder "Navigator" on your PC with a folder "Install" within it containing a zip-file "pnd_app". This file unpack in a folder "Navigator" on your sd-card and there should be then also the .exe file.
  • I have a folder named Navigato12 on my PC, but I cannot find any "Install" dir or "pnd_app" file...
    Is there a place where I can download it?
    Or, I can give you my ftp details if you have the chance to upload it
  • "Install" should be a subfolder in your folder Navigato 12 as well as folder "Data" containing the Navigator maps etc. and "Setup" and "Help". Don't choose the option "Setup the program" after download the progamm with "Setup utility" and you should have the "" in folder "Install". Probably you should uninstall everything and reinstall setup utility.

  • in Setup utilities select install Application/Pocket navigator/CE device/memory card
    then select location
  • OK I have uninstalled the Navigator sw and then:

    1. downloaded again the NavigatorFree_install.exe file form here:

    2. Installed the program again

    3. Chosen a free license key

    Program seems to be installed properly

    4. chosen the local folder on my PC

    5. software says it's downloading from the server

    6. installation complete

    Good news is that now I can see the folder "Install" on my PC with the "pnd_app.rar" file.

    Bad news is that when I open the file it says "unexpected end of the archive"... it opens the file anyway but inside I don't have any .exe file: I see (more or less) the same files I see on the SD card after the installation...

  • 1. install setup utility
    2. run setup utility
    3. install application
    4. install pocket navigator
    5. windows ce device
    6. install to memory card
    7. choose location

    there is no rar file

  • I do all the steps you say but at the end of the procedure I don't have the navigator.exe file (on the SD card) which I need to have the Nav running on my WinCE device.
    The rar file is located in the PC directory that I choose when I install the setup utility on my PC and it sounded a good idea to look there for my missing .exe file... But I still cannot find it...
  • wel, I do, I cannot imagine what are you doing incorrectly

  • Hi!
    Maybe it is hidden - check Your Explorer and its options.

    ... or use Total Commander.
  • my PC is set to show all the hidden files... and it's not there...
    I don't know what to do...
    Can anybody send me the .exe file? Is there any chance to have the navigator working if I copy/paste the .exe file from another installation?
  • Might be also a problem with your antivirus program or Win-OS security settings not let you download a .exe file. The "pnd_app.rar" has 6.976 kb.
  • nice clue.
    I am now trying with a different PC, in case it won't work I'll try to disable all the AntiVirus sw and Win security settings.
    I let you know
  • It worked!
    Trying on a different PC I can see all the installation files on my SD card including the bloody navigator.exe!
    Thanks for the support guys!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion