Starting from contacts Navigator says: Failed to add a routing point....
  • You may have entered the routing point in a coutry which you have not downloaded yet.
    I use Navigator free with free osm maps.
    I use Navigator Free with free osm maps in germany and the maps are already installed.
    Some days before it has worked well.
    Then I have changed the maps from device storage to sd card.
    I have used the function in Navigator for this.
    Anybody can help me to get this nice fuction back?

    Thank yo Uwe

  • 3 Comments sorted by
  • Tomas,
    Wow, thank you for your fast answer.
    Yes, now it works well again.
    It`s such a nice feature.
    Thank you for this perfect help.

    happy, happy happy ....

  • For anyone else landing on this thread looking to solve this problem, try the following. (I tried this with version 1.4.24). You may be able to miss out step (1) on a non-HTC phone.

    1) If you have an HTC phone and it's trying to load the "Location Picker" app, download the "Select Other Map" (free) from the Play Store

    2) In another App - contacts or calendar, tap the location data (address/postal or zip code)

    3) When the selector appears, choose "Google Maps" and "Only once" (best to be connected to a Wifi just for this part)

    4) Tap the post code again and then when the "Choose Map application" dialogue appears, choose "map navigator" and then "always use this"

    This seemed to fix my "missing country" issue. I think that somewhere in the system, opening google maps at least once sets the default country - which Map Navigator seems to need to enable it to show locations passed to it from outside the App.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion