Postcode search not working on Canada OSM maps (Android)
  • I am using the latest Android app on my Galaxy S3. The search function works alright using city/street names etc., but no results are shown when searching through postcodes. Just so you know, I select the country in search, then in the next field i type the postcode (L9T 0S5 - tried it with and without space), but it simply says no result.

    Without postcode search, the app looses a lot of its appeal, and I really don't understand why it wouldn't work unless the Canada OSM map file does not have postcode data (which would be sad).

    Would appreciate some help.

  • 2 Comments sorted by
  • Hi. I had same problem with UK postcode search.
    I found that there are two data files. One for maps and one for postcode data. The postcode file was being ignored. I deleted the UK map file leaving just the postcode data file. When searching now the postcodes were available.
    I then readded the original UK map data file and everything then worked fine, postcode search and maps.
    Hope this helps.
  • we do not have postcodes for Canada in free maps, in TomTom maps we have the first groupt (L9T) linked to streets.
    Please let me explain how it works.
    We provide free software, but do not make maps. Free maps are created by volunteers at - anybody can join and help to make maps better using their local
    knowledge. May be you can also contribute?
    Having said this, you can type (speak) address in the built-in Google search.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion