Google Maps Lookup Not Finding Things
  • Hi There,

    Platform: Samsung Galaxy Tab 2 10.1 running CyanogenMod 10.1.3 (Android 4.2.2)

    All apps and all Navigator maps are up-to-date.

    I was looking at routes and times to lodging in London, Ontario, Canada, last night.  Every place I tried to look up, via "Google lookup," returned "not found."  Even if I entered just "London Ontario Canada".  This occurred whether I selected the OSM maps or the TomTom maps.  I looked up "Detroit Michigan" and it found that.

    In each case: The same search criteria, entered using the Google Maps app, found every location, every time.  I entered one of the search criteria into the Google Maps lookup in the NavFree app, and it found it.

    Something awry in the interface to the Google Maps API, perhaps?

    ETA: Additional info:  I think that at one point I looked up a place by name in the Google Maps app, went to the web site associated with it, copied the street address into the clipboard, went back to Navigator and entered "street address London Ontario Canada" into the Google Maps lookup and it did find that.


  • 13 Comments sorted by
  • please try to reboot your device
  • tomas,

    Tried it.  In fact: One time in the past, when that happened, I rebooted the tablet and the lookup worked.  (That was prior to my replacing Samsung's buggy JB 4.1.1 with CM.)  That "fixed" it.  Reboot didn't work this time.


  • Strange - I just tried on a tablet and got one result for London Ontario Canada

    If i type in London Ontario Canada hotel I get six or seven results
  • Would logs help?


  • do you have version 1.0.35 or higher?
  • I'll have to check it when I get home, but I'm fairly confident I have whatever is the latest.  I always update fairly promptly when I see Play Store update notifications.  In fact: I'm pretty certain I manually checked for any app updates just last night.


  • tomas,

    Yes: It is 1.0.35


    Now go to the Google Maps app and type in "London Ontario Canada hotels" and see how many you get.  Hotels or B&Bs: I got maybe a half-dozen of each via Navigator's interface to Google Maps.  Via the Google Maps app directly: Dozens of each.

  • if I type 'hotel olondon ontario canada' I get seven results
    if I type 'lodging olondon ontario canada' I get three results

    in Maps i get more and more as I scroll down, as distance keeps increasing by scrolling down
    so it is not easy to say how many are found on the initial search

    searching in Google is altogether different thing, not possible to compare

  • tomas,  I wasn't searching in Google. I was searching in Google Maps.  One presumes that's what the Google Maps API provides.

    Furthermore: The places eliminated are not necessarily "the furthest away."  For example: Every bed & breakfast in London, ON I've tried to look up via Navigator, every last one of them, does not show up.  Whether I enumerate their names or look at (the truncated) list returned by a general search term.  They're all centrally located.  As in: Within easy walking distance of the center of London's entertainment, dining and shopping center.

    It seems to me this is pretty straight-forward: I can enter a place into Google Maps or NavFree and it's found.  I do the same in MapFactor Navigator and it's not.  Does this not imply there's something amiss with MapFactor Navigator?

    Must I load every other Android navigation application on the Play Store that supports Google Maps lookups, or perhaps poll the Android forums for their users, to see how they behave to prove the point?


  • well, let me know what exactly are you typing in and then I can try to replicate it
  • "London Ontario Canada bed & breakfast" (or "and" in place of "&" - doesn't matter) will turn up a couple dozen B&Bs in Google Maps or NavFree, including these:

    "London Ontario Canada Woodfield Bed and Breakfast"
    "London Ontario Canada Parkview Bed and Breakfast"
    "London Ontario Canada Dufferin House Bed and Breakfast"

    To make sure I wasn't doing Something Stupid, such as a typo, I even copy-n-pasted the entries from one application to the other.

    I even, at one point, entered simply "London Ontario Canada" and it came up "not found."  It found "Detroit Michigan", tho.

    Thanks, tomas.


  • I type "London Ontario Canada bed & breakfast"
    I get:
    Western Bed and Breakfast
    Lawson House Bed & Breakfast
    Ambleside Inn Bed & Breakfast
    james' Bed & Breakfast
    J B's Bed & Breakfast
    Joan's Sunnyside Bed & Breakfast
    Pink Chestnut Bed & Breakfast (The)
    London House Bed and Breakfast

    when I find centre of London, Ontario and then search near map centre I get 20 results including
    Woodfield Bed and Breakfast
    Parkview Bed and Breakfast
    Dufferin House Bed and Breakfast

    there are two APIs from Google, we do not combine them, Osmand may only use the second one, or combine them, I do not know
    we will look at it, but it could be, that it is better split, I do not know
  • So I tried something different, based on your comment, tomas, about "when I find centre of London, Ontario and then search..."  So I asked it to find "London Ontario Canada" (which, for whatever reason, it would not find the other night, but it did last night) and set that as the "where to search," rather than "everywhere."  Then I entered the name of one of the B&Bs (Dufferin House, I think) and it came right up.


    I only thought of that just as I was getting ready to go to bed, so that's the only experiment along those lines I did.  I'll try some other things tonight and report back.

    I will say this, tomas: I've loaded a bunch of free/trial navigation apps. The only one I liked, next to yours, was NavFree.  But I like Navigator's behaviour during actual navigation much better, in the way it easily switches between views.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion