Does Navigator Free work on Jelly Bean (rooted)?
  • Hi,

    I just upgraded my rooted Samsung Galaxy 2 (GT-I9100) last night to the Alliance ROM 7.01, which does lovely things to the stock Jelly Bean 4.1.2.

    Everything works - except Navigator: There was an update to Navigator which I installed this morning; when I tried it out, it just told me that it needed an SD card.

    I went back to the previous version of Navigator via Titanium Backup - same result.

    To make sure that the Navigator data had not somehow become corrupted, I restored the Nandroid backup of my previous installation, which used the Alliance ROM 4.1 (based on ICS 4.0.3) - Navigator worked flawlessly.

    Any idea what I can do?


    Jochen :-/
  • 2 Comments sorted by
  • Hi Jochen, it seems like theres a wrong path saved in setting. You could try to go to the android settings->applications->navigator then "force stop" & "clear data" and run navigator again.

    regards PetrS.

  • Thanks a million, Petr, problem solved!

    Kind Regards,



Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion