How to get my backups back? [Android 8.1, Navigator 7.2.23]
  • My problem: same device (Galaxy S9), but new Micro SD Card (containing a 1:1 copy of the old one - including the Android directory).

    Now Navigator doesn't find either my Favourites/Routes or my Backup directories.

    Today I could at least get one set of data back - by creating a new backup, finding it (in .../MapFactor Navigator Backups), deleting all files in that directory and copying the files from an older backup into it.

    However, there must be an easier way - which is it?

  • 3 Comments sorted by
  • Hi Jochen, best is to email support and explain in detail
  • Hi Jochen,

    with Android, SD-cards have individual "names" - when you change the SD, path is different from before.
    With my 8.1 device, path (as an example) for OsmAnd data is /storage/B40E-A565/Android/data/ (don't have MFN on that device, sorry).
    B40E-A565 is the SD-Card - when I exchange that SD (even with a copy of all data on the new one), the "name" changes and OsmAnd will not find any files, 'cause it saved the old name somewhere.
    So you have to "force" MFN to re-create all directories needed on the new SD-card (Favs, Routes, BackUps, whatsoever ...) - and after that, you can copy all your data from old SD folders to the new ones.
    Then MFN should recognize your data.

    Regards ...
  • Thanks, you two.

    Problem solved - sort of: I had several times changed the location of the backup directory, performed a backup, found it and moved all the old backups to the same place, closed/reopened Navigator - and the old ones were not shown.

    Just now they were! [No idea whatsoever why it worked now but not before.]

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion