MapFactor Navigator Android text-to-speech
  • I use TTS-Engine for a long time and not the internal voice of MacFactor. I have installed "Acapala TTS" here, and it worked perfect until newest update. Now i only can choose between samusng-text-to-speech and internal voice! Why? Before update i was able to select voices from my TTS App (Acapela TTS). In Android Settings of course I have selected this Text-to-speech App as default - it works well but in newest MapFactor Navigator.
  • 7 Comments sorted by
  • I tried now. Uninstalled MapFactor 7 and reinstalled version 6. Text-to-speech worked again as it should. Retried to make update to 7 - Text-to-speech did not work anymore as it should.

    As soon as iIhave Version 7 installed, it does not take the default text-to-speech engine as defined in android. Not the installed "Acapela TTS" nor the "Google Text-To-Speech". It just allows me to select "Samsung Text-To-Speech". 

    For me it seems, that MapFactor 7 does not take care of what is set as default under android and just takes the first in the list (which is samsung Text-To-Speech). 

    I went back again to version 6 and it works. I will not update to 7 until this bug is repared. I'm using Navigator FREE with payed plugins/externsions. 

    I'm using MapFactor on a Samsung S6 Lite 10.1 Tablet with newest system updates (not rooted). I'm NOT using Android Auto.
  • Hi, I tried to install an alternative text to speech engine (Vocalizer TTS), I have downloaded a voice, set the engine as default in Android system settings and I have found it in Navigator's Navigation voice dialog (Silent - Recorded voices - Vocalizer TTS). Could you make sure your desired default TTS engine is set correctly? I can find it in Language&Keyboard - Text-to-speech output - Preferred engine
  • I installed Google and eSpeak, Samsung was already installed
    Navigator offer engine I selected as 'preferred' in Android settings/general/text-to-speech output

    Android v9, Navigator v7.0.46
  • As I wrote: Returning to Version 6 of Navigator it works again perfect with Acapela TTS and this also works in all other apps. As soon as I update to Version 7 of Navigator it does not work anymore. I do not want to go to another Text-To-Speech engine only because Version 7 of Navigator is buggy. In Acapela TTS i have payed voices. So I will stay on Version 6 of Navigator until the bug is repaired. Again: I'm using it on a Samsung S6 Lite 10.1 Tablet, where the samsung-text-to-speech is installed and cannot be removed. It doesn't matter which text-to-speech enginge I select as default under Android - in Navigator 7 it does only offer me samsung-text-to-speech to select!
  • Acapela is not free, so I did not test it
    but all others work when I select 'preferred' TTS engine, it may be that 'default' does not have the same effect as 'preferred'?
  • You testet on a samsung s6 lite 10.1 tablet? all others may act different.
  • There must be difference in handling text-to-speech in navigator 7 compared to navigator 6, otherwise it would not react different.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion