Recorded GPX files in Nav Free do not properly display route
  • Using Navigator Free 6.0.205, I recorded several GPX files while hiking during the past week.  When I viewed the files in Navigator Free or on the OSM website, the files appear to be either are corrupt or were not recorded properly.  Instead of following a winding hiking trail, the trace shows a series of straight lines with many locations missing even though I passed by them.

    GPX files and screenshots are located here.

    GPX files recorded on 16-06 and 31-07 display routes properly.
  • 7 Comments sorted by
  • I think you have the same problem I "had" long years ago with IGO recordings...
    It records WAYPOINTS not routes. So depending on timeframe between recorded points you just have lines on surface, not following a streets. To see a route (must not be yours, depending on settings in routeplanner) you need  to import them to a routeplanner. Google Earth does not show routes from these waypoints.

  • Since I was hiking while doing the recording, either the waypoints were spaced 10+ minutes in time, or I was walking at 100+ miles per hour ????. In 5+ years of recording GPX files, this was the first time I have encountered this issue. Tracks show up bad in Navigator, GPX Editor, OSM editor, etc.
  • your GPS is probably giving bad positions
    record NMEA and email it to supportt
  • Tried saving other tracks.  They seem to be OK.  So not certain why there was an issue during those few days.  My phone is a Pixel 3a, so not a relatively old phone.  One of the tracks was walking around an open field, so hard to see how the GPS signals have been problematic.  Will keep monitoring.
  • Hi Tomas,

    I have found a way to reproduce the behavior.

    I started the recording at 01:03, then switched to the home screen at 01:04, then locked the screen at 01:05, unlocked at 01:06 to the home screen, then switched to Navigator at 01:07 to stop the recording.  Here's the result (I've trimmed the ends of the NMEA file a bit for brevity):


    Recording apparently only occurs when the app is the active screen.

    This was run on a Pixel 3A with Android 11.

    As I recollect with my old Samsung Galaxy S4, I could lock the screen and the recording would continue (I had to do that to keep the battery from draining too quickly).

  • please check permissions in Android settings/location/navigator
    should be set to Allow all the time
  • Hi Tomas,

    Checked the setting and found it was set to 'Allowed only while in use'.  Changed to 'Allowed all the time' as you suggested.  I reran the sequence described above, and the NMEA file shows no dropouts in the recording, even with the screen locked.  So issue is solved.  Thanks!

    My use case for recording track files while the screen is off is the scenario when I am walking on a footpath that doesn't exist in OSM.  I do the recording to be able to add to OSM after the walk.  Since the path is not on the map in Navigator, there's no need to have the screen on at all while I walk.

    I did not know about or change the location permissions in Android, so I would think that it's a default setting of Android 11.  There's no indication in Navigator's Recording menu tab that an Android setting can affect the recording.  Would be nice to have a pop-up (with a 'Don't show again' button) mentioning that, so users can know how to set the permission as they desire.

    Best regards,


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion