[Solved] issues with the latest apk
  • I just downloaded the apk from your http://download.mapfactor.com/. Now, after selecting language and granting permissions Navigator is stuck on "Extracting application data". I tried to uninstall and reinstall the app but same thing happens.

    Any ideas?

    Android 9.1.0
    apk whatever version was on the server (on Wed 8th Apr)
    (edit) System recognizes this as 6.0.91
  • 5 Comments sorted by
  • It is a game stopper if that's the case... It is not really about Google services but active google account. My phone Honor (Huawei brand) has google services installed but I decided not to create new or link with a current google account, I use F-Droid and AuroraOSS for apps which absolutely suffice.

    @tomas could you confirm if this is intended behaviour of your app or could that be rectified?

    Think off all those people who like me don't want google account, will not be able to have a google account (some Huawei phones) or use other Android flavours (LineageOS etc) possibly without Google Services.

  • The same happens for me when "Google Play Store" is deactiavted. If you activate it you can install the new version of MFN but when deactivating "Google Play Store" after installation you cannot start it again, the same message occurs.
  • That means, that Navigator is bound to active Google services!?

    I had no problems with the apk from the mapfactor site.
  • just be patient, it is beta
  • Patient?? I want it, I want want want the beta... It's all me me me ;) :))

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion