Do not receive HD Traffic
  • I just installed Mapfactor and an OSM map, enabled HD traffic ("even when roaming", and I double-checked this several times) but unfortunately do not receive any HD traffic in MapFactor. None of the blocked roads in my surrounding, as reported by TT HD traffic ( and within my own TT app) are shown in MapFactor. Not when scrolling the map and also not when creating a route and navigate.
    (The TomTom app with HD traffic works fine on my device, as well as Google Maps traffic.)
    What can I do?
    (I'm looking for an alternative to TT app because they continue to abandon features, I'm very impressed by MapFactor and would like to switch to it, but I really need to get HD traffic working)

    EDIT: Also, my first test route with MapFactor to a randomly chosen shop in the center of my town went completely wrong. Instead of navigating correctly (1,5 km), MapFactor calculates a route around the whole town, 12,5 km. I have used the default "Car" profile. This definitely cannot be a blamed on the OSM map because other apps using the same OSM map (e.g. Locus Maps and Magic Earth) calculate the correct route (1,5 km). I took a screenshot but do not find a possibility to attach it here.

  • 11 Comments sorted by
  • map manager/buy maps
  • please send logs from settings/advanced and include your order ID
  • I do not have order-ID yet, I just  downloaded/installed it yesterday. HD traffic can be tested for free during the first days, does it?
  • no, there is no automatic test period for anything
  • Settings - Navigation - HD Traffic: I can only switch it on/off, do not see any option to pay for it
  • Oh, I see. Did not expect to find it there. Sorry!
    I'm thinking about buying TT-Maps too, but before doing this I'd like to be sure: When using TT-Maps (for normal cars), is it also possible to tap on a road and mark it as blocked?
  • To reproduce the detour of 10 km mentioned above (with default car profile on OSM map):
    From: 50.863416, 3.798221 To: 50.870469, 3.810437
    You will see that MapFactor calculates a huge detour around the town and
    you'll need to put 2 waypoints in order to get the correct route. I
    tried at which calculates the correct, short route
  • In your Settings you also have the several vehicle profiles. Check the road parameters for your car profile. By default it has  "small local roads" switched off. Please switch it on and try again.

    From my point of view this is a "bug" in the application. They should be switched on but with a much lower priority.
  • @hvdwolf : Yes, enabling small local roads solves the problem, thanks so very much!
  • you can disable road link - click, select Edit (pencil)
  • @tomas : great, thanks a lot! This is one of the features TT has abandoned and which I'm missing there very much. So I think I will buy all options this weekend and switch to MapFactor. I have a final question about avoiding traffic jams in Mapfactor but will ask it in another thread in order to avoid mixing up too many different topics in one thread.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion