Moving to a new phone - can't convince the app to use the external storage
  • Hello.

    I've just bought a Sony Xperia X Compact with Android 7.0.1 7.1.1. I'm moving all the stuff from my old phone. I have a quite large set of maps, plus a list of preferred places, etc., that I'm trying to transfer. I've moved them to the new sdcard. But when I start the app for the first time (eventually uninstalling and reinstalling it) it does ask me whether I want to use the internal storage or the external one; but it seems to ignore my preference (I can see that the folder is always created under /storage/emulated/0/Android/data).

    Please let me know.

    PS I'm a software engineer with Android knowledge, just in case it can be helpful.
  • 6 Comments sorted by
  • I don't know how much help this is. I just downloaded and installed the app along with several US states. My phone is a Microsoft Lumia 950 with Win 10 OS. I installed the app on a 256 GB SD card. My phone would freeze, it told me I didn't have enough free space on the SD card when in fact I have over 100 GB free. I uninstalled it. I reinstalled on the phones memory and so far it seems to be stable and I have no where near the free space in my phones memory as I do on the SD card.... good luck, Blair
  • For me, with an older android version, there are two key settings.
    1. Location of app: using the android system Move to SD option works for me though it leaves some files or folders in internal storage.
    2. Map storage: using the app's Map Manager allows me to choose the SD.
    Just in case you'd missed one of them!
  • From android 7.0 onwards, and its implementation/convention (naming of external storage) by the manufacturer, can restrict access in some way to external storage/memory (sd card). Perhaps user setting can come into play to? Like encrypted storage?

    As of android 7.0 I can only use internal storage for Mapfactor Navigator Free reliable. Samsung Tab S3 & S5 Neo. All none essential like movie/music/photo's/... => is on external SD card.
  • please use Navigator to move to SD, Android option does not work properly
  • I did it, but read below.


    Unfortunately there's no option to move the app to external storage, so I can't try it. I'm only offered an option to move all apps to storage, but I don't know the consequences for other apps. I think that it's a different thing of my Sony compared to standard Android (AFAIK there are also some differences in the options for formatting cards). For what concerns the map storage settings inside the app, it's the option I've tried. I'm presented the option to move the stuff to the card, and apparently it does. But when the app restarts, it's still using the internal storage.

    I didn't encrypt the card (yet?) to deal with one problem at a time. I'm aware of the 7.0+ restrictions about sdcard usage... I fear the app has not been updated yet do deal with it.

    In any case, I found a way to do the thing, restarting from the beginning.

    1. Uninstalled the app, so to start from scratch.
    2. Installed the app.
    3. I couldn't move the freshly installed app to the sdcard, for the reasons I've explained above.
    4. At this point the app didn't detect the files that I had already copied on the sdcard. This is somewhat expected, the problem is that I can't access the settings option to use the sdcard because with no maps downloaded either you download something or you quit. Perhaps the makers of the app could add a fix for the new version, allowing to access the settings in this scenario.
    5. So I downloaded a few maps (the minimum allowable: e.g. Andorra, which is very small, plus Earth and a few other things, they are only 100+MB).
    6. Then I went in settings and asked to move the maps to the card. The app at this point noticed that there was already a folder (the data that I had prepared earlier), but it only allowed to overwrite them. I overwrote them and quit the app.
    7. A few folders still remained on the internal memory, but they are mostly empty or with small files.
    8. I re-synced the files on the sdcard from my backup.
    9. At the next restart, I found everything: both the old maps and the favourites, etc...
    10. I even tried downloading more maps, and they were downloaded to the external storage. So it's fine.

    Thank for the support.
  • Hi,

    Android/data/xxx is protected storage and when you access it using another app or PC, navigator lose access into this folder (I am not sure how exactly it works as SDcard has FAT32 filesystem but somehow the folder is getting locked).

    Possibility how to solve it is uninstalling navigator is:
    1) uninstall Navigator
    2) remove all Android/data/com.mapfactor.navigator folders
    3) put your data into <internal storage>/navigator
    4) using navigator/settings/advanced/"Change installation SD-Card" move it into SD card

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion