frequently loosing GPS signal while driving
  • I'm using a Nexus 4 (16 GB) android 5.1.1 (rooted) with Navigator 3.0.125 and have frequently losses of the GPS  signal. Car is moving approx. 60-70 km/h.
    Phone is attached to windscreen and calculates instantly the route and gets GPS signal fast. But when starting I get frequently the star sign instead of the arrow sign. 

    Using in parallel a Nexus 10 tablet with same settings as Nexus 4 - no problem. Does anyone has a clue what I should change ?
  • 20 Comments sorted by
  • Does the Nexus 4 work with other apps using GPS without problems?
  • GPS is controlled by Android, Navigator cannot make GPS reception better or worse.
    Try to reboot your device, it quite often helps.
  • Intall app like GPS Test (Chartcross Limited) on both devices. Check if GPS reception is similar for both.
    GPS sensor could receive a lesser signal. Could be several causes like
    - phone cover blocking
    - GPS sensor is in another location in the phone (turn 90° or 180°)
    - mount on screen to close to metal window rim
    - ...

    usb power to phone is only 500 mA or below . Cause cable or power supply (12v car to usb)
    Check with app like Ampere Meter (BhereApps)
    Compare against original  power adaptor  and supplied usb cable.
    Some devices can require up to 2.5A (fast loading)

  • @Oldie - yes , works with OsmAnd+ - Locus Pro - Here WeGo

    @tomas - did reboot with optimizing 117 apps (takes half a hour) 

    @Jan  - thanks for your hints. will try those apps (no phone cover / no metal window rim {MB Sprinter})
  • I did not mean reset, just reboot (restart)
  • @tomas - yes - I didn't reset - rebooted and another annoying glitch of android keeps starting with optimising all apps :( - Have not found a workaround.  
  • probably settings in Android, it never asks me
  • @Jan - have GPS Test installed in both units / result differ
    Nexus 4: Satellites in view 22 / in use 8 / accuracy 16 m
    Nexus 10 Satellites in view 12 / in use 11 / accuracy 8 m

    battery power both units on approx. 80%

    Does the differnce of accuracy has the effect of loosing GPS signal ?
  • @Jan - after watching both units for an hour I recognize that the Nexus 4 every now and then switches from 3D Fix to No Fix and than back again to 3D Fix 
  • GPS Test: menu top right hand:
    AGPS >  Clear and Update, see if this improves?

    That would indicate at certain point it does not have enough data (satellites in use?)

    Nexus 4 sees more GPS satellites and uses less of them?
    no skins on the nexus 4, like stickers on it?
    Differences between makes and brand?

    If in an area like Afghanistan, there could be interference on the cvilian GPS (US not allowing high precision: terror  threat)

  • @Jan - AGPS clear & update improves number of used satellites (view 19 / use 11) accuracy 6 m.
    no skins & no stickers.

    Brand is Google Nexus  / manufacturer is LG

    I keep an eye on it on my next trip.
    Thanks very much for your help 

  • Solving GPS problem, try one of these::
    - restart phone
    - toggle location On/Off/On
    - check mode is high accuracy
    - use airplane mode
    - clear cache partition
    - switch off LTE services
    - issue not solved: boot in safe mode, possible 3rd party app issue.

    if none of these did help: get new phone: is already 5 years old

  • Hello,

    Same problem here.

    Description of the problem:

    1-2 Minutes after navigating Mapfactor Navigator looses GPS connection.

    If I go to "Tools"-"GPS Status" it needs about 30 seconds for the GPS-FIX.
    If i keep the app in the "GPS Status" state, it keeps the GPS connection.
    But as soon as I go to the map-View (navigation - View) it will loose the connection
    after about 1-2 minutes again.

    Other Navigation apps (eg HERE wego) work fine and without any problems so I think that it isn't a Hardware problem.

    I had the problem on my old smartphone too (galaxy express 2)

    I already tried the following fixing solutions:

    - Reboot
    - deinstalation and new installation of mapfactor Navigator
    - AGPS Clear and update
    - tried with "GPS Booster" app

    I should say, that I have NO Data-Connection when navigating !

    Any help would be grate.

  • is the location icon in notification bar flashing or solid?
  • and Navigator says no signal when it is solid?
  • Yes, Location in Android is solid (other apps like Google maps or ".here we go" ) work fine !!!!
    Navigator says "waiting for GPS" when in Navigation mode.
    But when in "Tools-GPS Info"-mode Navigator finds satellites and work . When you Switch then again in navigating mode , Navigator works find for about 1-2 minutes, and then it looses Signal again until you swith in GPS-Info mode again !

  • please record NMEA and email it
  • You can see the 2 times, when I opened "Tools - GPSInfo": Here the signal is correct for a short time, then it looses again.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion