Navigator Free with delivery routes
  • Just downloaded the Android app and am playing around with the functionality to see if it's applicable to the purpose I am trying to use it for. I have a fixed, predetermined newspaper delivery route where (almost) everyone on the route receives the paper. Looking to define the route in Navigator Free and have the app give me turn by turn directions while I concentrate on throwing and skipping the addresses which have requested no delivery. The route typically involves staying right on a street and throwing one side, doing a U-turn at the end or at a predetermined spot, then retracing your path and throwing the other side. Are there any problems you can see with this approach?

    I seem to be able to define the route using a starting point, waypoints, and a destination or end of route. I am not creating a waypoint for every physical delivery addresses but rather just enough to make a route which doubles back on itself. But I cannot use any route optimization features as that seems to change the route based on speed or distance, etc.. Calculate Route does not seem to alter the route however, just create the turn by turn directions. Is that correct?

    I also have a question about the Simulate function. Is that intended to walk through the whole route or only a portion thereof? The latter is what the function does when I run it but the former would be great as a way of verifying that I created the route correctly without going up and navigating it.

    Curious also about the TomTom maps that can be purchased. What granularity is displayed on these for the USA? Is there a layer like what Google earth displays or are they still street maps fundamentally? I would love to see the outline of individual houses shown on the map...

  • 40 Comments sorted by
  • Hi
    to optimise waypoints go to Route info
    Simulate will do all journey
    aerial photography is far too big to store on your device, it is not practical for offline navigation

  • Thanks Tomas. I have run simulation on my route several times and it always ends abruptly about 1/10 of the way along the route, leaving me in the map with the visited waypoints colored dark gray. Is there a log or a way that I can see what is causing the simulation to stop?
  • Found the log file and the simulation is at the end ... Debug level is currently set to medium. I see the last step simulated then a call to RtgNav::StopNavigate() and a series of other functions... This log is 1.1 MB.
  • it could be damaged map file?
    try to delete relevant map and redownload
  • Deleted the Arizona map and downloaded again. Simulation still fails at the same point in the route.
  • email me routing_points.xml file, I will try it

  • Sent to
  • Viewed the xml file and the name is the name for my original route, which no longer exists. I saved that original file under another name and have made tweaks to the route, played with optimization, etc.. How does the routing_points.xml file get created? I seem to need to create a new routing_points.xml for the route as it exists now....
  • I have no problem replaying this route.
  • I don't know what to say... It doesn't work for me as I said. Should I uninstall and reinstall the application? What files do I need to preserve so as not to have to recreate the route from scratch?
  • I can still only get as far as waypoint 9 before the simulation quits abruptly. Waypoint name is East Via Linterna; lat is 116395724; lon is -399443499.
  • Are there any Android apps that conflict with Navigator Free?
  • try with default car settings (Car+)
  • That is what it is set to. I created a car called Toyota. In vehicle parameters, u-turn enabled and fastest optimization mode. Under road restrictions, everything enabled except small local road and other road. Stops at exactly the same waypoint 9...
  • Will this problem go away if I purchase the extra features for the Android version? This is not a limitation of running the stock Free version is it?
  • Would the fact that I am storing the maps, etc. On the sd card rather than running all on internal storage make a difference?
  • premium features will have no effect
    my maps are also on SD, but you are not running default vehicle settings if you change something - please try it with default settings
  • Saved my routingpoints.xml file to another directory. Did a backup and delete. Then copied in my saved routingpoints.xml file. Same situation. Simulation ends after the 9th waypoint.
  • Uninstalled the app and reinstalled it all on internal storage. Downloaded my map of Arizona, copied in my saved routingpoints.xml file and launched the simulation. Fails in the same place.
  • I did try again and it stopped on approx 50th waypoint, but I was replaying at high speed
    I sent logs to developers
  • Speed doesn't matter for me. I run it a 1X and 10X and still fails at the same point. Let me know if you want a verbose log from my phone.
  • So assuming this is a RAM issue, I am looking for a work-around. Am I correct in thinking that I could edit my existing routingpoints.xml file into a series of several smaller sub-routes small enough to simulate, get these sub-routes working as I want them, then re-assemble the subroutes back into a single route in routingpoints.xml?
  • yes, that is reasonable assumption
  • Thanks. I'll try that approach and let you know how it goes.
  • That is working... What do I do when there appears to be a bug with a map? I have a route where the arrow for the next action is a right turn but the route simulation says to turn left instead, even though the simulation goes right?
  • please check distance to next manuevre, it may be that turning right is compulsory and left is next turning
  • Actually the road allows either a left or right turn but the next waypoint is to the right. The simulation takes you left but the voice announces turn left...
  • The problem goes away if I add an intermediate waypoint before the right turn in the route. At that point, the simulation now says the upcoming turn will be to the right rather than the left, as before.
  • Hello again, I have figured out how to walk through large portions of the route by starting at different places in the route and simulating from that point forward. The route I have built creates a routing_points.xml file with some 220 waypoints for the one route I have defined...

    The problem I am now facing is when I actually go out to throw the route and turn on Navigation. All is well until I have to back track or otherwise deviate from the route. For example, suppose I have navigated the first 10 waypoints and am approaching the 11th. Now I realize I need to retrace the route backwards, pick up a paper I should not have thrown near waypoint 4, and then carry on. The app immediately starts to recalculate the route, and as I move forward, the directions it gives no longer match the simulation of the route.

    So, I am wondering if my basic approach to using the app is flawed. When I back track, do I need to turn off navigation and then turn it back on when I get back to where I was when I realized the need to back track? Should I be breaking this large route into a smaller set of sub-routes of twenty or so waypoints each? Open to your suggestions on what to read or try...

  • if you wish todisable 10 waypoints, then it may be better to stop navigation first
  • OK, thanks, let me see if I understand. In my scenario, I'm near waypoint 11 and realize I need to double back. So I should stop navigation, double back, return to my position, disable the first 10 waypoints in my route, and start navigation again, correct?
  • I am not sure what double back means, but if you wish to skip first ten waypoints and start at 11th then I would stop navigation first
    you can also skip next waypoint by clicking on the map and selecting Skip waypoint from toolbar, but that will disable on one
  • "Double back" means go back to a waypoint I have already passed, for example, back to waypoint 7 when I am approaching waypoint 11...
  • Is there any facility to import a route from a .gpx file?
  • you would need to switch waypoint 7 on in Route info
  • @WGrant / import a route from a .gpx file
    With a file eplorer (I use Total Commander) navigate to the gpx-file on your Android.
    Click it > Open with > "Navigator".
    You then can find this track in "My Places > GPS records"
    I did so with a route which I've created on my PC, using

    Navigator crashes when I choose "Replay" for this file. "Show on map" works.
    But I did not figure out how to make use of such a track for navigation WITHOUT re-routing. I just want to get navigated along this track as WGrant wants to stay on his delivery route.

    Any suggestion?

  • GPX file can contain track points or waypoints - if it contains waypoints, the it is imported as routing points set, otherwise as track

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion