Route Not Found
  • I am using the default settings on the OSM map and it keeps on coming up with this. It doesn't matter what destination I put in either.

    I am trying to move from Garmin to an Android app that allows my own POIs. This is proving harder than I thought!

    This app seems to be perfect but not if I can't navigate anywhere! 
  • 40 Comments sorted by
  • What are you trying to achieve?
    I assume that you already chose a destination point that also shows up in "Route info". Then, depending on your goal:

    - To view a route based on an arbitrary starting point, define a starting point so that it's also visible in "Route info". In "Route info", press button "Show on map".

    - To immediately start routing from your current GPS position, just press Navigate.
  • I've tried setting a destination and pressing Navigate to use my current loaction
    I've tried setting a departure point (my current location), a destination and the pressing Navigate

    Neither work so am a bit lost.

  • Are you using the same start & end points? If your start or end point is not close to a road (for example in the middle of a field) Navigator will give a route not found message. Try enabling small local roads in vehicle settings. This has been known to cause error in some countries.
  • Many thanks for the quick response. I've just tried to enable all road types with no success. 

    I am trying to Navigate from Heathfield (UK) to Strood (UK).
  • please provide departure and destination in coordinates
  • I have seven Heathfields and two Stroods for selection. Just choosing the firsts from the list, I can at least calculate a route from the tools menu.

    What you are telling, really seems to be something, that you still not know, how to use Navigator. This app's behaviour is somewhat different from what I was used to before. I think, we only can assist you, if you tell us step by step, what you tap and not just say "Navigate".
  • I go into Navigator, choose free maps. For example, I search for Camden Road, Tunbridge Wells. There is a pop up that gives me an option to Navigate. I tap that.  It shows the map and I get, 'Recalculating the Route' followed by 'Route not Found'.

    I've tried going to the map and pointing to the destination with no success.

    I am using postcodes but start co-ords are,, destination is  51°23'43.04"N,   0°30'3.33"E

  • problem seems to be in free maps
    seems like Vicarage road is not connected to A265

    Free maps are
    created by volunteers at
    - anybody can join and help to make maps better using their local
    knowledge. May be you can correct it?

  • Maybe I am being blind/thick but it looks as if it is. I'll try from another location and see what happens.
  • Even if I put the start point on the main road, it doesn't want to give me a route.
  • Quick update - I uninstalled it and deleted all traces of the app. I reinstalled it and it has the same problem. Even starting on the A265 to go 2 miles to Burwash produces the problem. 

    Otherwise it looks perfect and I'm not being sarcastic!
  • navigate will always start from your location, please use Calculate route in Tools.
  • That works fine until I try and actually navigate at which point it can't find a route.
  • Although this an extreme solution, would purchasing the TomTom maps cure the problem?
  • as I say, navigation starts from your position, no matter where you set departure
    yes, TomTom maps can route from your location

    can someone have a look at OSM?
    I cannot find what the problem is

  • A silly question perhaps but is your device location service service switched on & does Navigator have access to it? In Navigator Tools select GPS info. Are satellites available?
  • This works, with navigator 3.0.74, android 6.0.1  search:
    Country UK
    City: Burwash,East Sussex
    Street: Vicarage Road - Westdown Lane

    UK map 44-201701260 with Early map access in mapmanager, local road enabled in road restrictions (Route setup)

  • Thanks to everyone for getting back to me.

    Satellites are available - not a silly question, I promise you.

    I've gone into About and its showing Version 2.2.78. This was downloaded from Play Store yesterday.

    I am running Android 6.0.1

    How do I update the main app as that could be the problem?

  • search play store for mapfactor beta or install from here: Test of Android version 3.0.x
  • You may have to sign up for beta testing to get the 3.0.74 version. I think v2.2.78 is the latest stable version but someone from MFN should be able to confirm this.
  • One more thing. When you first run Navigator it asks you to choose free or Tomtom maps. I assume you chose free. I think you're then prompted to download at least one country (UK?). Did you also install the required files earth & sound signals?
  • As far as I know I did. I am resetting the tablet and doing a clean download so will see what happens.
  • I have installed the beta version and downloaded the maps, system files etc. It is still doing it. I checked GPS from within the app and it has a fix. The next step is to take it out on the open road and see if it works.
  • I've tried a "live" navigation from my current GPS position to the middle of Vicarage Road & it provided a route. You could try going to a nearby place then try to navigate home.
  • Travelling from Rochester Canal Rd to Burwash:
    The issue seems to be Vicarage Lane not Road.
    When destination is set to Vicarage Road the route is found.
    Set destination to Vicarage Lane the route is not found.
  • Ah! I know it exists, you can drive up it and it is maintained by the local council. Would the TomTom maps be better?
  • Sorry about the two posts but many, many thanks to all of you.
  • I have no idea if TomTom maps would solve your issue.
    Vicarage Lane, Burwash is on OSM map UK map 44-201701260
    I have no clue why the route is not found to there.
    Some experts could have a look at it, info
    lat="183545856" lon="1208096" Vicarage Lane - Stokes Road, Burwash, East Sussex, United Kingdom
  • TomTom maps have no problem with this route
  • Thanks and I'll purchase those as well.

    Will my own POIs show etc. on the TomTom maps please?

    Many thanks,


  • should do, but make copy first
    file favourites.xml, folder  android/data/com.mapfactor.navigator/files/navigator/
  • The navigation problem lies with Vicarage Road. To get to Vicarage Lane you have to go via Vicarage Road, which is correctly mapped on OSM as access="destination" for motor vehicles. Google Streetview shows a road sign restricting motor vehicles to "for access only".
    You can navigate to Vicarage Road successfully, as Navigator interprets the access restriction to allow you to get to it as destination
    Fairly unusually, there are a number of other roads that can only be accessed via Vicarage Road: Westdown Lane, Buckels Mews, Stokes Road, Westdown Park, April Lane, Park Hill and Vicarage Lane. None of these can be navigated to.
    So in some ways the fault lies with Navigator which does not navigate through this restriction to gain access to Vicarage Lane and other roads. I suppose the logic ought to be that in a case where a route cannot be found, any "for access only" restrictions are lifted. 
  • I can understand why it won't allow me to get here but I'm surprised that it won't allow me to escape from Vicarage Lane! 

    It works fine with the TomTom maps though.
  • I will try to explain this
    if you set waypoint on a closed link then route will be found
    if several links, next to each other, are closed and waypoint is on any of these then route will be found
    but if one link is closed and the next (with waypoint) is open, then route will not go through the closed link

    so solution would be to make all links the same
  • I've made the requisite edits to OSM.
  • I have used MapFactor for quite some time very successfully on a Samsung J5 with Android 5.1.1 . I have just got a new phone - Samsung J3 2017 with Android 7.0 and I'm getting the "Route not Found" issue.

    I have compared the settings in each phone and apart from some minor differences they seem the same. However on my old phone the maps are stored in the phone but on my new phone they are installed on the sd card. I needed a new phone because my old one ran out of space so I am reluctant to move the maps if I don't need to.

    Could someone tell me if this is a storage location problem or an Android version problem? If it is Android incompatibility then I'll have to keep my old phone as my SatNav - thank goodness for offline navigation!!

  • it is not a storage problem
    please let us have departure and destination in coordinates, then we can check
  • HI

    Thank you for your swift response!

    I have just tried various postcodes on my new phone (including that of a church near my destination) and I have not encountered the same issue.

    My destination is a private residential "village" but it does work on my old phone - in fact it takes me right to the door, could it be that it has now been excluded from your current maps? I can find it on Google maps but on their street view I can only "travel" a few yards up the private road that leads to this village.
  • By the way (not sure who to report this to) if I zoom the screen while I'm on this page I lose everything I have typed in the comment box - this has happened to me twice! :o/
  • it is not possible to see what the problem is without knowing exact position
    if it is some small private road then try to enable small local roads in vehicle settings

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion