Strange error with OSM map
  • Hi !
    I've tested two OSM navigation apps today.
    First, I took the road with Osmand. Then I turned back to my house using MapFactor Navigator.
    But it said "Trajet non trouvé" in french : "Road not found"
    I was in a Highway with 1km to go !!!
    So I came back and check openstreetmap website, and there is no problem.
    It's a problem with MapFactor or it's original OSM map conversion.
    Please, tell me what to do because a lot of people take this road !!
    (sorry for my english)
    Thank you !
  • 36 Comments sorted by
  • Noone can help you without knowledge about startposition and target of that route you wanted to chose. Please give more information.
    My first thought is your setting in car profile. Activate the second lowest kind of street (number 8 counted from top) and try again. Routing will use unclassified mapped roads and lower
  • Hi !
    Which type of information do you need , and how can I get exact start and stop positions from MapFactor (GPS coord.) ?
    Thank you !
  • A screenshot could help or streets from and to with the name of location. An alternative could be the route as a link to any OSM-router or google maps.
  • OK.

    Go to French map : FRANCE

    -> Start point :
    City : ROCHEFORT (Zip: 17300)
    Street: avenue Beligon

    -> Stop point :
    City : VERGEROUX
    Street: charles de gaulle

    This is a <10min route on a free highway. And mapfactor try to avoid the highway !!
  • If you switch start and stop points, everything is fine. Strange !
  • I cannot see why would this route go on motorway, but I can have different departure/destination
    please provide coordinates
  • Ok !

    Start point :   Lat : 45.967587  Long : - 0.963358

    Stop point :   Lat : 45.96089    Long :  -0.983684

    Mapfactor show a wrong and too long route with an ok travel time!!

    Swap points and it's ok !
  • I don't know how are you supposed to join motorway, there is only gated service road
  • Here is the correct route calculated by OpenstreetMap (4.8 km)

  • And this is what MapFactor gave me :

  • The correct length is 4.8 km
  • And if I do this on openstreetmap (only motor way in one way) :

  • I get this in MapFactor (error !):

  • So, in this way, the motorway doesn't exist for mapfactor !
  • And if I swap start and stop, it works !!

  • The first wrong route was in "Shortest route" mode.
    If I change to "Fastest route" I get this always wrong route in mapfactor:

    My settings include motorways, free or not.
  • I really don't understand this strange calculation.
    This was my first attempt to use mapfactor as I read some good reviews about it.
    And it didn't work at all !
    PS: osmand and navmii gave me the correct route...

    I really want to use MapFactor even if it's tricky to use (for ex, you have to press a button to swap stop and start points instead of moving one in top in the list with finger or have to press a "calculate route" button instead of an auto calc...) and the main UI is not so sexy (like navmii). But MapFactor have great detailed maps like osmand and is not as difficult to use...

    Well, is it a soft bug or a conversion map bug ?

    Thank you for your answers and sorry for my very bad english!
  • Analyzing nikkos's first screenshot I had a deeper look here:
    Coming from Rue Maurice Mallet for me the way getting to Autoroute des Oiseaux westwards is not possible to use, I dont't believe that the sharp u-turn on D5 is allowed. If tehe aerial view of bing-data is actual, there is no direct way from north of D5 to trunk-link towards Autoroute des Oiseaux just turning left:
    The only way to get on Autoroute des Oiseaux is over the roundabout in south of Autoroute des Oiseaux turning northwards.
    Looking to Google Maps confirms my opinion:

    I will look further, because this is not the real reason für the strange routing of MFNF.
  • I took a look at the history of that part of the A837.
    As you can see it has been modified on August 14 when it was changed. For a detailed description see

    This PTY2 removed the oneway tag which is completely wrong. I think Navigator has a bug as it see a two-lane route where one part has the oneway tag and the other not. Probably it is going wrong there with the calculation.
    Anyway, this PTY2 really made a mistake here.
    If you can confirm that that part is indeed oneway (like the rest of that lane), I will correct it.

  • I guess I got it  ;)
    It's again the Mapfactor-Navigator-way to organize routing on unclassified-mapped roads in osm and so my first impression in my firs post is confirmed.
    All the roads from Avenue de Béligon to D5 are mapped as highway=unclassified, what seems to be ok, because unclassified is the lowest level of roads with connecting function.
    Mapfactor put unclassified together with residential- and service-roads in on group of roads and uses this group only for the shortest option from start to next higher road-class like tertiary. The same way ist the use of unclassified to get to target from tertiary or higher.
    And so the next tertiary is Route de Breuil you are leaded from Avenue de Béligon and the error takes its course.

    This is another example for what I did regret in the way you classify unclassified several times. Please change as soon as possible and accept the connecting function of highway=unclassified 
  • service roads and unclassified are not the same group
    the problem is that you cannot get from D5 to A837 unless you make u-turn, which Nikko suggests

    so, you may get a slightly better route with small local roads switched on, but I cannot see how you could use A837
  • Hi !

    If I understand, this is  MapFactor not having the same categorizing as OpenstreetMap...
    Tomtom maps compatibility fault ?

    But if MapFactor is unable to deal with highways (!), it is totally useless...
    I hope it will be fixed soon.

    Thank you for your answers !
  • Tested again and same thing. If I start from another start point (well known street), I've got this with OpenstreetMap (which is correct):

  • And this from MapFactor :

  • Mapfactor doesn't want to take the free highway !!
  • you are correct, we do group some categories, but, in this case, it is not problem with grouping
    route you suggested is not possible, please look at streetview - if any application suggest this u-turn, then it is wrong
  • If I enable all the roads types, I get the same thing. Annoying...
  • In fact, I get the same error from Navmii app !

  • Is it OpenStreetMap related ?
  • In OpenstreetMap editor, one way of the highway is described as a Motorway or Highway and the other is described as a Trunkroad. I've submitted the modification in openstreetmap.
  • For, both lanes have only the direction east. There is no lane going west!


  • This explains a lot ! ;)
  • Like I said this morning: PTY2 corrected the road and made it wrong.
    Today it has been improved (trunkroad to motorway), but it is still not correct as the oneway tagging is missing for this part of the road.
    The screen Oldie shows is not correct as that view can't find the correct oneway tag and therefore treats both lanes as going into the same direction. If you edit the road  in Openstreetmap you see that one lane, at that particular part of the roads, misses the tagging. Only marking it motorway will not correct this as a trunk road is noit the same as an unclassified road.

    The oneway tagging is missing between the 2 nodes of that piece of road. That's why I asked: 
    "If you can confirm that that part is indeed oneway (like the rest of that lane), I will correct it."
    It needs the oneway tagging

    Edit: I just added it.
  • @hvdwolf Did you check the southern lane as well? When I checked eastward routing yesterday evening with Oruxmaps, BRouter and latest Openandromaps (France South), BRouter didn't use the southern lane at all, but routed only on the northern lane. Even if I made the map quite large, set starting and end point clearly on the southern lane (which is presumably eastward), BRouter found a route only on the northern lane (eastward, as we now know, that this OSM data were wrong and must be still wrong in map data downloaded yesterday). But nevertheless I would have exspected, that eastward routing on the southern lane would be possible. And when it is not, there must be something wrong with the southern lane?

    @nikko You will have to wait up to two months, until @hvdwolf s changes will show up in MFN map data.
  • @oldie: I did check the southern lane but only for that short "between 2 nodes" part and a small part left and right of it. Maybe the entire motorway requests more analysis but actually a local should do that. I now made corrections because it was the logical thing to do, not because I know the situation.

    I will check further to look for missing or conflicting tags.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion