[solved] Crazy problem at one street for routing
  • Hello,
    I have a problem on one street, but I can't find a bug in OSM. So I think, there is a bug in Mapfactor.

    How Mapfactor navigate (wrong routing):image

    Destination Detail (wrong routing):

    If I move de Destination about 20m, its routing correct:

    Destination Detail (correct routing):

    Test-Routing from Destination1 (wrong routing) to Destination2 (correct routing):

    Why is it routing so wrong? You see, the wrong routing is over 15 Minutes long. If I move the Destination, its routing within 7:10 Minutes.
  • 8 Comments sorted by
  • For me it seems to be the old problem in MFN free, that highway=unclassified, which are the lowest level of settlement connecting roads in OSM, are put together with residential and lower to small local roads in MFN. For me that's irritating users and generates routing like the upper one.
    There was a thread about that before, but nothing happened. On countryside it's often the best to use these unclassified between settlements.
    So please change that in MFN-classification and you'll get some more totally satisfied users.
  • with default car settings I get route 6.3km
    so it could be problem with your vehicle settings
  • I agree with @hurdygurdyman. This has already been discussed extensively in 2 long threads.
    It has come up as (new) user questions multiple times. 
    The best option is to split it.
    the second best option is to enable them but not with the default 50% priority but with 40% or so. That is exactly how I use them. Sometimes it is the only possible way to use these roads.
    Secondly: lots and lots of roads in cities fall into this category which means that Navigator uses completely unnecessary deviations because it does not use these roads. (But now I'm repeating some of the arguments which have been mentioned multiple times).
  • nope, I have the default car settings. I don't have changed something in these settings.
    But, I've forget to post something: I have the newest map (Early maps access - map 44-201604060).
  • I've found the problem:
    it was really a problem with my vehicle settings: In the road restrictions, the "Small Local Road" was disabled...
    But I don't know why, because I can't remember, that I've changed somehing there...

    @thomas thanks for your hint.
  •  problem is solved, but "Small Local Road" is with default car settings disabled, 

    tomas why not with default car settings "Small Local Road" enabled?
  • Sometimes it is a good idea to enable them, sometimes not :)
    It might be a good idea to have two car profiles, one with local roads enabled and the other one with local roads disabled and see the difference in the route. If there is a lot of difference, like in efred's case, I would investigate with google maps/street view to make sure my car can make it.
    In my experience a 'small local road' can be a very good road, wide, well paved and very easy to drive onto, or a very narrow passage, barely good for cycling or walking.

  • Hm, it is true, sometimes it highway (tertiary / residential / tertiary) wrong (+20km), sometimes just good


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion