Not being able to write on the SD card - Android version > 4.4
  • Why was -from all applications- only Mapfactor Navigator trapped to not be able to overwrite its own downloaded maps after Android OS update to the version which restricts SD card writing?
    It's annoying!
  • 7 Comments sorted by
  • close Navigator and delete data in Android settings/application manager/Navigator - then reboot your phone.Please take backup first, otherwise you could loose your favourites...
  • @mtorpan:  Your statement "only Mapfactor Navigator trapped to not be able to overwrite its own downloaded maps" is simply not true!
    I had the same with 2 other nav apps as well and with my own editor, which I had to modify as well because of 4.4.x. 
    It is Android, not navigator. Most apps only have very little data and store that data in <internal_storage>/data/data/<package>, which you can't access with a file manager unless your phone is rooted. You can't simply store hundreds of megabytes of data in that location. So every application storing its data outside that specific location is affected.

  • I had this problem on Meizu M2 Note (Android 5.1), where MapFactor would install maps ok to Internal Storage but not my extra SD Card (after initial maps install, would only show blank white screen). 
    Tomas's suggestion did not work. 
    Another suggestion was to install to Internal Storage and then move to SD Card. I did not try this, as there was no guarantee that extra maps would work (I want to download a LOT of maps!)
    What I did for my 128GB SD Card ..
    - remove SD Card from phone and insert into Linux computer
    - reformat SD Card as FAT32 and gave it a name ('SD128GB')
    - eject from Linux and re-insert in phone
    - install Mapfactor straight to SD Card 
    - it worked!
    I hope this helps others. 

    It seems (after searching internet) that another solution would be to change the Mapfactor app to explicitly ask for creat permission for the SD Card folder - obviously untested by me.
  • which filesystem was there before formating?
  • Not sure. Whatever an Android 5.1 phone (Meizu M2 Note) initialises it as - which I did twice (not sure how - I *think* it's an option when the phone notices that an SD Card has been inserted. 
    It's possible that it's not so much the filesystem, as giving it a volume name. 
  • I am having a similar problem when I start Navigator I get a message that "Navigator folder is set as read only".  It indicates that my devices has been updated to Android 4.4 or higher?  

    My devices has always been on Android 4.4.2 since I have had it for the past 4 months, and Navigator worked fine until I let it update my downloaded maps?  

    I read the instructions to delete the Navigator data in Android Settings, however that will delete all my maps on the external SDcard (2.83 GB of map data).   I have already downloaded these maps twice because of this problem and when Updated maps are downloaded I get the "Navigator Folder set to Read Only" message again !!   Is this going to happen with every map update?  And should I not allow map updates?

    I also have a device with Android 5.1.1 and I have downloaded several map updates and do not have the "Read Only" problem?

    Thanks for any help on this problem

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion