Folder set as read-only in Android 5
  • Running Navigator Free in Android 5 leads to error message as 'folder set as read-only...Android 4.4 or higher'. How can I get access to downloaded maps?
  • 11 Comments sorted by
  • try to delete data in Android settings/application manager/navigator and then reboot your phone. Please backup first, you could loose your favourites...
  • Note: on some devices there are still problem that navigator doesnt work with external sd card well... internal memory is working on all devices
  • Navigator worked well till I upgraded to Anderoid 4.4.2. Now it crashes and folders are read only. The folders are on the external drive and I can't even delete them. I uninstalled the program but the files remained and it still crashes on reinstall! My wife has the same tablet but mapfactor is not on an external card and works perfectly. Can you help?
  • close Navigator and delete data in Android settings/application manager/Navigator - then reboot your phone.
    Please take backup first, otherwise you could loose your favourites...
  • Tomas, why don't you recommend people buy another phone? Deleting your data is like kicking it in the ass. No, yours is not a solution, it is kicking in the ass. Solution means something intelligent.
  • I completely agree it is a pain in the backside, but please search the web. You have to blame Google (android), not navigator. It is the constantly changing approach of Google to safety and security inside Android. If you read the articles you understand why they are doing it, but it is simply blocking you from things you could do before and not anymore now. 

    I agree on one point though: What Navigator should do from my point of view, is releasing "android release fixes". If Google releases a new android changing security settings, like in 4.4.x and again in 5.x, Mapfactor should simply create an intermediate update that on install checks for the android version and current installed base, and copies that installed base to the new allowed location and start using that location if the android version requires that. 
    I assume it is then still up to the end user to remove the old data location (as "nothing" has write access anymore to the old location due to the new security settings).
  • @hvdwolf, I overheard a friend of mine saying that with android 6 the user has only one big storage area available, resulting from the sum of internal and external storage, which I assume, are managed by the operating system.. this is where android is going to...
  • I must admit that I'm not up to date with Android 6. I'm only referring to Android 4.4.x and 5.x. 
    I did not even think of 6 as the topic title was about Android 5
  • @hvdwold I am not up to date with Android 6 either and I don't know much about it. The most recent version I have ever used is 4.4.2... I made that off topic comment just to mention the latest changes in Android policies. 
  • I had problem with Android 5.1 - would install to Internal Storage but not SD Card. Read my comments on what worked for me at 
    Basically, reformat on PC as FAT32 and give SD Card a name e.g. 'SD128GB'

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion