Navigator closes/crashes after pressing "navigate"
  • Hello out there,

    I've been using Navigator on my BB Q10. It worked perfectly with the free maps but since I bought the TomTom maps, it became useless. I choose the desired destination and after I press the "Navigate" button, the app closes down. I reinstalled the app, deleted and re-downloaded the maps, but the problem appears to remain. The app keeps closing down, while it's still "kinda" running in the background. When I reopen it, the app runs a "data integrity check". Is there anyone experiencing the same?
  • 9 Comments sorted by
  • try to Reset to default in Settings/advanced
    you need to select Backup and delete
  • I don't need to resend the log, if I'm using a device that already had the TomTom maps, right?

  • Nope, it's not working. I tried the free maps just to see what it says... it works perfectly. With the TomTom maps the same error occurs. It's like it's cursed :)
  • in that case your SD is probably faulty, or even fake
    try to move Navigator to the internal storage

  • well, I don't have any SD card, I have only internal storage. And the free maps are being downloaded the same place as the Tom Tom maps. Well anyway, I've got a new Q20, I'll try to make it work there. 
  • Well, now I got an SD card for my Q10, I reinstalled Navigator, downloaded the maps, moved the whole folder to the SD card. I launch Navigator and it says "the application requires an SD card". I moved the whole thing back to the internal storage and in the advanced settings I try the "Change installation SD-Card" but I can't get in. It says "cannot change installation SD-card. System appears to have only one SD-card". So, I don't know... 

    It runs perfectly with the free maps, but they lack many streets/locations. I payed for the TomTom maps, but the Navigator refuses to run with TomTom maps. I bought an SD-card only to be able to (or hoped that I'd be able to) run Navigator with TomTom maps. Is there anybody that can give an advice??? 
  • And please, you guys at Map Factor don't misunderstand me. I appreciate your work and in fact, your free version of the maps runs perfectly and it's not your fault. It's just a bit ironic to spend 30 euros for get some extra service out of a free app and not being able to use it. Please, keep up the good job. It's not a criticism of your work.
  • We dont officially support BlackBerry. BlackBerry has some limitations in emulating Android apps. As I know from one user, BlackBerry quite well runs Navigator 1.6.x but not version 2.x.
  • yes, and it runs perfectly with my Lenovo tablet so... no big deal :) 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion