How do I transfer a Route from PC to Mapfactor on Android?
  • Hi!
    I have been trying the following:
    I use Linux, I want to plan a route in qlandkarteGT (OSM map) and transfer the waypoints to my Android Phone using Mapfactory Navigator with OSM maps.

    For this, I marked waypoints in qlandkarteGT, exported them to gpx, translated the gpx file to Mapfactory format using gpsbabel. So far so good.

    Then I used a text editor to transfer the resulting points to favourites.xml, but when I move the file to the mapfactory directory, I can not find the points in "my locations".

    Also when I edit the points to routing_points.xml I cannot find them when starting the navigator app.

    I make really sure that the app is stopped before transferring the xml files to the smartphone.

    Navigator is installed on the external SD card, there is a directory named "navigator" from which I took the xml files, transferred them to the linux PC to edit them and transferred them back. No effect.

    Also I tried editing routing points in MapfactoryNavigator in the App, but these only show up in the App,  not in the xml files.

    Where is my error ? Do I edit the wrong files or in the wrong location ?  The Android File explorer shows that I am using files in "/storage/extSdCard/navigator".

    On the device memory, there is also a "navigator" directory, but it is empty.
  • 12 Comments sorted by
  • Hi Tomas!

    Thanks, that is where I got the idea to try this, and the hint at "routing_points.xml" in the last comment to this app is basically how I tried it.

    The reason why I did not try this app: I run Android 4.4.2 and it is not rooted. Due to the file permissions, you need to root the android or use an Android 5.

    Now I transferred the route "manually" to the phone: I searched the waypoints in the navigator app on the phone and added the route by using the "start", "waypoint", "destination" flags. This route saves alright, but again it does not display in the xml files.

    Am I missing a step like for example translating XML to a navigator binary format or vice versa ?
  • sorry, I do not understand, you are adding waypoints by editing routing_points.xml manually and then copy to your device?

  • Yes.

    1. I copy routing_points.xml (or favourites.xml) from the smartphone to my Linux PC using owncloud

    2. I manually edit the waypoints that I have generated using qlandkarteGT as tool and that I have transferred from .gpx to Mapfactory Navigator xml format using gpsbabel ( gpsbabel -i gpx -f infile.gpy -o mapfactory -F myxmlfile.xml) to the xml file (using Kwrite)

    3. I transfer the xml files back to the navigator directory on the device

    4. I launch Mapfactory Navigator and expect to see these route points when I go to "routes" or "my places".

    However I don't.

    Also a route that I created on the device did not show in the xml files when I transferred them to the Linux PC.

  • The Idea comes from a comment of a user (D. Kortz) who had tried the android app, but failed as he also has Android 4.4. It is the last comment on the page of the app.

    The mapfactory format had been added to gpsbabel by someone who -if I remember correctly- was intending to also import gpx data to mapfactory navigator. So I guess I am missing an important step in between.

    I hope someone has a hint that points me in the right direction.
  • I am not a linux user, I have no idea what qlandkarteGTis, or any other tools you have
    I use text editor to edit favourites.xml ?
  • Yes, "Kwrite" is a plain text editor.

    qlandkarteGT is a powerful open source OSM map and track/ waypoint editing software. It also exists for windows.

    I used it to generate the gpx file.

    Then gpsbabel was used to generate the Mapfactory xml statements and the editor was used to copy them into the xml files.

    Looking at your answer in this question:

    I wonder whether I should re-import the xml files in a totally different directory ? However the path android/data/com.mapfactor.navigator/files/navigator/ does not exist on my device, there I can only find android/data/com.mapfactor.navigator/files/Download/ and all these directories are empty.

    I also checked the "logs" directory, hoping to find a file (maybe with parsing errors) but no new navigator log was created.
  • I thought you copied favourites.xml from your Android device - which folder was it from?
  • I used favourites.xml from /storage/extSdCard/navigator (I installed navigator on the SD card in order not to fill up the device memory with maps).

    I copied and pasted the waypoints in Mapfactory XML format into the file and copied it back into this directory.

    When this did not work I tried the same with routing_points.xml from the same directory.
  • go to Settings and click Send logs
    mark it for my attention
  • Done.

    Question: are you a Mapfactory Employee who is working on Sunday for our benefit ?

    If yes: I think then we can postpone the topic.

    I have entered the route that I needed urgently manually, now this thread is for me to learn "how to do it right" next time. Hence it is not urgent enough for someone to work Sunday hours on it.

  • Tomas took a look at my logfiles.

    Seems like I have somehow messed up the installation- will re-install in a few weeks and then I will add a comment here whether it works after that.

    Thanks a lot Tomas!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion