PC Navigator 14 installation
  • Hi,  I installed Navigator free 14.  "Install application" and "Install map data" setting itself were no problem.  But the program did not open.  the error message says "Setting files not found. Application will exit now.".   In "Install map data", I used "Manage map downloads", and I assigned Taiwan map among Free regions.   Please let me know what's wrong.   Do i need set a special folder name before setting map install?  If so, how do i?  Or other actions do i need?
  • 22 Comments sorted by
  • Hi,

    I finally managed yesterday to get version 15 installed.
    Here the problem was that the setup utility after updating itself to 15.0.2 lost the original setting "Early map access". As soon as I ticked this option again navigator 15.0.2 appeared and was then installed.
    This worked on Windows 7, Windows 10 and WINCE.

    However not on Windows XP, there the Setup Utility also said it's updating itself to 15.0.2 and then has to restart what it did too. But it always came up as 14.1.2 and of course tried to install 14.1.2 navigator.

    I worked around it in the way PrzemekSupak wrote, take the installation files from a win7/10 installation and put it on XP and execute them.
    setup_pc_navigator.exe for Windows
    pnp_app.rar for WINCE

    This installation procedure in the last years has always been a pain.

  • What an installation mess!
    Every time MF brings out a new WIN/WINCE version it's a problem installing it.

    On Windows I had 14.3.2 installed and the Setup showed that it needed an update to 15, so I agreed and the setup utility 15.0.2 came up. It happily worked along and installed the old 14.1.2 again, destroyed the newer version and all my settings.

    Ok, I thought I did something wrong, so I deinstalled MNF and manually deleted all remaining traces of navigator on the disk. Then downloaded the installation software again from the website and what does it install; 14.1.2 again.

    Here again the socalled 15.0.2 Setup Utility installed 14.1.2 on my SD-card.

    So where do I get a correct version 15.x installation file that really installs the new version?

    Even if the windows branch is kind of neglected, maybe MF one day can come up with an easier installation/update method that doesn't drive me crazy every time.


  • are you opening Navigator FREE, or the commercial version?
  • I tried to open Navigator Free on Win7 and Win8.1, but got error.
  • try start/programs/navigator/pc navigator/navigator free (default settings)
  • I tried your instruction. The result "defined path not found".   So I describe what I did my Instllation, bellow.
    Please tell me what's wrong:
    1. click Download Setup Utility(windows) on mapFactor site
    2. Start "NavigatorFree_install"
    3. Select language "English"
    4. Select Destination Location of Setup Utility, "C:\Program Files (x86)\Navigator14\Setup Utility"
    5. Select Start Menu Folder, "Navigator 14\Setup Utility"
    6. Select Additional Tasks, check "Create a desktop icon"
    7. Ready to Install, click "Install", 
           Destination location:  C:\Program files (x86)\Navigator14\Setup Utility
           Start Menue folder: Navigator 14\Setup Utility,
           Additional tasks: 
                Additional icons:
                    Create a desktop icon
    8. Shortcut icon appears on desktop, and "Enter product key window" appears, then click "Use free key"   and "OK", then "Product key accepted" appears, then click "OK"
    9. "refer Folders" appears, it says Please select the path where downloadable content will be stored,
        "Navigator" folder is under "ProgramData" folder, "14.1" folder is under "Navigator" folder and it is highlited.  Folder tree is the below;
               Local disk
                               --5 folders here,(14.1, Data, Help, Install, Setup)
    10. then click "OK", NAVIGATOR FREE window appears for "Install application" and "Install map data"
    11. click  "Install application", next click "Install PC Navigator"
    12. Licence Agreement, I accept it.
    13. Select Destination Location, "C:\Program Files (x86)\Navigator14\PC_Navigator" apperas, click Next
    14. Select Start Menu Folder, "Navigator 14\PC Navigator" appears, click Next
    15. Select Additional Tasks, "Create a desktop icon" with checked mark, click Next
    16. Ready to Install, it says the below, click Install,
        Destination location:
            C:\Program files (x86)\Navigator14\PC_Navigator
        Data location:
        Start Menu folder:
            Navigator 14\PC Navigator
        Additional tasks:
            Additional icons:
                 Create a desktop icon
    17.  then map data installation comment window appears, click Yes
    18.  click "Manage map downloads"
    19. select "Free regions", "Taiwan OSM", then click Next
    20. select "English (US) as Voice language, then click Next
    21. "Operation was completed successfuly" appears
    22. two icons appears on desktop, 
                "PC Navigator 14" and "PC Navigator 14 FREE"
         four icons appear on windows appli
                "PC Navigator 14" and "PC Navigator 14 FREE"
                "PC Navigator 14 (default settings)" and "PC Navigator 14 FREE (default settings)"
    23. double click these icons, but all icons generate error message "Setting files not found. Application will exit now"

    I am not an expert of programing, so please tell me what's wrong my setting and how do I do.
  • I think you are installing v14 and maps for v15
    are you using this link?
  • Hi, tomas, Yes, I used http://navigatorfree.mapfactor.com/
    I fogot to delete Navigator folder in ProgramData, when re-download setting.
    Again, after deleting Navigator folder in ProgramData, I tried to download all data related Navigator with checking holder contents step by step.
    The difference is;
    In step9.   Under Navigator folder, only "14.1" holder exists. Folder tree is the below.  14.1 folder has no data at this moment.
               Local disk
                               --14.1     : previously 5 folders here,(14.1, Data, Help, Install, Setup)
    Others are the same.  After installation, there are Data, Help, Install, Setup holders.  
    I checked data in each holder.  Except for Setup holder, they seem to be OK.
    Setup holder has no data.   Is it OK?
  • Hi, the situation is stii the same, "Setting files not found. Application will exit now." error comes up.
    What's wrong?   What Setting files should be?   And what folder should has those files?
  • (btw)
    Thank You for new Navigator 15.

    ...if Your Setup Utility 15 can't see this update, delete files from folder ProgramData/Navigator/x.y/install
    and install PC Navigator15 once again.
  • I deleted all data related Navigator, then installed again. But the same error, "Setting files not found. Application will exit now". I checked folders and files data. So map files are in "Data" folder.Navigator folders are the below;

     -- Navigator
    -- 14.1
    -- Data
    -- espeak-data
    -- fonts
    -- images
    -- earth_osm.mca
    -- sounds_en_us.mca
    -- sounds_xx_signal.mca
    -- taiwan_osm.mca

    Program Files (x86)
    -- PC_Navigator
    -- config
    -- map
    -- Setup Utility

    -- Roaming
    -- Navigator
    -- 14.1
    -- x.y

    Files seem to be OK. But I found the error on Setup log in x.y folder, "trayutil"

    DMP 2015/08/12 10:37:20 Tray utility started.
    DMP 2015/08/12 10:37:20 RcfReader: failed to open C:\Users\??\AppData\Local\Temp\regions.dcf
    ERR 2015/08/12 10:37:20 SettingsCollector::constructor loading C:\Users\??\AppData\Local\Temp\regions.dcf & C:\Program Files (x86)\Navigator14\Setup Utility\dvd.dcf failed.

    Navigator doesn't work on Win8.1 Japanese version? Because Japanese version has Japanese character folders. There is something wrong. \??\ folder name is Japanese character. I can not use Japanese character name Folder? Should I change to English name?
  • yes, please change to English

  • I'm having the same troubles as Uli:
    *) Navigator version 14.3.2 was installed
    *) Setup Utilility forced me to update to 15
    *) I did (there is no alternative)
    *) now Navigator version is 14.1.2

    Uninstalling, deleting everything (except maps) and reinstalling installs Setup Utiliy 15.0.2, but Navigator version 14.1.2.

  • Look at my post above. If there is Navigatorxx installation file on Your PC, setup doesn't download it again (and doesn't check version).
    Just delete all Navigatorxx installation files and klick on 'Install Navigator PC'.
  • As I wrote in my post, I deleted every Navigator related file, with no success.
  • Please, check folder 'Program files' and 'Program data'.
    I have new file (setup_pc_navigator ver. 15.0.2-1) in folder 'install'. I think there is no problem put it on open disk.
  • I repeat again: I DELETED EVERY NAVIGATOR RELATED FILE, which certainly means also in "Program files" and "Program data". I even deleted every Mapfactor-registry-entry.

    Result: Navigator version before is 14.3.2, after is 14.1.2

    The downloaded "setup_pc_navigator.exe" shows in it's properties product version 14.1.2-1. There is no 15.x version anywhere.

    Why isn't it possible to simply make this new setup-file downloadable in a direct way?

  • Finally I succeeded in installing Version 15 on a Windows 7 PC with running Navigator v.14.3.2

    I did following steps:
    • Navigator 14 Setup Utility - "Early maps access" is activated
    • Product updates - only option offered is "installer update 15.0.2" - answered "Yes"
    • Popup windows appears: "Archive file processing error" - File create error (C:\Program Files\Navigator14\Setup Utility\setup.bin) - "OK"
    • Another Popup window appears: "Setup" - Unable to start application (C:\Program Files\Navigator14\Setup Utility\setup.bin) - "OK"
    • Manually extracted all files from "...path to downloadable content...\Setup\setup.dat" to "C:\Program Files\Navigator14\Setup Utility", overwriting all existing files
    • Starting setup.exe directly from "C:\Program Files\Navigator14\Setup Utility\"
    • reactivating "Early map access" (thanks to Uli) - now PC Navigator 15 setup is offered and installs correctly
    • Proxy settings also disappear and have to be set again
    • The "Warning screen" welcomes you as "Navigator 14", but Info really shows v.15.0.2
    • Though the setup utility is about v15, the folder "Setup Utility" stays in "C:\Program Files\Navigator14"

    As Uli already said: The installation process for Windows PC is nothing Mapfactor can be proud of.
  • They are right.

    Here it is how it "worked" for me.

    Checked early maps in Setup utility 14.x.. I could update the Setup utility to 15.x. Checked early maps again. No new program version offered.

    Uninstalled Setup utilty from windows including "ok" to "delete data" when requested. Found Setup utility setup at mapfactor.com and installed this. Then "Applikation installieren" on Setup utility and it requested download of Navigator setup - ok. Started Navigator - no maps. Copied maps from directory program data\navigator\x.y\data to 15\data. Started Navigator again and voila map are there.

    Everything indicates Navigator 15, no more 14. Even the tray icon of the setup utility, which indicated to be version 12 even at version 14.

    No I wonder how Nav14 worked with directory x.y but Nav15 only with directory 15. Does this mean, that for future updates I have to move data to the then next directories 16 and 17 and so on?

    Renamed data directories 14.1 and x.y. to alt 14.1 or alt x.y. Nav15 still worked.  Deleted 14. and moved x.y to Desktop (because there are still copies of all data). Nav15 still works.
  • Oldie,

    you can always edit atlas_pcn_free.idc, in Win10 under ProgramData\Navigator\15.0 to reflect your map storage location.

    Use an editor with a search and replace all function because there are tons of lines to edit, at least one for every map you have loaded.

    I have all my data not on C:, e.g. F:\OSM-Maps\Data

  • @JambaFee

    Please tell us with which program you extracted setup.dat, because I had the same idea and didn't know how to extract it.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion