New Routing Mode -- EASY mode --
  • New Routing Mode -- EASY mode --

    Currently there are 3 routing modes, Shortest, Cheapest and Fastest. I would to see an Easy mode as well. This will not be the Shortest or Fastest but it will be the easy route using mostly major and primary roads.

    I have tried numerous road restriction configurations but I have not managed to find out the right configuration (disabling roads altogether creates more issues than solutions).

    Wonder whether an Easy mode can be developed.
  • 12 Comments sorted by
  • Assigning high priorities to major and primary roads should be enough.. doesn't it work?
  • Unfortunately not. Mapfactor seems to disregard the priorities and go its own way. :-S

    I can force it by disabling all other roads apart from major and primary roads but this creates a lot of other problems.

    Somehow the way it calculates routes is not consistent, for instance, the route to a place was different from the route back. The route back it was the "easy" route that It should have been the same going to. I do not understand why the routes were so different.

    Also, the routes are different from other nav apps as well. For instance I get different routes from OsmAnd and CoPilot using very similar routing parameters.

    Mapfactor is great but others are catching
  • Try delete settings.xml file.
  • @PrzemekSupak  

    I cannot find the settings.xml file.  I can see a vehicle_profiles.xml file. Could this be the same one?
  • Please wait for comment from Mapfactor team, or check it in previous posts.
    WindowsCE has settings.xml and del it helps with preferences issues.

    As far as I remember, answer is 'yes'.

    Check 'Restore initial settings of Navigator' in menu/advance.
  • if you cannot find settings.xml file then it may not be possible to get created
    check that your SD is not write protected
  • Not write protected.
    There is no settings.xml file. I have in both v1.4.24 and v1.6.13 the vehicle_profiles.xml file ( android version).
    I deleted it and it was recreated with the default settings - but has not resolved my issue
  • Could You please show it on map. The most possible reason is issue with map.
    Try set 70 % for motorways, primary, secondary roads and enable small local roads.
  • I thought you are using WinCE version, 1.4.24 and 1.6.13 are Android versions, there is no settings.xml
  • I used your suggestion - its getting better. Most of the route is as expected now. One more thing to work out.
    I get the same behaviour on both latest TomTom and OSM maps

    See screenshots. 

    First shot - Mapfactor route calculation
    Second - how it should be forcing it with a waypoint
    Third - CoPilot route calculation

    I suspect that the destination point could be a culprit as well. 

    Thanks to both - you are a great help.

    @tomas - just a thought -  is there any way to save Profile parameters with every route ( ie within the Routing_Points.xml file).




  • Try my preferences:
    Change in setup, for a while, to metric (km/h).
    Add new car, fastest, max speed 110 (km/h).
    140/90/63% for motorways,
    65/40/50 for small local roads.

    Routing goes always A605/A1 or, for different destination, A605/A1139.
    Now,if it works well, change speeds and preferences for better time calculation.

    I have three, four different car profiles for standard or comfort routing.

    Start from Oundle.

    With new maps, all preferences above are NOT current!
  • @Stavrich - you can save different profiles, but you cannot assign them to specific routes

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion