Message "Android Auto does not respond"
  • From one day to another I get the following effect when starting Navigator via Android Auto: The screen stays blank and after a while I get the message "Android Auto does not respond" offering me the options to exit or wait. Selecting "wait" just repeats the procedure.

    Maybe related: Just before that issue, Navigator was not always shown in Android Auto's launcher. I didn't find a way to reproduce this, sometimes the app was shown, but most of the times not. When shown, Navigator could be started and was perfectly working via AA. Now, Navigator is again reliably shown in the launcher, but can not be used as described above.  

    AA: 9.4.631624-release
    Navigator: 7.3.26
  • 16 Comments sorted by
  • I've also got the the same problem. Same versions of AA & MFN. Android OS 13 running on Samsung Galaxy S21 FE. I've uninstalled then re-installed AA & MFN but problem persists. All other apps in AA running without problem.
  • Unfortunately, same result with the 9.5.x version. As jd517 has mentioned, all other apps are working as expected via AA. The issue shows up on Android 11 and 13, both Samsung mobiles.
  • I have the same issue, Moto G7, aa 9.4.631624-release with a Pioneer AVH Z5200 DAB.
  • I tried to downgrade Navigator but it won't install.
  • Every time Navigator is started, it asks if I want to buy TomTom maps. This usually only happens occasionally and not every time.

    Could this be the cause of the "update" message and the issue ?
  • To my understanding "update" appears if the "Android auto does not respond / Wait / Exit" message can't be displayed because a second app is using a part of the screen and it is the message that is "updated". Does this message show up even when Navigator is the only application on the (in that case blank) screen?

    Does the suggested AA version 9.5.x changes anything for you?
  • I don't know if this is relevant or not, but I have HD traffic and alternative routes. However, the issue also occurs when these features are disabled in the settings.
  • I am just using the free version with no premium features.
  • I can confirm that AA version 9.5.6318 does not work.
    It looks like the problem is with the Navigator App update.
    I have also purchased alternate routes, remove ads, online search, HD Traffic and TomTom maps.

    As far as I can remember, when it was working, the app could not be opened on the smartphone while AA was connected. Now the app can be opened on the phone anyway.

    Unfortunately, this makes the app useless to me.
  • Updating AA to 9.5 didn't work for me either.
  • On the plus side the advert on navigator exit has stopped working as well.
  • I can confirm that MFN 7.3.26 opens in AA 9.5. Thanks for the quick response.
    Sorry. That should be 7.3.27.
  • I've just tried 7.3.27 from the link above and that connects to aa and works as expected.

    Thanks to the Devs.
  • I confirm that the APK from the link above is now working properly with AA.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion