Moving favorites in "MY PLACES"
  • I don´t know since when it was changed, but with 3.0.90 I can´t move under "MY PLACES"
    "MY FAVOURITES" by holding und moving. I can only hold and tip "Move up"
    or "Move down". In "MY ROUTES" I can hold and move the route up and
    down. In "GPS RECORDING" I can´t move them anyway!? I know that
    "FAVOURITES" have worked before the way "ROUTES" work now.
    New favourites
    are put always to the end of the list. Therefore it is much better to
    hold and move instead of hold an tip "Move up" many times to get the
    favourite to the top.
    I know I can sort them with A-Z or Z-A, but that is not the same. I want the favourites sorted the way I use them often!!
  • 52 Comments sorted by
  • please check android settings/accessibility/vision
    if off, then you can drag, if on, you get menu
  • Hi tomas,
    thanks for answer, but that can´t be the reason.
    It has been the other way before and it works with "MY ROUTES" but does nor work with "MY FAVORITES"!?
  • well, I tried it and developer was correct - not implemented in My routes
    not sure why you don't try it
  • Sorry, don´t understand, my english is not so good:
    Try WHAT? Do you mean try to change the android settings? I have Android 6.0.1. What do I have to change?
    I have many submenues in vision!?
    But why should the developer make a difference in moving the points between "MY FAVOURITES" and "MY ROUTES"?? And I know, that this constellation has change before. I know definitely that I could move the favourites by hold and move in "MY FAVOURITES" last year!!!
  • in Android settings go to Accessibility, then Vision and disable it
    move up, move down, is for users with bad eyesight
  • In Android settings - Accessibility - Vision I have the following Submenues:
    "Dark Screen" grey can´t be changed
    "Rapid key input" grey can´t be changed
    "Speak password" grey can´t be changed
    "Font size"
    "High contrast fonds"
    "Magnification gestures"
    "Notification reminder"
    "Negative colours"
    "Colour adjustment"
    "Accessibility shortcut"
    "Text-to-speech options"

    What do I have to change??
  • on first line I have Switch Access
    Android 6.0.1
  • I would like to sent you my screenshots to show you what I see, but I don´t know how to sent a png!?
  • How ever.
    I have seen in other discussions, that there are screenshots in the comments, how did they manage that?
    Copy and paste does not work, too many characters.
  • You will have to upload images to a server like There you get a link, which you can insert into to field klicking on the "Insert Image" icon in the editing menu of a post.
  • tomas, here are my screenshots


  • I do not know, may be under Manage accessibility?
    on my Samsung it is on the first line
  • I don´t find that settings. Could you send a screenshot of your settings?
    I tried with a Samsung S3 mini Android 4.2.2 there it works with "MY FAVOURITES". I can hold and move the favourites and the routes!!
    On an Samsung Tab 4 with Android 5.0.2 it does not work, ther I can only hold and move the routes, as on my Samsung S5!?
    All three have the latest Version 3.0.103.

  • Now I got that setting! The reason was, that I deactivated "TALKBACK", because I thought I wouldn´t need it.
    Now I could set the "Switch access" to "On".
    But that changed nothing in Navigator. I can´t hold and move in "MY FAVOURITES", only in "MY ROUTES"!!??
  • it should be off
  • YES!!!
    Thank you very much!!
  • Hi tomas,
    now I got a new Smartphone with Android 10 und have Navigator 6.0.233.
    Here I got the same problem as described above. I can hold and move "MY PLACES" but not "FAVOURITES"!?
    Do you know a solution?
    Best regards
  • favourites and my places is the same thing, isn't it?
  • Sorry,
    I meant in "MY PLACES", I can hold and move "MY ROUTES", but not "FAVOURITES"!?
  • it works as it should for me
    not sure why it doesn't for you, possibly some Android settings - in old Android it happened when visually impaired settings was on
  • I can confirm this misbehavior. In My Places, items in My Routes can be moved by drag and drop, whereas in Favorites, trying to drag an item opens a dialog which, among other options, offers to move the item up or down.

    Don't know if it's a bug or a feature, also from formerly versions, I don't know any other behaviour. It's a kind of beauty mistake which is not essential to survive with MFN in the outbacks ;)
  • this is not bug, it is feature for visually impaired
    please check your Android settings
  • Just to understand: where is the difference between "FAVOURITES" ans "MYPLACES"?
    Both are xml. files: "favourites.xml" and "routing_points.xml" and I could change the sorting in an editor.
    What has this to do with visually impaired settings?

    As you can see in my former notes, I found a correction on my old Samsung S5 as I activated "TALKBACK"!? Then I could see and change the "Switch access".
    Now on my new A40, I installed TALKBACK, but found no switch to make a change!?
    And has someone an idea, where I can look for them in Android 10, Samsung A40?? German version?

    2highlander: I agree, it not essential, but I have about 10 "normal" favourites. Now I planned a holiday with several overnight stays, which I want to have at the top of my favourite list for the next weeks. But every new favourite goes to the end of the favourite list an I have to move each of them manually to the top.
    Even with 10 existing favourites it means 10 times clicking and moving up with 15 favourites means together 150 times clicking and moving!!! It could be much much easier with holding and moving.
  • I can replicate this when I set voice assistant on in accessibility/screen reader (Android 10)
  • But with voice assistant on I can´t use the phone...
  • not sure what do you mean, I wrote that it should be switched off to drag favourites
  • It was switched off but does not drag favourites.
  • then it is some other settings, something to do with accessibility I would think
  • Just for information:
    XIAOMI Redmi Note 4, Android 10, Navigator 6.0.233
    Dragging My Places works here all ok
  • I never understood the different behavior of Favourites/My Routes. What behavior ever, it would make more sense if both would behave in the same way ...

    Galaxy S5 and S9+, both voice assi off, same behavior. My Routes is dragdrop, Favourites are not.
  • As you mentioned Samsung Galaxys, I also checked my S4, Android 10, Navigator 6.0.233, same Android settings.
    Moving Favourites by dragging does NOT work on this device. Just clicking and moving up 1 step.
    Same LineageOS version 17.1 as my Xiaomi where everything works.
    For me that seems to be also device dependent.
    Very strange.

    Edit: checking Sony M4 Aqua, Android 6.01 Sony Std, Navigator 6.0.228 and 233, all works ok
  • NOT working on Samsung A40, Android 11, UI-Version 3.1, Navigator 7.055
    NOT working on Samsung S5, Android 9, Lineage 16.0, Navigator 7.055
    NOT working on Samsung S5 mini, Android 6.0.1, Navigator 7.055
  • please email support with details, your description is far too vague
  • See my first statement from April 2017!!
  • Or the discussion of October 2020
  • please send your route with waypoints, then we can check what the problem is
  • we have not received anything from you
  • Hi Fratzfelix,
    To solve your problem, you can rename your favorites with a number in front of the name in the desired order like:
    and then organize the display with the A-Z function


  • MacDony: That doesn´t help me. If I have 10 older favorites, and I plan another route with 5 new favorites, they are all at the bottum of the column. To get them to the top, I would have to rename all of them!!
    Because the old 10 have:
    The new ones I have to rename :
    but before that I have to rename the old ones to
    How should that work practically?
  • tomas:
    I want to move my favourites under "MY PLACES"
    "MY FAVOURITES" by holding und moving. I can only hold and tip "Move up"
    or "Move down". In "MY ROUTES" I can hold and move the route up and
    down. In "GPS RECORDING" I can´t move them anyway!?
    New favourites are put always to the end of the list. Therefore it is much better to
    hold and move instead of hold an tip "Move up" many times to get the
    favourite to the top.
    I know I can sort them with A-Z or Z-A, but that is not the same. I want the favourites sorted the way I use them often!!
    As you can see above, you wrote that you could replicate it by setting voice assistant on in accessibility/screen reader, but I have it off!
    And Uli said that it works on XIAOMI Redmi Note 4, Android 10, Navigator 6.0.233, but it does NOT work on
    Samsung Galaxy S4, Android 10, Navigator 6.0.233.
    higlander said it does NOT work on his Galaxy S5 and S9+
    So there must be a fault depending on the hardware!!??

  • I think this is dependent on Android accessibility settings
    in old Android version it was visually impaired, it may be called something else in Android 10
  • Ok in this case, you can rename your points according to the route A or B or C
    etc ...

    or even create a folder of favorite waypoints for each trip.

  • tomas:
    I tried all settings in accessibility settings, nothing works!!
    And please try to explain, why it works with "MY ROUTES" and not with "MY FAVOURITES"!??
    And why I cannot move "GPS RECORDINGS" anyway?
    There must be a difference in the program-code!?
  • MacDony:
    And then? What about my next trip?
    Changing A to B, B to C, C to D, just to make a new A?
    That´s not the way, because I know that it worked before and it works on other hardware!
  • you need to restart Navigator when you change Android settings
    I can replicate your problem when switching Accessibility Menu shortcut on (A11), but it could be also another settings
  • I know that I have to restart Navigator!
    What Menu shortcut do you mean?
    Under Acessibility I have the following points:
    -Recommended for you
    -Visibility enhancements
    --Hearing enhancements
    -Interaction and dexterity
    -Advanced settings
    -Installed services
    I think, I have all settings off.
    I have Samsung One UI Version 3.1, Android 11. What UI do you have?
    Maybe native Google has other settings?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion