Running Navigator Free on Win CE .Net 4.2 Core
  • Hi there,

    I'm trying to get the Navigator Free software working on my Transonic PNA-4000.
    It runs with Windows CE .NET Version 4.20 (Build 1088).

    I already copied the files (navigator.exe and so on) to the storage card, but now i have the following problems when i try to start it by clicking on the navigator.exe:
    first I got the error "Cannot find 'navigator' (or one of its components)...." so i downloaded the file zlib.dll (like proposed in another thread in this forum), but I'm not sure it's the correct version of it,
    because after putting it in the windows folder, navigator.exe now exits with the error "'navigator' is not a valid Windows CE application."

    I hope someone can help me.

    P.S: of course, i selected Windows CE device in the installation routine (MapFactor Installer).
  • 10 Comments sorted by
  • Just downloaded some other versions of zlib.dll (more exactly zlibce.dll and renamed to zlib.dll), but with them simply nothing happens after clicking navigator.exe :-(
  • I would guess that you probably have zlib.dll there, and what is probably missing is WININET.dll used for internet search etc. I am not sure if there is any dummy WININET.dll available on the net.
  • Didn't find a wininet.dll so far, but now the programm shows the splash screen after some seconds, but after that there are only two blue squares in the upper left and right corner of the display and I can't do anything...
  • If it already started (splash screen) then the set of DLL is complete ... but probably not suitable for your system (?). Which one did you add at the end?
  • This is one of them "zlib for WindowsCE Ver.1.1.4" written by Kazuo Adachi
    or zlib Compression Library 1.2.3 for Windows CE from OpenNETCF
    and a version that came with anonther program for Win CE that contained it in its own folder.

    Splash screen appears with both of the last two.

    P.S: The archive from OpenCFNET contains the zlibce.dll (which i renamed to zlib.dll) explicitly for wince/CE 4.2/ARMv4
    And my device has an Intel PXA255 processor, which is a ARMv4 afaik.
  • Advice? anyone?
  • I had a similar problem installing Navigator 11 on a CE device memory card.

    The installation went OK but when I put the card in my Actis 3 CE device it could not find Navigator.exe.

    The advice given by Directions in the UK was:-

    1. delete all on your sd card
    2. insert it in your PC
    3. start
    installation of CE version and install it to mobilenavigator folder (you need
    to create it first)
    4. install map data, best if you create a folder for it,
    e.g. data
    5. rename navigator.exe (in mobilenavigator folder on SD) to

    Excellent support from Directions, this solution worked first time.

  • Same problem here. Transonic PNA-4000 C with WinCE .NET 4.2 Core.

    First I added the missing zlib.dll to the program folder. It makes no difference which one you choose, both lead to the same result: Two blue boxes in the upper corners.

    I used execheck to find out more about it. The program says that commctrl.dll can't be loaded and
    \windows\coredll.dll doesn't export a function ordinary 1551
    \windows\coredll.dll doesn't export a function ordinary 1763
    \windows\coredll.dll doesn't export a function ordinary 1556

    Overwriting these two files with files from WinCE 5.0 breakes the operating system.

    Question: Is there way to get Navigator working using the functions provided in WinCE 4.2 or is the minimum system requirement WinCE 5.0?

    Got a step further: See here First Post, Step 4. Software is running but has graphic errors
  • Same problem here.
    I used the MioPocket-Package for the missing windows-files (zlib, ...)

    Any solution or hints ?
  • see comment at ... i.e.
    if you want to experiment with WinCE 4.2 device and version 11, you can try to replace exe by
    The problem is really with ::GradientFill(), Ordinal  1763, which is necessary to replace by some kind of "::FillRect". Hopefully there will be some official release soon.

This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion