fixed: Calculate route, Route not found crashes navigator free 2.2.44
  • Update: fixed in 2.2.51
    UK search for:
    CT161JA (Dover ferry port), add to places
    LL651DR (Holyhead ferry port), add to places

    LL651DR  as departure
    CT161JA as destination

    Route Info:
    Routing mode: Fastest
    Road restrictions: Off Small Local Road, Other Road
    Route Setup: Set Off: Toll Road, Charge Road and Congestion Charge

    Itinerary: Calculate route = OK 563 km

    Routing points: Reverse
    Itinerary: Calculate route = Navigator Stopped (report ok) and closes

    Route  info
    Delete all
    My places
    Set CT161JA  as departure
    Set LL651DR  as destination
    Itinerary: Simulate = Route not found

    select now Llanfawr Road, The Edingburgh Castle, ID=10154806746 (53.30739, -4.63026)
    this  works in both directions, simulate or calculate route.
  • 36 Comments sorted by
  • No, it is not enough. And I know that it is very frustrating when others say "it is working for me", especially when it is the only answer. But Oldie also specified what he did.
    And yes:  it is crucial to know whether you are the only one or that others have that same issue.
    And I say the same: The route is not found but the application does not crash for me.
    You also mentioned above:
    Routing mode: Fastest
    Road restrictions: Off Small Local Road, Other Road
    Route Setup: Set Off: Toll Road, Charge Road and Congestion Charge

    I tried your settings and I tried every combination of your settings: still no crash.
    I also tried the 
    As you encounter it on 2 devices I assume it is really a bug and "somewhere" in you settings and a setting which has not been mentioned yet, OR it is another application on both your devices that might interfere.

    And 1 minute later I found what is happening. With your settings:
    departure CT16 1JA
    destination LL65 1DR

    Menu -> Tools -> Calculate Route  ==> No route found, but no crash either

    Menu -> Route Info -> Itinerary (2nd tab) -> Calculate Route ==> CRASH

    I guess the others also did the calculation from the Tools menu instead of the Route Info menu.

    So yes: definitely a bug.

  • Good to know, especially as I always run the function from itinerary only

    Edit: no I do it always from itinerary with function show route on map, as this recalculates too
  • yes, from itinerary it crashes for me as well
    I have never used this :-)
  • problem is with LL651DR - it is on oneway street and there is no route out of there
    with TomTom maps it works

  • That I do understand. Not the crash, should it just not return "Route not found" as in Itinerary: Simulate. Instead of crashing/closing navigator free?
  • crash I cannot replicate
  • Happens every time when I do:
    Route info: Itinerary: Calculate route: CT16 1JA to LL65 1DR (UK)
    Not certain crash is crash? Looks like it.
    popup window: "Navigator is gestopt" (Navigator has stopped). Marshmallow 6.0.1 message?
    pressing OK: Navigator closes

    When I use:
    Route info: Routing Points: Simulate:
    pop-up: Calculate Route
    pop-up Window: Warning:
    "Route not found"
    pressing OK does not close Navigator

    Simulate catches: "Route not found",  Calculate route does not.
    Samsung SM-T810 (gts210wifixx) 9.7 inches.
    Happens with Map renderer Software and Hardware
    What else can I provide? Test? I have time to test this.

  • The same happens on
    Samsung SL-G903F(s5neoltexx) Lollipop MR (5.1.1) 1080x1920 pixels (full HD) with MFN 2.2.40
  • I cannot replicate this, Android 6.01, Galaxy Note Edge
  • I understand you can't replicate. Here this happens every time, is not random, every time in this situation.
    There must be away that you can get more information from my part: log, ...
    OSM UK date version 44-201606290.
    both are amoled
  • I have the same map data
    where is your log?
  •, File (11.3 KB total)
    Will be deleted on 15 August, 2016. Download link :
  • Do you have enough with this log? The issue is still there in 2.2.41.
  • I could see Route not found in the log, but I passed it to developers
  • OK, I'm available if anything else is needed.
  • I have same bug here.

    Initialy work very fine. After a move to SD card : crash. Uninstall, reinstall and now

    route not from J4L2R1 to Zoo de Granby.

    Thank you to help
  • Found the bug.
    Arrived point Zoo de Granby is set in the center of the park ! So cannot reach it in car !!!! Setting point in road near Zoo work !
  • Navigator should just say: "Route not found" as it does when simulating the route. And not unexpected close the application.
  • Navigator 2.2.43 (1.2 GB/ 2.7 GB)
    Galaxy Tab S2 - SM-T810, Marshmallow (6.0.1), ARMv7-A

    CT16 1JA to LL65 1DR (UK)
    included logs
    - one calculate: app unexpected close
    - one simulate

    mapfactor-Navigator, Files (5.47 KB total), content:
    - Calculate - navigator_160812_093311.log.txt
    - Simulate - navigator_160812_093541.log
    Will be deleted on 19 August, 2016. Download link
  • I get Route not found and I cannot see anything in your log
    may be programers will enlighten us, but you need to be patient as it is holiday season

    are you using default car settings?
  • @Tomas: I myself occasionally encounter crashes when a new version is installed. These crashes no longer occur when I have rebooted my phone. Maybe this should be a standard remark in replies.

    @Jan_Gruuthuuse: Have you already rebooted your phone after having installed the new navigator?

  • yes, standard practice power down and restart. Rebooting does not make a difference in this case.
    my opinion: is the way how the route not found is handled.
    Route Info: Routing points: simulate: route not found, app does not close
    Route Info: Itinerary: calculate: route not found not showing on screen, app closes.
    Have you tried: departure:  CT16 1JA to destination: LL65 1DR (UK)

  • tomas:"problem is with LL651DR - it is on oneway street and there is no route out of there
    with TomTom maps it works"
    There is a route out:

    (but that's another issue)

  • tomas: "are you using default car settings?"
    created a new car profile, left untouched: same behaviour, so answer is: yes
  • from calculated log:
    DMP 16/08/12 09:33:48 PROFILER: <1> ARouting::::findJoinedRoute - failed - 0.451 secs
    DMP 16/08/12 09:33:48 Routing::memSize() = 5057144 (after)
    DMP 16/08/12 09:33:48 Finding route failed
    DBG 16/08/12 09:33:48 Route stage find ended with failure
    DBG 16/08/12 09:33:48 Route stage find failed
    DMP 16/08/12 09:33:48 RtgCbk onComputeRouteFinished(found route ids: none)
    DMP 16/08/12 09:33:48 (JAVA) RtgNav::setMapMode(true,false,false)
    DMP 16/08/12 09:33:48 (JAVA) RtgNav::setLineToDestination(false)
    DMP 16/08/12 09:33:48 (JAVA) RtgNav::getRouteInfo()
    DMP 16/08/12 09:33:48 GetRouteInfo failed - route 0 not found
    ERR 16/08/12 09:33:48 assertion failed (line:103 in ../../src/RtgNavFwd.cpp)
  • 1. with starting point as per your screenshot it routes, but if you set departure before the roundabout then route is not found, even if I enable all road categories - in OSM it says Allowed access Customers, that may be the problem, it does not specify vehicles

    2. crash I cannot reproduce and cannot comment on log extract, but log did continue, so I do not think that bold line is the cause - we have to wait for programers to look at it
  • 2.2.44 issue remains "Itinerary: Calculate route = Navigator Stopped (report ok) and closes"
  • I have no crash for the route from the screenshot. As with @tomas there is no route found starting before the roundabout (why not found?). Latest UK OSM maps, latest beta of Navigator, Galaxy Tab4 8.
  • Snip...
    Sorry, it was the wrong thread
  • @oldie:
    I have the issue with 2 different devices:
    - Samsung SL-G903F(s5neoltexx) Lollipop MR (5.1.1)
    - Galaxy Tab S2 - SM-T810, Marshmallow (6.0.1), ARMv7-A
    Booth with latest UK OSM maps, latest beta of Navigator. Navigator free should show the window "route not found" as it does when you simulate the route and not close all together. That the route is not found is another issue.
    It is like you're saying it works for me and @tomas and that's enough?
  • Sorry, but this was mentioned in my 1st post:
    "Itinerary: Calculate route = Navigator Stopped (report ok) and closes"
    Glad this is now confirmed.

  • chattiewoman: "Edit: no I do it always from itinerary with function show route on map, as this recalculates too"
    This is grayed out here?
    update: this works only after calculate route.
  • show route is in routing points, calculate route is in itinerary
  • 2.2.51 fixed the "route not found" crash from Itinerary

    Thanks for doing so

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion