Routing - accuracy?
  • I am a truck driver (delivery and collection work) and have done a couple of routes with Mapfactor which didn't seem accurate. One 'route not found' - I did read in another post that 'U-turns' should be unchecked but that made little difference.

    Two days; 10 may 16 was 'no route found' and 13 may 16 the route seemed a bit unusual. All I can compare it with is with Voyager app which seems to work fine (but alas uses google maps to check post codes so can't be used without signal). Perhaps I am using Mapfactor incorrectly - I am using it for routing and the satnav for driving. My satnav experience so far has been that problems are more likely if one tries to use waypoints and goes past a location to then U-turn. So perhaps someone can advise? mapfactor was with Car shortest route.

    I depart from the depot in Spalding UK and put the destination (although I don't go that far) as Norwich. This allows me to enter collections along the route when phoned. At each stop I enter the next in the garmin while I test out Mapfactor.

    10 may 16
    stops: PE30 4JL, PE30 0NP, PE38 0EQ, PE38 9JE, PE38 0PU, PE37 8FF, PE32 1JA, PE37 8DA, PE32 2UE.

    voyager - as expected, the trip is south from Kings Lynn to Little Ouse and then across East to Swaffham

    mapfactor - route not found

    13 may 16
    stops: PE12 8SG, PE12 7QW, PE12 8LY, PE12 8NG, PE34 3LW, PE38 0NL, PE33 9NP, PE37 7QA, PE37 7XD. PE32 1JE was a collection which when entered and optimised inserted in after PE33 9NP.

    voyager - seemed ok but drops 2, 3, 4, 5 differed with mapfactor


    thanks (sorry not sure why the images don't work... usually do on other forums - used direct link instead)
  • 15 Comments sorted by
  • 10 may 16
    postocde PE30 0NP is not a valid postcode

    13 may 16
    I have a completely different route, is PE12 8SG departure ans PE32 1JE destination?
  • nice of you to reply so promptly

    10 may 16
    sorry typing error PE30 0NP should be PE33 0NP. Broke my leg last sat so as I am in pain still it took me longer than normal.

    13 may 16
    ideally departure is PE12 8SG and destination is PE37 7XD. PE32 1JE was a collection I was notified of at noon. Added it, optimised it and appeared in the route after PE33 9NP which is correct... that was great.

    Perhaps my approach of using a departure i.e. Spalding was not the best and a far destination i.e. Norwich was too far. Point is once I am on the road I don't know when I will get a collection so I need to be prepared. To me it seemed best to allow the route for my area which is Spalding to Norwich.

    Having loaded in the route again, the order is still the same but the purple line is going to PE12 7QW i.e. A151 where as it was down the A17 to PE12 8SG.
  • Well I have put the 10 May route into Mapfactor again. Still the same problem. It seems there is a fault somehow as no problem with google maps. It would appear that there is a glitch in how Mapfactor does routing. I did get a similar message on another day but can't find the stops so probably deleted them.
  • then, I think, you set your vehicle profile incorrectly
    to get back to default close Navigator and delete file vehicle_profiles.xml, folder  android/data/com.mapfactor.navigator/files/navigator/
  • I've checked that. It doesn't matter whether set on car (fastest, shortest route) or truck (fastest, shortest route). PE38 0PU seems to be the trouble. Certainly a valid post code and compared with company address correct.

    By unchecking the 'tick' box all locations are correct but in grey. That provides me with what I want which is a plan view of all drops. I wonder if due to it being 8 miles 'out on a limb' it upsets the software when it calculates the route. Still the only app i can find that plots routes correctly having tried most available.
  • I do not understand what do you mean, please give more details
  • Please check whether you have (inadvertently) blocked certain road segments. Please check "Tools -> Disabled links"
  • Country is UK.

    Perhaps we should consider another route. Looking through the list it seems 9 May was also a wobbly. Also I should explain that the truck is loaded according to postcode which is not always correct - so I am using Navigator to check. I cannot always rely on merely a postcode e.g. PE32 1DJ, PE32 2RA being close as these two are about 15 miles apart. The order that a truck is loaded in is important as it is a case of 'last on - first off'. In this case; PE32 1DJ was before PE32 3RA, then PE37 7NP and PE37 7TN and lastly PE32 2RA. The truck was loaded with the two PE32s together, so I had to move them, do the PE37s and then PE32 2RA. Using Navigator helps me to avoid possible routing error and save time. Not to state the obvious but fuel as well and explanations to the boss if I have not completed deliveries and started collections.

    So I have used navigator as an offline map I suppose. (google maps is fine when one has a signal which in rural areas is variable). When I am given the collections at lunch time - I can enter them and maybe save time/fuel if a collection is close. It varies from day-to-day. I use a satnav to separately take me from stop to stop. Once fully happy with Navigator I may do all on Navigator.

    My routes are thus not 'round trip' due to the collections advised later in the day (preferences 'U-turn' checked). Start I leave as Spalding, and destination is either Dereham, Norwich or Fakenham. I enter the stops as waypoints and use Navigator to order. Mostly it seems to work well. I leave the vehicle as truck 'fastest' and haven't altered any road restrictions.

    9 May 16 produced another odd postcode PE38 0QH that I know is correct as it's a farm that I have delivered to several times but not since using Navigator.

    Start: Spalding   Dest: Norwich 11 stops in between
    PE12 8LA, PE30 5DD, PE30 4NG, PE30 4LA, PE32 1DJ, PE32 2RA, PE37 7NP, PE37 7TN, PE38 0PD, PE38 0QH, PE38 9LJ.

    The message comes up 'route not found'. PE38 0QH is only 3 miles down the A10 from PE38 0PD. If one unchecks all the boxes so the waypoints are now grey plots on the map, and no purple line between them - they have been ordered and give me their locations relative to each other. Excellent exactly as I need. But why doesn't the purple line work? Strangely enough if I enter the PE38 0PU from 10may16 it is just a few miles further down the A10.

    So I am wondering if there is a problem with certain locations on the A10 but that doesn't seem likely. If i was using Navigator as my satnav I would want the waypoints to default to unchecked and then check the one I am driving to.

    In summary; I like Navigator but it seems somehow with waypoint routing there is some problem that needs to be identified. You'll notice also that the two Swaffham drops between them take a road south in a loop that is certainly not correct.
  • you say truck, does this mean that you have TomTom Truck version?
  • No just the truck on the app with OSM. It doesn't seem to make a lot of difference with that of car. It may avoid some of the lanes. When I have compared the two so far there hasn't been much difference. Even with car 'fastest' v 'shortest' i haven't noticed much difference so far on the routes I have done.
  • truck attributes are frequently missing in free maps, routing
    would not be reliable.
    For that reason truck version is with TomTom maps only - Map
    manager/buy maps

    postcode PE38 0QH is on closed road, move waypoint to the A road

  • OSM lists the postcode PE38 0QH as a farm shop. The small access road, Steel's Drove, is shown in OSM as a track with only private access allowed for motor vehicles. This could be the reason for "route not found " messages & why Tomas suggests using the junction with the A10 as the waypoint. I don't know if the whole of Steel's Drove is a private track but if the shop needs acces to the car park from the track then this section at least should be marked as allowed access for motor vehicles in OSM.
  • Thanks for the explanation. It probably is a private track beyond the shop but that's like a lot of my deliveries. It seems that Mapfactor reads the OSM a bit more critically than the Garmin (with OSM installed), Here maps or Navmii.

    I am not using the waypoints to navigate by but rather to route by - not the way intended but works well for me. I use it for checking the routing the office give which is not always correct. Offline routing apps I found were fairly poor for the job. I will get the TomTom map for trucks though.
  • you can try to enable small local roads and other roads
  • Hello,

    enable small local and other roads makes no difference in the route from 9 May 16. But with WP "PE38 0QH" unchecked in the RP-List you'll get a route between the other points. So my way around this problem would be, setting start and end and the other WPs. Then in the RP-List tick off all WPs  but not the first one, start calculation and if getting a route take the next WP of the list start calculation again and so on and in the end you'll find the "trouble" making WP. 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion