Navigator unusable because it doesn't find Ext. SD-Card any more
  • Hello,

    I posted this in another thread already (, but meanwhile I believe that this is a different problem. That's why I open a new thread now. Additionally I had to expand the description in the end because the problem continues after I thought I had fixed it.

    The problem started after one of several map updates failed, but this might or might not be the cause of the problem.
    I have only OSM maps installed. My phone is a Samsung XCover 2 with Android 4.1.2
    1. Notification of updates -> chose to download them.
    2. During
      the last of several updates something went wrong, app said connection
      was interrupted. (Okay, that may happen.) Chose to make the last update
      some other time and closed the app.
    3. Next morning started the
      app. First error message something like "No access to external SD card.
      Maybe due to system update to Android 4.4?" and as I dismissed it
      second message: "No maps installed. Download?"
    4. I choose not to
      download, because I know they are on the device. I want to go to
      settings and check if the app remembers correctly that they were stored
      on the SD card. (Which is by the way perfectly accessible and I'm still
      running 4.1.2.) App exits, no way to interact.
    5. Restart app,
      choose download, so that I can somehow enter the app. Barely space on
      internal memory, luckily for Andorra + the mandatory earth.osm it is
    6. Now I can go to settings. Strangely the folder where my
      old installation including more than 1GB of data resides is identified
      as "Internal Memory" and the one where navigator moved itself just now
      as "External SD-Card 1". (I believe I realized this error before when I
      had chosen the so-called internal memory after my first installation of
      the app.)
      image(<- This is how I found the settings. I had chosen the opposite.)
      change the path back to so-called internal which is external really and
      close the app. It says it deletes some invalid data and exits.
    7. After
      restart it says for quite some time it verifies the integrity of data.
      But after some minutes and a restart it seems to work.
    8. Verified that the app works correctly
    9. Start the app again later that day to use it for navigating -> initial problem. First it complains that the Ext. SD card is write protected, later on it doesn't find it any more.

    Result: Can't use Navigator any more at all.

    Are there different ways an SD card can be mounted? Can anything have changed that is a problem for Navigator but not for other apps? Everything else works as normal as far as I can tell.

    Any help appreciated!


    (All messages' wording may have been different. My system is German and I didn't immediately take notes.)
  • 11 Comments sorted by
  • I found already in this post, that Navigator is not tolerant at faulty sync. So it is also not at faulty update. Maybe, it is the same problem.
  • (btw)
    It is good to see if there are no any maps, in data folder, with 'bak' ending/extention.

  • @Oldie: Maybe same problem. But definitely the same problematic behaviour coping with problems.
    @PrzemekSupak: No, there are none.

    Meanwhile I realize that Navigator is not the only app having problems accessing the card, so the cause is not Navigator. Just a bit annoying way to deal with problems.

    Anyway, although now this is a bit of abuse of this forum:
    The SD card is mounted, but read-only. This happens seemingly spontaneously.
    I have read that this has happened to other people as well and the only two "solutions" I found were:
    1. CHKDSK. I have had the file system checked by Windows
      (don't know whether problems were fixed because I forgot to uncheck
      "automatically") and afterwards it was okay again and an hour later it
      happened again.
    2. Card is going bad.
    Does anybody have any other hint?

    Best regards
  • Which one do you mean?
  • the one from Lubos
    This is Android bug and incorrect SD card setup by manufacter of your
    device, not bug of our navigator. If you delete
    Android/data/com.mapfactor.navigator on sdcard then it will be possible
    to move navigator on SD again. IF YOU WRITE TO THIS FOLDER ANYTHING OUT
  • @Lubos has one post there but two comments, I find.
  • A warning for those upgrading to Android 6. If you have your maps stored on the SD card and adopt your SD card as internal storage navigator hangs when opening with the message waiting for SD card, you will then have to force close. Will uninstall and reinstall to see if that cures problem.
  • Hello all,
    just to end my initial case: It was actually the card that was going bad. I had it checked in the shop and replaced it and now everything is back to normal. So the only thing on the side of Navigator would be to handle such errors better.
    And the confusion of "internal" and "external" in the settings.

    Best regards and thanks for your help
  • Uninstall and reinstall cured problem with Android 6.
  • I had the same problem and solved it the following way:
    - Took out the SD card, copied all content to my laptop (using the card adaptor in the laptop's slot)).
    - Put the card back to the phone and erased card.
    - Copied back the old content from the laptop. When asked, integrated old content in existing folders (generated by the phone).
    -It worked from then on without problems.
    Possible reason: SD card must be formatted by the phone, not by some other devices like laptop, factory etc.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion