External SD & KitKat, returns
  • Following the http://forum.mapfactor.com/discussion/6102/external-sd-kitkat/p1 thread, I've got a similar issue
    Xperia E1, Android 4.4.2, MapFactor 1.5.22

    If you use the "Move Application to SD card" feature (Androids application management) for MapFactor, MapFactor won't run if you shut down your device.
    It will go to the same error process
    "The Navigator folder is set as read-only.  This could be because the device has been updated to Android 4.4 or higher."
    "Unfortunately, Navigator has stopped."

    I tried many, many tricks to go around this issue:
    - backing up/restoring: not usefull
    - cleaning MapFactor data: as MapFactor is on the SD card, the data cleaned up include Maps, Favorites, etc.. very frustrating

    The only useful trick is "DO NOT MOVE MapFactor TO THE SD CARD!"

    Any other idea?
    Any new version with this issue fixed? (xperia E1 do not have a large pool of device storage)

    Thanks in advance

  • 7 Comments sorted by
  • I don't know why you want to move the app to the SD-card.
    The data is on the SD-card and can be large.
    The application is in internal memory using about 25MB. What's the big deal? If your run 4.4 KitKat you must have a reasonably new phone having at least 4GB internal memory. We are no longer living in the time that internal memory was sometimes as small as 64MB.

    I hope you don't mix up data space (SD-card or internal memory if you chose so) and application space (internal memory)
  • hum, as i said before, xperia e1 don't have enough internal storage (for me 25MB is not a very small amount)

    besides, I FOUND the trick, but I consider there is a bug in MapFactor:
    if MapFactor allow the "Move to SD card" feature so MapFactor must run correctly when it has been used
  • this is bug in Android 4.4.x
    the only way that I think you can get rid of it is to uninstall Navigator, delete folders navigator and android/data/com.mapfactor.navigator/, both on SD and internal storage and then start from scratch.
    Please backup your files.
  • thanks,

    I did reinstall navigator, but not this way
    I'll post here the results
  • This is Android bug and incorrect SD card setup by manufacter of your device, not bug of our navigator. If you delete Android/data/com.mapfactor.navigator on sdcard then it will be possible to move navigator on SD again. IF YOU WRITE TO THIS FOLDER ANYTHING OUT OF NAVIGATOR APP IT STOPS WORKING AGAIN
  • Hi,

    I uninstalled Navigator, cleaned up all navigator folders with FileKommander... useless

    I installed Navigator again, dowloaded maps and moved the app to SD card => the error pops again AFTER rebooting my phone
    (for my test I didn't touch anything else nethier on the SD card neither in internal storage

    thanks all for your kind answers
  • Try to clean navigator folder using PC not Android app

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion