Importing coordinates west of Greenwich (Android version of Navigator free)
  • Hi,

    I am currently in Ireland and use a free Android app called Irish Beach Guide to look for interesting beaches.

    This app doesn't show the beach positions on a map itself, but offers a choice of all apps on the device with mapping abilities.

    If I choose Navigator, it shows the beach to be somewhere in Germany or off the German coast.

    Obviously the "minus" in the longitude is ignored.

    If from the beach guide I choose Locus Pro (which just like Google Maps has no problem with the coordinates), and export the coordinates from there to Navigator, everything is fine.

    P.S. TomTom apparently can't handle this at all - bad maps?   ;-)
    I've tried three beaches, and in every case it told me "address not found" and then just showed my current position.
  • 5 Comments sorted by
  • please let us know what exactly are you inputing
  • I myself am not inputting anything.

    I run the free Android app Irish Beach Guide, select a beach and tap on the map icon provided by the app.
    This then gives mea  choice of apps to export the beach's coordinate to.

    I am just looking at Clogherhead Beach on my Android device.
    Its coordinates according to the app are  "Lat/Long   53.7887     -6.23486"

    Exporting this to Locus Pro or Google Maps leads me to the right place, whereas with Navigator I end up (when I tap "Show on map") a few kilometres north of Borkum (one of the West Frisian Islands) in the North Sea.

    When I then open Search/Coordinates  in Navigator, I see  "latitude  53.7866    longitude  6.23481" - no Minus sign.

  • when I insert 53.7887 -6.23486 in Navigator and click Map I get position near Strand street Co Louth
    same as Google
    I am not sure what are you doing incorrectly
  • Yes, but that is not what he is "saying". Navigator might do it correctly when directly typing it in, but not when importing it from another application.
  • Jochen, I suppose you are using 1.2.50 ... and there was related bug ...
    You can try latest development version (1.3.15+):
    if you need to return to Google Play version there is "stable" link

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion