missing streets
  • Hi,

    I recently updated Navigator free due to a crash of my android phone and reinstall of OS. The previously installed version had only one feature missing, the speedcam alert sound did not play, but besides of that bug the navigatior free performed very well. Current version plays now speedalert sound, BUT:
    When program has idled some time in background it will not reactivate, and will show a white screen instead, making necessary to reboot the phone to start again navigator free. Other Apps still work then.
    Second issue is, that navigatior free will not find most streets in Hamburg, where i live, anymore. There are several entries in cities selection dialog, named hamburg, but none of them show many streets in following street choice dialog. In previous Version there was an entry called "Hamburg (Landmasse)" where every street i ever searched was found, but this entry is missing in current version of navigator.

    Does anyone know about these Bugs ? Why is current version of Navigator so buggy an still online on update servers ? ^^

    jm2p Zeph
  • 14 Comments sorted by
  • Hi zephram,
    about streets you can read here:
    please let us have your comments should you decide to test the pre-release version

    as to blank screen - how long do you wait?
    I do not think that the current version is 'so buggy', it is very stable on my mobile
  • I also noticed the white screen twice with the current version. Unfortunately I cannot exactly say what I did before, but I think it was when switching to another app and coming back to navigator.
  • Same white screen sometimes here. Apparantly also, when Navigator is sent to the background and then activated again. At times I waited a couple of minutes in vain for Navigator to come back. I did solve the problem by shutting down ("Stoppen erzwingen" in German) Navigator at the app control center. It was not necessary to restart the phone.
  •   Same here, if I get any phone call or switch to another application on resume to navigator I only get a white screen and the only solution it's to kill the application and restart it
  • I just used navigator and call came in, I did not get white screen
    could you possibly email log after this happens?
  • I just installed the latest 0.13.30 version and I tried to simulate the same condition but it didn't happen again so maybe the bug it's gone. I'll try to test it on road and I'll comeback with the results
  • White screen will only appear after an hour idling in background or longer on my phone.

    Anybody an idea where the other entries for cities went to ? AFAIR the currently available entries for Hamburg didnt find many streets on any version ever...

    jm2p Zeph

    @Oldie: Thnx , I will try that
  • hi zephram,
    what do you mean by ' other entries for cities went to ?'
  • I installed version: 0.14.15 today, now I can find home again :P

    @tomas: At some previous version I had more entries for "Hamburg" than now at the current version. One of it was named "Hamburg (Landmasse)" (german version). I only was able to find my street when i had choosen "Hamburg (Landmasse)" as a city before, so as most streets in hamburg, i think. At current live version most streets are unknown under every city entry that points to hamburg. "Hamburg (Landmasse)" and some other entries for hamburg disappeared. In Version 0.14.15 there is some ranged mode für searching streets, it seems my street can be found again.

    Also the new version doesnt seem to have the white screen bug...

    jm2p Zeph
  • Ok I tried it on the way to work and I've done a phone call for 5 minutes, during the call I kept it on navigation and after I end it I went back to navigation and I found the white screen instead.  If you give me your email I'll send you the log files
  • support at mapfactor.com
  • Hi, I just sent the email with the log files, I hope you will find a solution soon.
  • Hi Cosmy,
    thanks for your log files - upload is now version 0.13.32 (the same link 0.13.x). It should better catch that problem and describe it into log. If the problems repeats could you (or others) please send us log from 0.13.32?
    thank you
  • Hi, the bug it's still there and I just sent you the logs again with the explanation how it occur.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion