Android NavigatorFree maps freezing (no panning/zooming possible) after installation
  • Hello Navigator Experts,
    I was using Navigator successfully for some time on Odys Aeon Android 4.1 tablet, mainly as OSM offline card reader.
    The tablet does not have GPS, so I am using FakeGPS (and Android App, which simulates a GPS receiver), after having made the
    Android Setting that allows such GPS simulations.
    As said, the setup worked very well for almost 1 year.
    Now I had to do a factory Reset of the tablet due to some other reason. After re-installing now the latest version of Navigator Free,
    it starts nicely, I have cleaned up the directories and maps and re-loaded maps, BUT whenever I open a map, it shows the FakeGPS location
    in the map, but I cannot pan or zoom. The map does not react on any touches. Even the +/- Zoom button just shortly invert (so they have seen
    my touch), but no reaction on the map.
    Anybody any idea ? Or can the developer team provide me a link where I can access a previous version of Navigator, in order to check whether an
    older version is still working. (I haven't made any recent App Update before the factory reset).
    Thanks so much for any help

  • 33 Comments sorted by
  • Thanks tomas,
    I tried the pre-release version, but it still shows the same problem, unfortunately.
    => still I cannot pan/zoom in maps, and I still appreciate any ideas.

  • maybe send logs to support (settings > send logs) and mention link to this forum
  • It hasn't got anything to do with fake/real GPS. The latest update made my Navigator not work any more. The same situation: the map screen is frozen and it doesn't change during navigation simulation. In the mean time, other apps such as OsmAnd or Google Maps work very fine. The is a major bug in the latest update. Mapfactor people, please repair that.
  • it works for millions of others, if you want us to see what the problem is, email logs to support
  • Hi folks

    same here. Used to work fine on my Dell Streak 7. One of the last updates broke it. Naviation still works, but map is not updating, it stays at position from App launch time. No Pan or Zoom possible. At next App start the map of the last position is displayed.

    Hope you can find the bug soon.

  • Same here. I'm using mapfactor for a long time on a Samsung Galaxy Tab 7.7 and it worked allways fine.
    Yesterday I want to use the app but after start and changing to map it does not work right:
    The map is not at the right position, it is not possible to move or to zoom and no action at the map.

  • I have installed the pre-release version. Same problem.
    Are there older versions available?

  • did you uninstall prior to installation?
  • I did both:
    First I installed it over the existing version. Same bug.
    Then I have deleted the user specific data and did an uninstallation and after that the installation of the pre-release version. Same bug. Android Version of the Tablet is 3.2. But note: until Jan. 2014 the app has worked absolutely fine. Since that time I did not use it because of using another navigation device.

    Now I have tried a new installation on my old Samsung Galaxy Gio (Android 2.3.3) and it works absolutely fine.

  • Now I have installed an older version (0.13.27) on my tablet and it works again. But I want to use the newest version too! Because of new display notices. So please look about this possible bug.
  • install the latest version
    and then switch off Google analytics in settings/advanced
  • Hi Tomas,
    My name is Vlad and I have the same issue. I did as you suggested above (installed + switched off Google analytics) but without no improvement :(
    Very love this App so will be more then thankful for the help
  • please email logs to support
  • Tomas, you keep saying "email logs".

    1. Are you linked to the developers in any way?
    2. Where are those logs to be found?

    There obviously is a problem for many users as the map screen stopped responding.
  • this is problem with Android 3.x
    install this version, if you have not done so
    and then go to Settins and click Send logs
  • That apk contains version 1.2.39. What I have already had was version 1.2.25. Neither works. Both have the map screen totally frozen.

    There seems to be no problem with Android 3.x. 
    all he other map apps work fine (Google Maps, Be on the Road, Osmand...)
  • may be you can send you device to our office, so that we can find solution?
  • Hello tomas,

    I have EXACTLY the same problem as is described in this thread. I use Samsung Galaxy Tab 10.1 model GT-P7500.
    Everything in the app works fine, just the map does not redraw itself. But if I for example rotate the device, so that display orientation changes from portrait to landscape or vice versa, thr map gets redrawn. Still the map navigation is unusable, because I would have to rotate the device there and back all the time.

    Are you the company employee? Were you able to reproduce this issue on any of your company devices?
    If not, I would be willing to lend you my device.
    Kindly write me an email.

  • yes, I am from Mapfactor
    so far we have not been able to reproduce this
    if you email, I will send you old version, so that you can use Navigator
  • Hello tomas,

    thanks for a fast response. What email should I write to? Should I use the general email info at mapfactor dot com ?

  • please send it to support (at)...
  • That is a bug in the newer versions of Navigator. 

    The problem appeared only after one update (of around 23 April 2014?). Previously I
    did use the app with success. Since ALL  the
    other map/navigation apps work fine on the tablet, it is clearly something
    wrong in the new versions, and NOT with your tablet.

    The screen stops responding, but you'll notice a funny thing: it gets updated with your previous actions when you change the tablet vertical position from landscape to portrait and vice versa.

    SOLUTION: until they correct this bug (which apparently they cannot figure out), you have to reinstall an older version of Navigator (like 1.1.5).


    1. Uninstall any version newer than 1.1.5.
    2. Install version 1.1.5. Don't worry, it is good enough, it'll do the job.
    3. Make sure you disable automatic updates for this app (otherwise, in a couple of hours, you 'll get stuck with a new buggy one).
    4. Check manually for a newer version every 2-3 months and see if they fixed the bug.
    5. If the bug is still there, revert to version 1.1.5 and go to step 3.

  • hello,

    I have the same problem.

    where to get the version 1.1.5?

    thanks for help.

  • Maybe we can convince the developers to post it again. 
  • mdx is away at this moment, when he comes back, I will ask him to make it available
  • OK, here is (permanent?) link to 1.1.5:
    The latest (experimental) version (now 1.2.50+) are available at
  • The map-freezing bug has not been fixed yet in version 1.2.50. Users with this problem should stick to version 1.1.5, It's good enough.
  • it will not be fixed until version 2 is out, sorry for any inconvenience
  • Hi tomas,
    any news about new version with fixed bug? When can we calculate with fixed version?

  • not until v2, a few months away
  • Any news about this freezing bug? No! It seems that the developers are waiting still all users with this bug will have a new smartphone/tablet with new android. No further comment!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion