Solved: Navigator Free Android: address navigation - start/target selection
  • If I select an address in the tablet's or smartphone's contact list and choose open with navigator free, the map shows an place within the ocean in the west of Africa. The "tooltip" shows an address with escaped spaces or special chars.

    The address was added using and was synced to my tablet and phone.
    "Straße" was spelled in full.
  • 14 Comments sorted by
  • Yes, if you would like to use "Google Play beta feature" it is necessary to be member of Google groups:

  • OK, it does not depend if it is Str. or Straße.
    And another bug is: I have to open Navigator Free, press the back button and select the address from contacts. Otherwise nothing happened. It just opens the app.
  • Thanks for the response.
    Is there no chance to use the new google play beta feature? Like the facebook app?
  • what is new google play beta feature?
  • Hi Martin,

    I visited your link but I get a "white body screen". There is a "tooltip" which says: You do not have permission to approve or reject applicants.
    (Probably this is your administration link?)
    So I clicked this link (!forum/mapfactor-navigator-android-beta-testers) by clicking on "MapFactor Navig.." on the left. There was an apply button and I filled it. So hopefully this works now. :)
    Your group is not listed in My Groups until now so I think there is an administrative user activation.

    Time will tell.

    Best regards and thanks for the support and app.
  • OK, "membership is pending". Great.
  • Still no update. So I tried the version linked by tomas here
    Now all addresses return an address not found error. Too bad.
  • So, now I finally joined the beta version (thanks to mdx) and the address adding is working again.
  • I am still using version 1.0.0 on Android and I have found an update issue that I am not sure of whether directly related to this one and already solved in 1.0.11:

    Until recently, I had two navigation apps: Google maps and yours.
    When I clicked on an address in a phone contact, I was first asked by Android which navigation app to use. I'd chose Navigator but would NOT select "remember choice". After that, Navigator would open, but stop at the main menu. No map would be opened.

    Lateley, I deactivated Google maps so that Navigator is automatically my main navigation app.
    Now, clicking on a contact address works differently:

    First try
    Navigator is directly opened. After some delay, the map opens and the selected address is shown correctly. Yippie :-)

    Second try:
    However, there is just one little bug in this scenario:
    While Navigator is still open, I return to my contacts to select another address. When I click on it, the map is immediately shown again - but with the first address. In order to show the second address, I have to manually reopen the map.

    And a question concerning handling: When the map is opened and pointing to my target address, is there another way to e.g. navigate to this address without having to click exactly onto the pointer? It's quite fiddly to hit it exactly.
  • this is solved in the beta blubb subscribed to
  • And what about the question at the end?
  • it will open menu, same as you get at the end of any search, where you select Navigate, or show on map...
  • While Navigator is open, I access my contacts and choose a new location to travel to. The map automatically updates to show the previous location whenever I do that. The second place wouldn't show up until I manually reopened the map.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion