Using command line argument configset
  • Hello,
    I am trying to start up Navigator (10 and 11) from command line with a different settings file (i.e. hide minimize icon, etc) but I type (as manual seems to indicate):

    PCNavigator.exe --configset=new_xml_setting_file

    and error message "Configuration not found in registry. Installation may be corrupt. Application will exit now." is displayed.

    So, what am I doing wrong? I've tried with absolute paths, relative, quotes...

    Besides, how can I edit default settings xml file? Cause I change default_settings.xml parameters with no result...

  • 5 Comments sorted by
  • Hello SEFOSA,
    parameter --configset refers to configuration in registry. In your case I would use --atlas instead and path to atlas_pcn.idc or atlas_pcn_free.idc, depending if you are using commercial or free version. Make a copy of atlas*.idc and modify it in your copy. Replace __USERPATH__\settings.xml to your alternative file.
    p.s. if you want to see changes in your default_settings.xml you have to delete settings.xml file first

  • Thank you!

    Just one more question, is it possible to disable the posibility to turn off the gps?

    I replace 'yes' with 'no' in the <turn_gps> within settings.xml in order to avoid such posibility, but after that app crashes when menu is clicked. With other menu items, this is working great.

    Best regards
  • Are you sure that your settings.xml is valid XML? I tried to use 'no' for "turn_gps" and it was ok (it just disappeared from main menu, as expected). Can you send me your settings.xml file?
  • Ok, this is the settings.xml that makes my installed application crash when menu is clicked. Just changing 'turn_gps' to 'yes', everything runs rightly.
  • which version of navigator do you use? I noticed settings_version 10009, which is not compatible with my 11.0.28 ...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion