Navigator FREE installation problem
  • I try to install Navigator FREE and I have two problems:

    - 1. problem: "Navigator 11 - Setup Utility" freezes after first start with following note: "Downloading current server data." It can not finish installation.

    - 2. problem: During note: "Downloading current server data."
    is possible to choose only "Settings" button and after click on on "Ok" in "Settings" dialog box, the whole program "Navigator 11 - Setup Utility" crashes. (FYI: Version info in the right down corner is: I1.0.15 FREE)

    The same problems occured in Windows 7 Home Premiun and also in Linux wine 1.3 (openSUSE)
  • 16 Comments sorted by
  • I tried to reproduce and it was ok - can you have a look in the log file
    (C:\Users\<user>\AppData\Roaming\MapFactor\Pocket Navigator Installer 6.0\setup.log)?

    Can you try older version?

    I guess that it is related to internet connectivity, but still it should not crash.
    p.s. what language do you have selected for installer?
  • I have the same issue with an English installer. It worked fine a few days ago but now does work today:

    DMP 2011/08/16 12:40:59 MapFactor Navigator installer application start
    DMP 2011/08/16 12:40:59 cmd line parameters: "C:\Program Files (x86)\Navigator11\Setup Utility\setup.bin"  "C:\Program Files (x86)\Navigator11\Setup Utility\setup.exe"
    DMP 2011/08/16 12:40:59 RcfReader: C:\Users\<user>\AppData\Local\MapFactor\Navigator\regions.dcf opened successfully
    DMP 2011/08/16 12:40:59 executable: C:\Program Files (x86)\Navigator11\Setup Utility\setup.bin
    DMP 2011/08/16 12:40:59 version: 11.0.14
    DMP 2011/08/16 12:41:00 Remote device connected:Windows Mobile 6 v5.2 build 19965
    DMP 2011/08/16 12:41:01 Remote device connected:Windows Mobile 6 v5.2 build 19965
    DMP 2011/08/16 12:41:01 HttpDownloader::downloading
    DMP 2011/08/16 12:41:01 HttpDownloader::downloading

  • I have the same problem with german installer; worked fine at least until 11. Aug, when I downloaded several maps (installer version 11.0.6)
    When I checked for new software on 14. Aug, installer got stuck as described above when trying to download the regions.dcf file (not crashed I think, it was still possible to open Settings dialog and close application).
    Internet connectivity in general I would exclude because I could easily access, when trying to download authorization was requested ...

    DMP 2011/08/16 20:25:15 MapFactor Navigator installer application start
    DMP 2011/08/16 20:25:15 cmd line parameters: "C:\Programme\Navigator11\Setup Utility\setup.bin"  "C:\Programme\Navigator11\Setup Utility\setup.exe"
    DMP 2011/08/16 20:25:15 RcfReader: D:\Documents\Karten\Navigator\regions.dcf opened successfully
    DMP 2011/08/16 20:25:15 executable: C:\Programme\Navigator11\Setup Utility\setup.bin
    DMP 2011/08/16 20:25:15 version: 11.0.15
    DMP 2011/08/16 20:25:15 Remote device disconnected
    DMP 2011/08/16 20:25:15 Remote device disconnected
    DMP 2011/08/16 20:25:15 HttpDownloader::downloading
    DMP 2011/08/16 20:25:15 HttpDownloader::downloading
  • regions.dcf on server was empty - we will investigate why. Now it should download data directly from Prague (falcon). If there is still a problem, please let me know.

    Edit: problem was in wrong symlink - it should be fixed now and run from robin again ... sorry for the trouble.
  • Hi Martin,

    works fine again, thanks a lot!
  • And what you can say about my log?

    DMP 2011/08/19 08:18:54 MapFactor Navigator installer application start
    DMP 2011/08/19 08:18:54 cmd line parameters: "C:\Program Files\Navigator11\Setup Utility\setup.bin"  "C:\Program Files\Navigator11\Setup Utility\setup.exe"
    DMP 2011/08/19 08:18:54 RcfReader: failed to open C:\Documents and Settings\All Users\Data aplikací\MapFactor\SetupUtility\regions.dcf
    ERR 2011/08/19 08:18:54 SettingsCollector::constructor loading C:\Documents and Settings\All Users\Data aplikací\MapFactor\SetupUtility\regions.dcf & C:\Program Files\Navigator11\Setup Utility\dvd.dcf failed.
    DMP 2011/08/19 08:18:54 RcfReader: C:\Program Files\Navigator11\Setup Utility\regions.dcf opened successfully
    DMP 2011/08/19 08:18:54 executable: C:\Program Files\Navigator11\Setup Utility\setup.bin
    DMP 2011/08/19 08:18:54 version: 11.0.15
    DMP 2011/08/19 08:18:54 PDA driver not available
    DMP 2011/08/19 08:18:54 PDA driver not available
    DMP 2011/08/19 08:18:54 HttpDownloader::downloading
    ERR 2011/08/19 08:19:37 HttpDownloader:HTTP request failed
    ERR 2011/08/19 08:19:37 MsgBox::critical:"HTTP request failed"
    ERR 2011/08/19 08:19:37 HttpDownloader:Nelze stáhnout po?adované informace.[HTTP request failed]
    ERR 2011/08/19 08:19:37 MsgBox::critical:"Nelze stáhnout po?adované informace.[HTTP request failed]"
    ERR 2011/08/19 08:19:49 MsgBox::critical:"Chyba p?i stahování aktuálních serverových dat."
    ERR 2011/08/19 08:19:50 dcfUrlArrived failed: url =
    DMP 2011/08/19 08:19:50 RcfReader: failed to open C:\Documents and Settings\All Users\Data aplikací\MapFactor\SetupUtility\regions.dcf

    On second computer I have another problem: After some upgrade disappear menu item Trace? (in czech Cesta) from main menu and from settings too.
  • It works now!

  • Solutions for me:

    1. "HTTP request failed" disappears after proxy setting. But it neads before to copy the file regions.dcf to expected place, without this I had no access to Configure button.

    2. Lost menu item returns back after delete of file settings.xml corrupted in upgrade process. Of cours, all my settings was lost, but pleasure from my lost button was much big.

    Thnx to Mr. Dlouhy for email help. Especially for info about "tunnel navigation" in Navigator11 - it should be work with OSM after importing this flag from OSM in next release, with commercial maps works long ago
  • I get the message ''HTTP request failed'.

    If I try this url (from setup.log), I get a login window (code+password).



  • Same problem here today (13.Dec.2011). Downloaded the setup utility, installed on XP machine. When I run the Setup, it shows "HTTP request failed". After pressing OK button, I get "Failed to download current server data", press OK again and it crashes (setup.bin has encountered a problem and needs to close".
  • Do you use proxy for connection to the Internet? If yes, could you try newer version of setup utility?
    p.s. when you are asked for the key select "use free version"
  • Yes, I use proxy. With the newer version, I still get the error "HTTP request failed" after selecting "use free version".

    I'll try at home.



  • But it does not crash, right? Go to settings and set-up your proxy parameters. It should work - if not, please let me know.
  • That works at home. So, no problem anymore with the installation.
    But I have a few other questions... I'll create them elsewhere in the forum.
  • Windows 7, downloaded normally, all OK,    but, after the first time, the program opens in Arabic???????
    of course I dont read it. How can I reconfigurate it if I dont know in what page I am?
    Thank you
  • Default is "system default" which is probably not Arabic in your case. Maybe accidental click (?).
    You can
    1) download the manual and follow the icons
    2) "Reset to Default" and start from scratch
    3) edit settings.xml file in C:\Users\<user>\AppData\Roaming\Navigator\11.0\ folder

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion