Never seen in 8 years : MFN app (7.3.32 and 7.3.48) now crashes my whole phone
  • Hello !

    I'm a userof the Mapfactor Navigator app on different phones since about 8 years.
    Since about 3 years, I installed it on a Redmi Notes 8 with 3 Gb RAM and 32 GB ROM.
    When I go in the "about" section of MSN it says :
    7.3.48 arm64-v8a (1.0 GB/2.6 GB free)
    I allways had problems (not only on this phone) with MFN becoming slow(er) after 3 or 4 hours of use, but well it didn't stop to work.
    Since V 7.3.32 it got worse, and it's the same with V 7.3.48 : now MFN freezes after some hours (no possibility to quit), and minutes later the phone reboots...

    I like this app very much, but I must admit that I'm loosing ma patience...
    If it gets not better I think I will change for Kurviger, even when it costs something.

    Ich benutze MFN seit etwa 8 Jahren auf verschiedenen Handys.
    Aktuell habe ich einen Redmi Notes 8 mit 3 Gb RAM und 32 GB ROM.
    Die "about" Sektion von MSN sagt :
    7.3.48 arm64-v8a (1.0 GB/2.6 GB free)
    Seit jeher hab ich das Problem dass MFN nach ein paar Stunden langsamer wird, aber bis jetzt ging es noch.
    Aber seit V 7.3.32, und auch mit der 7.3.48 ist es noch schlimmer geworden.
    Nach ein paar Stunden blockiert MFN total, und es ist nicht einmal mehr möglich das Program zu verlassen.
    Und wenige Minuten später resetet sich das Handy...

    Ich liebe MFN, aber ich muss zugeben dass ich so langsam meine Gedud verliere.
    Ich denke schon ernsthaft nach Kurviger umzuweckseln, auch wenn es etwas kostet...

    Roland aus Frankreich

  • 12 Comments sorted by
  • hi, please send logs from settings advanced and include detailed description
  • As for detailled description look at this post :

    Since this post (version changed from 7.3.32 to 7.3.48 but is this the reason ?) it's worse.
    The audio stuters a lot (it allways was OK before), and as said previously at one point the app freezes totally and the Handy becomes unresponsive, until it resets (about 1 to 2 minutes between the app freezing and the Handy reseting)


  • well,, in one of these logs route is constantly being calculated, around 1,000 times
    not sure what the problem is, possibly your GPS, but it could be something else

    first thing I would suggest is to make backup to Play (or user defined folder)
    then reset to default in settings/advanced

    then try again without restoring backed up files
  • Thanks for the reply Tomas.

    I think the file you speak about is "navigator_231011_123859.log.txt" with more than 1 MB in size, the day and time in fact corresponds to the moment MFN crashed yesterday.
    I don't know if it can help, but here is the gpx file I was following yesterday :'autome.gpx

    I will try your solution the next time I make a bike tour.

  • My crashes are happening within 10 minutes while planning a route on all my phones and tabs. MFN first slows down remarkably and then freezes the whole system.
  • I have been running your route in simulation for 40 minutes without problem

    try what I suggested earlier
  • "I have been running your route in simulation for 40 minutes without problem"
    Some people have this problem after hours; 40 minutes are not enough. And maybe simulating the route is not enough because it also has to do with the GPS or other things.

    I went on a bigger tour in 2016 and encountered this error as well. I had to restart the smartphone several times.
  • it is still running, no problem after 3 hours

  • As I already wrote in, I have the same problem. I tried versions up to 7.3.17 and had no problems, from 7.3.42 on it's crashing my Google Nexus 7, while on a Xiaomi Mi A1 all versions work.

    I use them side by side on a motorbike, the tablet only displays the route on the map, routing itself only happens on the phone. Because the Nexus calculates the route only once after starting the app in my opinion the problem should not have to do anything with route calculation.
  • you need to send logs, then we may be able to help

  • just finishedsimulating your 6h trip without problem
    I also tried to skip waypoint and all worked fine

    but, of course, simulation is not navigation, for that I would need you to record NMEA

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion