No more access to data-folder??? (Android 11+12)
  • Hallo,

    I have a new (used) Pixel 3a. Its my first "unrooted" Android.
    I cant find the "data-Folder" for the Mapdata. The 3a has only an internal storage.
    In /storage/emulated/0/android/data/com.mapfactor.navigator/files is nothing:

    The access to other folders works fine (i.e. Locus maps):

    Download of mapdata works fine, but WHERE are the data? (because I want to copy my individual ocm-files in)


  • 47 Comments sorted by
  • android/data/com.mapfactor.navigator/files/navigator/data

  • YES, "android/data/com.mapfactor.navigator/files/navigator/data" is the folder on my old, rootet Android7-Device.

    As I already said: There are no (visible) Data. "Files" is an empty folder

    I think there is a problem with access-rights in MF (better: the moment while installation, when the folders are created)! In other programm-folders (like LocusMaps) I have FULL right to read and write.

    Without the possibility of using self-created favorites or mca-files, MF is almost useless for me.
  • please send logs from settings/advanced, then we can give you exact location
  • Here is one line from the logs, where a folder is mentioned:

    2021-12-29 20:09:21: File greece_osm.mca download succeeded to /data/user/0/com.mapfactor.navigator/files/navigator/data, stored version: -1, server version: 202112140, download time: 30 secs

    In Android 11+12 Users without root dont have access to these files. So please program MF so, that the files will be stored in android/data/com.mapfactor.navigator/!
  • even no chance with ADB-Debugging

    And there will be more people having this problem....
  • developers cannot install anywhere else then Google dictates, it would not pass Google check
  • Maybe you can call the developers from LocusMaps. THEY have the skills to do that.... (see my screenshot above)

    android/data/.... is possible!

    Locus chooses android/data/ with full access for users.

    MF choose /data/user/0/com.mapfactor.navigator/files/navigator/data. I dont know why...
  • I think Locus was installed before changes to Android, I also have Navigator Pro in accessible folder, but not the standard version, which I uninstalled and reinstalled

    I have Android 9 and thought I would be safe to access installation folder - unfortunately I uninstalled Navigator and installed again, it went to /data/user/0/com.mapfactor.navigator/files/navigator/data

    strangely I have not upgraded Android for 8 months!!!

    and I tried to install Navigator 4, 5, 6 and 7 - all went to folder data/user/0/com.mapfactor.navigator/files/navigator/data
  • I installed both, Locus and MFN, today on a plain, factory-reset-device!

    Locus-developers programmed to use the "android/data/"-folder, So, it is possible. MF had just to programm it "right".

    For me, the great advantage of MF was, that I could create OWN mca files (for travel). If that is no longer possible, I have to say unfortunately "bye navigator"
  • PS: If MF dont have the "skills" to programm this user-friendly, then MF should at least provide an internal "file browser" in the navigator, with which one has access to the data directory!
  • well, not sure how you managed that
    I just installed Locus and it is in folder which I cannot access
  • Is it in folder "android/data/" with no access? Then you can use X-Plore,then its possible
  • Another tipp: you can choose in locus-settings the folder. So you can select here an accessable folder
  • I can see all when I select private folder, I will ask developers
  • I have now tried to at least take over the "settings" from my old mobile phone (favorites, vehicle profiles, ...). I was able to create a backup in GoogleDrive with my old mobile phone (it can then also be selected for restoring on THIS mobile phone).

    On the NEW mobile phone the message "Download of the backup files not available" appears. When I choose "Backup" on the new mobile phone, "Backup created on GoogleDrive" and then "Cannot create a backup folder" comes up.

    Internet connection exists, Google account has been set up.

    When I log in GoogleDrive I cant see MF-Backups anywhere - Sorry, I'm really "pissed" now

  • one way to do it is to move Navigator to SD, insert SD in PC, backup your files and then you can move Navigator back
  • Google Pixel-Phones have no SD-card. Just an "built-in-memory". So this is NOT a solution
  • you can use USB stick
  • I don't think you understood the problem.

    What exactly should I do with the USB stick? OTG? OK, I can READ files from USB stick via OTG. And then? Where to PASTE in the files? The User of Android 11 + 12 has no write access to the directory used for navigator by MF!

    AGAIN: There is only ONE thing that the developers of MFN has to do: Built in a function, to select the data- and setting-folder MANUALLY within the app. So everybody could choose an folder with write-permissions. And dont say "thats not possible". In LocusMaps it is!
  • PS: And what could be the problem with "Download of the backup files not available" respectively "Cannot create a backup folder".
    GoogleDrive is currently the only chance for me to use MFN.
  • open Navigator and go to settings > Map manager
    move Navigator to USB
    close Navigator and copy your .mca files and favourites... to USB
    then insert open Navigator again and move Navigator back to internal storage

    it worked for everybody as far as I know
  • No, dont work. See screenshot:

    USB-Device is available:

  • So, I've now installed OSMAnd. "Lo and behold", they too manage to save all data in accessible directories.
    The problem with switching to a different software is always the "familiarization phase". But once you've done that, a return is unlikely ... Bye bye
  • I don't know why it does not work for you, but I do not have Android 12 to test

    as to Locus and Osmand - developers think that they use old API, which will at some point expire and they will be forced to use new one, meaning that folders will not be accessible

    good news is, that we will do something about it, so please be patient
  • "good news is, that we will do something about it, so please be patient"

    Thanx for this. But the "clock is ticking" :)
  • Hoping my old Device will working along time. The first senseless changes was the No access to the SD-Card. Developers found solutions for this problem. No Access for config folders for users seems to be a new Android-Feature. This is in my eyes a senseless Feature. Synchronization with the PC should work. Synchronization should just work with the map explorer and the map explorer should also be better sometimes.
    But i will be patient.
  • A little hint: with the "stock-explorer" you can actually not get into the directory amdroid/data (what tomas said!) , but if you use the X-Plore you have access. I use this app for many years so it I dont recognized that.
    So, if Navigator uses the android/data folder again, everything is OK (with a special file browser)
  • Important is the access via MTP and synchronisation with the PC. Moving Files with the Taschenrechner is nothing for me.
  • I have since bought Osmand. The route calculation is painfully slow. But it has many advantages and functions and can (at least for me) replace Navigator and Locus maps.

    AND: access to all data-folders
  • Search in the archives for my modified routing templates for OsmAnd based on midifications of the heuristic coefficient. They are 3 - 20 times faster and can be used for distances over 1500 km.
    Note though that not one single Nav app is as fast as MNF Navigator. Only a few OSRM apps are that fast but these are less flexible when it comes to using other profiles.
  • Thank you. I will check this
  • So, still no solution after 3 months.  :-q
    But I've since familiarized myself with OSMand (which is not easy because it's very complex and extensive, but also a bit too convoluted).

    So far I have used Mapfactor for pure (car) navigation. For hiking, cycling and POI management LocusMaps. OSMAnd joins (for me) both apps in one! In contrast to MF, you can also navigate perfectly by bike, on foot or even by boat(!). You can configure your own map views for each navigation type. Map updates in the Pro version even hourly(!).

    You can also create the map material completely yourself. The interaction of routing and POIs is much better than with MF ("POIS along the route"). Nice (surprising) features, such as being asked at the end of the navigation if you want to look for a parking space.

    In short: I am thrilled.
    I leave MF as a backup on the phone. But I will probably hardly use it anymore

  • It works not, the config files are hidden. GPS tracks hidden. Config from PC was moved to a unused folder!!!!
  • Config from PC was moved to a unused folder!!!! Nothing is good! Files are hidden! And now? How to use my GPS Tracks? How to use Routes which made with the PC? This is no solution.
  • When MF cant say "its your fault" or "you have a faulty SD-card" then is silence here..... I dont like MF's attitude towards the users...
    I was a really big fan of navigator for many years. But app & support getting worse with every update...
  • please ask Google why they started protecting folders
  • No, I ask MF why they are not able within >3 months to switch to another ("unprotected") folder (like LocusMaps do, Like OSMAnd do, ...)
  • it has already been done, you can choose backup folder in settings/advanced/backup
  • Who speaks about backupfolder? I create my own mca-files. But now I dont have access to "feed" navigator with it. Same with other individual files (Sound, Profiles and so on)
  • import of mca files was introduced in v 7.1.37
  • OK, didnt recognize this. That would help a lot if I will MF as Backup
  • Trying to use a new device. Installed MF successfully, but now need maps. Tried several times to download a map through the app, but the Internet connection is poor in my current location, so it always falls. Now trying to copy a map from old device to new, without success. I've read this whole thread.

    I've moved the backup folder to a new location, but the backup options do not include maps.

    I've installed x-plorer, but have no success granting permissions to the appropriate folder. According to its documentation, everything is locked down.

    It's there any way to copy maps from one device to another? I did this regularly using Windows as an intermediary several years ago, but I am completely stumped with this current MF version and current Android.
  • please use import feature in settings/map manager
  • Thanks, but I can't find a corresponding Export function so I can save the map file from the device where it has already been downloaded? The only backup options I can see are for Settings, not for actual maps.
  • I wrote Import in settings/map manager
    I understood that map files are accessible on your old device
  • I can use the maps with MF on the old device, but I have no other access to them. Does MF have any ability to copy them into a non protected folder? Alternatively, are you aware of any app that will allow me to browse into the folder where they are stored so I can copy them myself? The old device is android 13.
  • you would need to move Navigator to SD in settings/map manager
    folders in SD are accessible

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion