MapFactor Navigator crash during driving
  • the MapFactor Navigator, free version 5.5.35 (2019) is used on a Galaxy S9 smartphone with newest android version and most recent maps (freeMap,Germany, updated). Unfortunately, the Navigator crashes sometimes during the journey out of unknown reasons, despite continued power- and GPS supply.  The crash is complete, i.e. the Navigator times out at once, without prior warning and has to be started again with the same data. The crash is not related to specific regions, maps or time, but can happen everywhere and at any time.

    Such a crash can be dangerous if it occurs in traffic stress situations when you do not know where to go!
    Could anybody help?
  • 16 Comments sorted by
  • thanks for the rapid response. I deinstalled the old version and installed the new one recommended (see your link) on my smartphone. The version downloaded is: 5.5.66 arm64-v8a (1.4 GB/3.5GB). However, this version does not function on my Galaxy S9, android 9. Each time I want to start it, it takes about 5 minutes before the menu-screen has been loaded. Uploading of free maps is not possible either. I retried the whole process several times in vain. Possibly the version recommended is one for a 64bit computer?
  • it is for both, 64bit and 32bit
    please send logs (settings/advanced) with detailed description
  • because the 5.5.66 version did not work with my Galaxy S9, I re-installed the most recent version available in google play store, i.e. 5.5.35. The 17 logs available - that apparently refer to both versions -  I'll send per e-mail to andrid-log@mapfactor.c...because they are presumably to big to post it here. Is that o.k.?

  • I have MFN running both on SD card in a s5 and a s9+. No problems at all. If You have MFN also pushed to SD, my first thought is that the card might be defective.
  • I tried to outsource the MFN free-maps to external SD-card in vain several times. The error message being that there exist already MFN maps on that card (whicht is true), and whether this should be overwritten. If I agree, MFN overwrites the maps on the SD-card (which takes quite a while) but MFN and maps nevertheless remain on the internal S9 phone. I tried the same process three times in vain. All files of other programs on the external SD-card function without problems. MFN runs nevertheless on the S9 phone in principle, but with the above named problem of unexpected crashes during driving.
  • please send logs by email
  • I have sent the logs already by e-mail to android-log@mapfactor.c ... this morning at 10:04h  (see above), didn't you get it?
  • If You push MFN to SD via android, this will produce well known errors. You have to do it with the appropriate option in the settings of MFN instead. If the appearing dialogue prompts You an existing installation might be overwritten then choose yes and download Your cards again via wifi if necessary, who cares?
  • sorry, but I only used the appropriate MFN menues for trying to outsource the maps to my SD-card. Formerly, with my old Galaxy S3 that worked fine without problems, now with the new S9, I encountered the above named problems, i.e. MFN overwrites the SD-card maps but sticks afterwards nevertheless to the internal phone storage.
  • Ok, in principle it will function, best prove is my installation, also on a s9+. So, next step, clear data and cache. Otherwise, I really do think something's going wrong with your sd.
  • just sent logs once more by e-mail to same address, including short description of problem. Hopefully, this time the mail goes through. If yes, please confirm receipt.
  • no, we have not received logs from you
  • Hello Dirk,
    I think the S9 will habe Android 9 installed?
    A few months ago I got the hint from support, that there is an Android 9 problem in Navigator. After nearly one hour oft navigation the programm will close without any message in screen.
    Is it the same Problem you have?
    @Tomas: when do you think the Android 9 problem is solved? Perhaps you have an Beta Version vor us?
  • it hass already benn solved, please update Navigator

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion