skipping waypoints, response time
  • phone: samsung trend plus with lineage 13 no gapps and removed all unnecessary apps
    mapfactor: version 4.0.48

    Skipping a wayppoint in a route works but is very slow. This is what I do:
    1. Tap the screen to show the menu on the bottom of the screen.
    2. Tap the 'skip waypoints' icon. Then the message 'Calculating route  Please wait' appears. So I know the waypoint is skipped
    When I just started a route this works as expected. The response time is good.

    But when I have driven a while the response time is long, very long.
    When I tap the screen I have to wait a very long time before the menu on the bottom of the screen appears.
    Then after I tapped the 'skip waypoints' icon I have to wait a long time again before I see the message 'Calculating route  Please wait'.
    I noticed this behaviour the first time with version 3.0.25. 

    I would like to get rid of this waiting period after tapping. A tiny lag is no problem but a lag of 20-30 seconds is very annoying. Can this be fixed????????

  • 9 Comments sorted by
  • knibja.

    Your problem is already solved!
    The same day I left for france  and checked this deletion of waypoints. 2.5 week later I needed
    to delete a waypoint because of roadworks and try to delete it.And what happened?
    You don't believe it . I set a new random waypoint. At first I did not notice what had happened,.
    I got the most crazy instructions. Then my wive discouvered what had happened,
    The old-fashioned navigation with our paper maps took us to a point to reset the MFN navigation.
    You tell me how you like a FUNDAMENTAL change of the program without prior notice.
    IMHO the old way of deleting a waypoint is the most safe way of doing it. You need hardly to look
    on the screen when you use a button(or 4) on the corner of the screen. Look what the 
    motorbike guys wrote about it.
    Let me stop here before I get furious again!!!!

  • The problem is not solved and it is not slowdown of the waypoint deletions only but general slowdown of whole app (probably caused by too many running threads). We are aware of it but we cannot reproduce it on the debugger.
  • Of course, the problem is not solved. But I thought it was clear that it will not happen
    again because this way of deleting a waypoint is removed and changed to creating a waypoint!
  • skipping a waypoint is only possible when you are navigating a route.
    creating a waypoint is only possible when you are not navigating a route.

    Is this behaviour changed since 4.0.48???

  • What I wrote on July 15 happened on June 17 about 11.00 o'clock in the neighbourhood
    of Sarlat (Dordogne). Navigator version 3.1.120. I was navigating a route home!
    Maybe you can think of an other reason why I had this happened.

    A total different point.
    Why changed my comment of July 16 to bold ? It happened before.
    Very annoying!

  • I agree 100% with @mes . Its very frustrating having to wait or keep taping the screen not knowing whether the 1st tap was accepted or not.  I have made 4 of the panels "skip  waypoint" to make it easier to click on (being on a motorcycle) as none of my suggestions were accepted - at least make the response quicker.

    These are the annoyances that spoil a very good product. Please note that the majority of motorcyclists use waypoints more than other users and we have more physical restrictions in using the device,
  • I made all the 8 panels "skip waypoint". it is the only panel I need on my motorcycle trips.
    The waiting is frustating but it is also easy to make mistakes. When I keep my finger too long on the panel I get the menu in which I can change the action of the panel.

    I allready asked this before but I would like to see a permanent clickable icon on the screen to skip the next waypoint. This icon should only be visible while navigating a route with multiple waypoints and there should be no difference in short or long presssing the icon. 

    At this moment I quit the app completely when I have a break on my trip. So I have to start the app and the navigation again when I start driving again.
  • As I said, we are not able to fix it because we do not know where exactly the problem is. You can help us by reporting the problem this way:
    1) let the app show dialog "The app is not responding"
    2) press close the app in the dialog
    3) open Navigator again, open settings, advanced, send logs
    4) write into message "Freezing of the app, please forward it to Lubos"
    5) send it

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion