[Bug] and [Request]: Google Voice search no longer works; Add OK Google to Mapfactor Navigator
  • [BUG]
    Mapfactor has/had Google search in the search options. You tapped the microphone and said something like "Štefánikova 24 Praha" and got that location. Currently in 4.0.37 (and earlier?) that doesn't work anymore. Not for "Prefer Google", not for "Prefer Mapfactor". Please fix as I find that quite useful.

    Once the Google Voice Search has been repaired :), please add "OK Google" as well to Navigator. I used Android Auto for one afternoon and it is simply great to say "OK Google", "Navigate to Štefánikova 24, Praha" and get the route and directions (in this mail in English, but I actually said it in Dutch with different destinations).

    Edit: Please note that I tested on my phone with other applications as well, including the Google Apps. In those apps both GoogleVoiceSearch as well as OK Google work fine.
  • 9 Comments sorted by
  • Oh, that's good, MFN voice search doesn't work at all on my S5 no matter which of the 3 search options I choose.
  • Hi, I fixed the voice search bug (it will be in 4.0.40+).

    About "OK Google" (or new "Hey Google"), I am somehow sceptic because the voice recognition of towns is very often incorrect and the search engine mostly receive more items and it is not always correct to select the first item...
  • Thanks for fixing the google voice search. 

    Not many apps have the OK Google or new Hey Google, but mapfactor has such a good programmer, I just thought I ask it ;)
  • Maybe later when Google's AI improvements make voice recognition better.

    Last time I tried voice search for "Praha" (Prague) and Google voice recognition gave me "Haha" as the result.
  • I encounter something weird.
    Every first time I say something it wants me to speak again.
    And then every second time it does recognize my POI or address.
    Any idea?
  • I will take a look on it next monday
  • I will do some more testing. Today I used it again, but was distracted and after 30 seconds or so, the command was executed after all. It seems as it needs some time to start "something" in the background.
    However, the foreground is immediately back which seems as if the command was not functioning. Is this search some AsyncTask being executed?
    When I did the same again, simply waiting after having given the command, it did indeed work.
  • It is Android Intent with result, after requesting it, it is called on Navigator activity onPause. After finishing it there is called onActivityResult on Navigator's activity and we read from it the text.

    I was not able to reproduce the problem but I hope that I fixed it. The change will be in 4.0.44+.
  • It is working fine.If I say something to Google Now it reacts immediately. In Navigator it just takes a bit longer. As I'm a very impatient person :) I considered it a bug.But again: it is working fine.
    Currently on the 4.0.45

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion