Anomaly with chinese 2Din with Windows CE 6.0
  • I have recently bought a chinese navi made by unknown brand for my Suzuki Jimny.
    For some reason the sd card with the software navigation is corrupted and it doesn't work.
    However, even if it has worked well, I would prefer to use opensource maps, simply because they are much better.
    Bearing that in mind, I started looking in internet for a software that uses OSM on Windows CE6.0 and eventually I came across MAP FACTOR.

    After having read all the features it has, I downloaded the software and the map on a SD card, put it in the NAV, selected the port and the Bould, and finally it appears working perfect. Actually it does, until I switch the screen to something else. Once I go, for instance to the radio screen, I cannot go back to the navi, it doesn't work anymore. To make it work again I have to take out the SD card and start the process again.
    Does somebody address me to solve this problem?
  • 2 Comments sorted by
  • Sorry to give you the bad news but Mapfactor does not work well with wince 2din devices.
    I had the same problem and tried all possible ways to make it work and also in 10 different devices but with no luck.
    I tried every single solution that the forum members gave me but ended up with the same problem all the time.

    It is very sad because this really is probably the best navigation software out there.
  • I would think this is problem with your operating system, which probably shuts SD when not in use

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion