Newest Mapfactor not win10 compatible ?
  • My Mapfactor program says, there are some updates available, but first i need to update the program self and then restart. It downloads the update file... nothing happens... when i then try to check for updates it says i need to restart MF, when i restart it the whole thing begins from "there are some updates"...

    so i've tried to download a new version MF setup from developer and when i run it my windows says this program cann't be run it's not compatible...

  • 2 Comments sorted by
  • Same problem here too.
  • It’s the same thing with every version change since I installed MFN for the first time - the update procedure on PC never works without manual intervention.

    My solution this time (17.0 to 17.1):

    1) Before starting the MFN Setup I deleted the files "xxxxx\Install\setup_pc_navigator.exe"  and "xxxxx\Setup\setup.dat" (xxxxx ist the folder where the downloadable content is stored).
    2) After restarting the setup utility I first called „Product updates“ and installed the setup utility.
    3) After the next start of the setup utility I went to „Install application“ – „Install PC Navigator“ which starts the setup procedure
    4) After successfull installation I reapplied all my personal configuration changes
    5) Manually deleted the folder „C:\ProgramData\Navigator\17.0“

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion