Importing POIs with Digger
  • I am having trouble getting diggerQt.exe to work for me. I also see a program called DiggerConsole.exe but it just flashes open and closes in about a microsecond. Using digger_12_2. Is that the latest?

    Some problems may relate to the input file formats, I have tried gpx and csv with no success.

    If I select icon, I get to the page Object Definition. In the manual that page shows a box for selecting a file with a png icon, but I do not have that at all. It seems to not know where to look for the icon and shows me a default with ? and test style. However, the Next >  button is grayed out. Is there a place to enter the icon location?

    If I select mark, it goes further but always results in my Data all being banned - whatever that means.

    The log shows the exception.

    ERR 2016/12/19 12:17:29 Exception thrown: .\src\Importer.cpp(214)
    ERR 2016/12/19 12:17:29 Exception std::exception& ex caught: .\src\Importer.cpp(150) message:'mapFactor exception: All data was banned, cannot finish import.'

    An example file of working data would let me change the csv or gpx to match a template and I could work with that if it is a data problem.

    Meanwhile, I can put data into favourites.xml, but the program sorts them alphabetically which is not very useful when there are a lot of POIs. Also, I don't see a way to show them on the map other than one by one. It would be OK if they would all show. Or, if I could sort them by distance from me or some other arbitrary point. 
  • 5 Comments sorted by
  • probably because Navigator is not installed on your PC
    you will need to select your own icon
  • Navigator is installed. I thought that myself.

    Maybe I need to put Navigator in a different location on the PC?
  • Where do I select the icon?
  • double click in box under Style, then on path next to file name, then ...
  • Bingo!

    Thank you. I have been looking all over the forum for that tip!

    Just never thought of clicking in there. It looked like it was showing details not expecting input.

    Worked perfectly now - mca file generated and works on the Android app.

    Thanks, Tomas!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion