TCP/IP connection working - question on sending messages
  • Having tested TCP/IP with telnet(putty) and "socket test 3" apps on a windows 7 PC - I'm happy with the general functionality, and I can send and receive data as expected.

    I'm now trying to integrate the TCP into my Home Automation solution - Housebot (used in my campervan).
    • I can send chat message from Navigator to Housebot (and Housebot works as expected) - proving the connection works (on various sockets).
    • When I send a command such as $software_version  - Housebot TCP/IP socket logs the message as sent 
    BUT - Navigator does not respond to any messages such as $software_version, $maximize, $last_position, etc

    I've tried \n and \r\n as terminators. Still nothing. I've tested the commands using the socket tester, and the messages are clear and as typed.

    Is there anything else I can try (known protocols and terminator characters) in your experience to get these messages into Navigator. (I've tried my paid v14 and my development v15 free versions).

    Many thanks!
  • 1 Comment sorted by

    Used 0D0A (HEX) as the command terminator. There may not be another user of Housebot who uses Navigator, but it's worth bearing in mind for other TCP/IP integration projects....

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion