[SOLVED] Mapfactor bugs with shared location (Geo Intent). Android JB 4.1.2
  • UPDATE: Version 1.4+ has fixed this bug. For previous versions there's a proposed solution below in this thread using a google maps url with the daddr parameter as URI data.

    • In my case I use the app Easy Navigation to storage new destinations and of course I have set Mapfactor as my default navigator for the car. Then after tapping over a chosen location, the coordinates are shared with Mapfactor which automatically opens and shows the next option menu:

    • The bug happens when applying any of the three "Set" options inside the red area above (set as departure, waypoint, destination) as immediately after Mapfactor freezes and stops (next image). Which means that a shared location can not be set as destination and therefor the "Navigate" option doesn't work correctly.

    I should remark that the same error happens with other apps trying to open a share location with Mapfactor (e.g. Geo PlacesHere I Am!) 

    Phone specs:
    Android JB 4.1.2
    Samsung galaxy S Advance and S2 with stock ROM.
    Rooted: Yes
  • 16 Comments sorted by
  • Anyone there? 

    I supposed everyone is on holidays.

    I'm seriously thinking that this bug will stay forever :(
  • I do not use Clicknav, but it works from other applications, like Yelp.
  • Hi Tomas,

    It's interesting what you're saying. Actually I tried Yelp on my phone and effectively it seems working with the option "Get directions".

    Also Tripadvisor works with the same option which I think it's a clue to the problem.

    Indeed all these apps send the location coordinates to Mapfactor via URI data. For instance Yep shares the address and coordinates while Tripadvisor shares only the coordinates (as Easy Navigation does too).

    However I have no idea how to look at the exactly shared URI format and parameters that each app is sending to mapfactor.

    By the way, I wonder if there is a Mapfactor API for Android.
  • Using the app Intent Intercept I was able to catch the URI data that the above mentioned apps are sending to Mapfactor. Here's what I figured out:

    App           :    URI Data (Intent)
    Yelp                http://maps.google.com/maps?f=d&daddr=address+@Lat,Lon&doflg=ptk&navigate=yes
    Tripadvisor     http://maps.google.com/maps?daddr=Lat,Lon
    Geo Places    geo:Lat,Lon

    So Mapfactor can use the daddr parameter from the google url to retrieved successfully the location (address) and/or the positioning coordinates (Lat,Lon).

    Easy Navigation and Geo Places do something similar (sending just coordinates) but using the standard Geo URI format instead. Which means that the Geo URI Intent is not working properly without a place / address name. This bug is only found in previous versions to Mapfactor v1.4+ on Jelly Bean 4.1.2

    Conclusion: A stable solution is to send a google url as URI Data with the next suitable format : 


    where Destination Name = String with the shared location name or specific address
    Lat,Lon = Coordinates numbers in decimal degrees

    NB. (Secure Protocol) https is not supported prior to v1.4+ on all Android OS
  • I am not sure what is it you do not understand
    may be it is better to email support
  • @tomas 

    I'm just disappointed about how Mapfactor's support treats my suggestion through this forum (more than 5 months) and no official fix yet.

    I'm not a developer and still I try to figure out how to solve this bug.
  • In my opinion the team should put their efforts first on improving and completing the base navigator application (on both platforms: Win and Android) before implementing APIs for other applications which are imho of little use for the majority of Navigator users.
  • @Uli

    I would totally agree. However when you get an answer like "hopefully next week" and there's not feedback or whatsoever during 5 months, I suppose I'm not criticizing the current priorities but pointing out the lack of support in this specific case. That's all
  • Hi Luis,
    I looked through your emails and cannot find anything promising 'hopefully next week'
    I also cannot reproduce bug you are reporting as per my comment above.
    may be someone else can try it?

  • @tomas,

    So as to not get confused. It was precisely @mdx who posted that answer in the first discussion thread about this bug back in February. (see here)

    About the bug, I think that the proposed solution 6 posts above (google maps URI) is working fine. Actually I was able to test today the intent on my android phone. Of course this is nothing official but a partial solved problem.

    By the way, I should thank and give you credit for giving me the clue to the proposed solution.
  • A.m. bug does not happen to my rooted Xperia Active with ICS. All menu fields work.
  • @Oldie

    Could you please precise which app were you trying?

    The bugs that is reported (on Jelly Bean 4.1.2) with the last version of Mapfator. It happens with apps that use geo URI data to share location coordinates: Easy Navigation, Geo Places and Here I am.

    Other apps like Yelp and Tripadvisor are working fine using a google maps url.

    However it might be a bug that occurs with some versions of Android. So it is always useful to have others experience.
  • I used Clicknav.
  • @Oldie

    Thanks for your feedback
  • UPDATE: Version 1.4+ has fixed this bug. For previous versions there's a proposed solution in this thread using a google maps url with the daddr parameter as URI data.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion